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RoadRunner Product Description
Design 3D scenes for automated driving simulation

RoadRunner is an interactive editor that lets you design 3D scenes for simulating and testing
automated driving systems. You can customize roadway scenes by creating region-specific road signs
and markings. You can insert signs, signals, guardrails, and road damage, as well as foliage,
buildings, and other 3D models. RoadRunner provides tools for setting and configuring traffic signal
timing, phases, and vehicle paths at intersections.

RoadRunner supports the visualization of lidar point cloud, aerial imagery, and GIS data. You can
import and export road networks using OpenDRIVE®. 3D scenes built with RoadRunner can be
exported in FBX®, glTF™, OpenFlight, OpenSceneGraph, OBJ, and USD formats. The exported scenes
can be used in automated driving simulators and game engines, including CARLA, VIRES VTD,
NVIDIA DRIVE Sim®, LGSVL, Baidu Apollo®, Unity®, and Unreal Engine®.

RoadRunner Asset Library lets you quickly populate your 3D scenes with a large set of realistic and
visually consistent 3D models.
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RoadRunner System Requirements
RoadRunner is an interactive editor that lets you design 3D scenes for simulating and testing
automated driving systems. Before you install RoadRunner, check that your system meets these
required specifications.

Specification Recommended Minimum Requirement
Operating System Windows®: Windows 10 x64

Linux®: Ubuntu® 16.04+

Windows: Windows 10 x64

Linux: Ubuntu 16.04
CPU Intel® or AMD® x86-64

processor with four logical cores
operating at 3.5 GHz or higher

Intel or AMD x86-64 processor
operating at 2.5 GHz or higher

Memory 16 GB 8 GB
Video Card NVIDIA® GTX 1060 3 GB OpenGL® 3.2-compatible with 1

GB VRAM
Disk SSD hard drive 2 GB available disk space

For more details on graphics card requirements and support with graphics issues, see “Graphics and
Startup Issues” on page 8-2.

See Also

More About
• “Install and Activate RoadRunner” on page 1-4
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Install and Activate RoadRunner
RoadRunner is an interactive editor that lets you design 3D scenes for simulating and testing
automated driving systems.

The procedures in this topic are for a single RoadRunner computer installation or update/upgrade on
Windows or Linux. These procedures can be performed by an individual license holder or by an end
user or administrator with a network license.

Follow these procedures to install RoadRunner for the first time, update an installed release of
RoadRunner, or upgrade an installed release of RoadRunner to a new release.

Network License Administrators Before you or your end users install RoadRunner, perform the
following tasks:

• Install the network license manager. See “Install or Update Network License Manager for
RoadRunner” on page 1-11.

• Download the network license file and the platform-specific product installer and save them to
removable media or a network location. You will need to give these items to your end users for
them to install on their own computers.

Verify System Requirements
Before you install RoadRunner, check that your system meets these required specifications.

Specification Recommended Minimum Requirement
Operating System Windows: Windows 10 x64

Linux: Ubuntu 16.04+

Windows: Windows 10 x64

Linux: Ubuntu 16.04
CPU Intel or AMD x86-64 processor

with four logical cores operating
at 3.5 GHz or higher

Intel or AMD x86-64 processor
operating at 2.5 GHz or higher

Memory 16 GB 8 GB
Video Card NVIDIA GTX 1060 3 GB OpenGL 3.2-compatible with 1

GB VRAM
Disk SSD hard drive 2 GB available disk space

Get License and Product Installer
Use an Individual License

Get your RoadRunner license by following these steps.

1 Go to the License Center on the MathWorks® website.

If prompted, sign in to your MathWorks Account.
2 Click the RoadRunner license in your account.

1 Get Started with RoadRunner
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3 On the Install and Activate tab, click Activate a Computer.
4 In the form displayed, enter all requested information. When finished, click Submit.
5 Download or email the license file and save it to a folder on the computer where you will install

RoadRunner.

Next, download the product installer by following these steps.

1 Sign in to your MathWorks Account on the MathWorks website.
2 Under My Software, click the down arrow next to your RoadRunner license.

This action takes you to the Downloads page where you can find the download RoadRunner link.
If you see Get Latest Release, click Download RXXXXy to get to the right page (where XXXX is
the release year and y is the a/b version; for example, R2020b).

3 Under Additional Product Downloads, click Get RXXXXy RoadRunner.
4 Download the platform-specific installer to the computer on which you want to install

RoadRunner.

Use a Network License

• End Users — Get the license file and platform-specific installer from your license administrator
and copy them to the computer where you are installing RoadRunner.

• Network/License Administrators — Give end user the platform-specific installer (or provide
access on a network share) and the modified network license. See “Step 3. Customize Network
and End User Licenses” on page 1-11 for instructions on configuring the network license for end
user access to RoadRunner software.

Install RoadRunner
For RoadRunner installation, GUI installation is available for Windows and GUI and command line
methods are available on Linux platforms. Installation instructions vary based on the platform and
method you choose.

Platform and
Installation Method

Instructions

Windows GUI 1 Double-click the downloaded product installer.
2 Follow all prompts to complete installation.

Linux GUI 1 Double-click the .deb file that you just downloaded.
2 Click Install and follow all prompts.

Linux command line 1 Open a command prompt.
2 Enter the following command, replacing release_number with the current

release number:

sudo dpkg -i RoadRunner/ release_number.deb

For example, for the R2020b release, use this command:

sudo dpkg -i RoadRunner_R2020b_glnxa64.deb
3 Follow all prompts to complete installation.
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Activate License
Before you can use RoadRunner, you must activate the license. Follow these steps to install an
individual or network RoadRunner license on your computer.

Note If you do not have a license, see “Get License and Product Installer” on page 1-4.

1 On your desktop, launch RoadRunner and follow all prompts.

• Windows — Launch RoadRunner from the shortcut on the desktop or Start Menu.
• Linux — Launch RoadRunner from the installed shortcut. To find this shortcut, click Home

and type "roadrunner" in the text field or go to "/usr/share/applications".
2 When prompted for a license file, enter the path to the license file from “Get License and Product

Installer” on page 1-4.
3 Follow any additional prompts to complete activation.

Create a New Project and Scene
After you install and activate RoadRunner, you can now create a project to get started creating
scenes.

RoadRunner uses a project folder to store the assets (materials, models, and so on) that you can use
within the application. If you do not already have an existing project, you need to create one. See the
"Create a New Project from the Start Page" section on “Project System” on page 3-22.

After following the previous instruction, RoadRunner opens to a new blank scene.
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To get started, you can use the “Road Plan Tool” on page 5-108 to create your first road. Alternatively,
use one of the other “Tools” to start creating your scene. For more on getting started, see the Getting
Started with RoadRunner video series.

If you experience rendering issues or crashes on startup, see “Graphics and Startup Issues” on page
8-2 for troubleshooting help.

See Also

Related Examples
• “Install or Update Network License Manager for RoadRunner” on page 1-11
• “Get RoadRunner Updates and Upgrades” on page 1-8
• “Graphics and Startup Issues” on page 8-2
• “User Interface”
• “Fundamentals”

External Websites
• License Center
• Getting Started with RoadRunner
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Get RoadRunner Updates and Upgrades

Update Installed Release
When an updated version of RoadRunner for your installed release is available, download the installer
again, and then rerun the installation. See “Install and Activate RoadRunner” on page 1-4.

Upgrade RoadRunner Release
To upgrade to a new release of RoadRunner, follow the steps in “Install and Activate RoadRunner” on
page 1-4.

Install RoadRunner Add-On Products
To install RoadRunner add-on products, for example, the Asset Library and RoadRunner Scene
Builder, complete the following steps.

1 Contact Sales to put the add-on product on your RoadRunner license.
2 Follow all instructions in “Install and Activate RoadRunner” on page 1-4. You must get an

updated license, download and rerun the installer to get the added products, and activate the
updated license.

See Also

Related Examples
• “Install and Activate RoadRunner” on page 1-4
• “Update RoadRunner Licenses” on page 1-9
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Update RoadRunner Licenses
If you are an individual RoadRunner user, you can download and install an updated RoadRunner
license on your computer. If you are a network license administrator, you can update the network
license for add-on products or to add users or seats to the license.

Update RoadRunner Individual License
When you get an updated license for RoadRunner, you must update the license on your computer.

To update your license, use the following procedure.

1 Go to the License Center on the MathWorks website. Sign in to your MathWorks account if
prompted.

2 Click the RoadRunner license in your account.
3 On the Install and Activate tab, under Get License File, click the down arrow next to your

RoadRunner license.
4 Enter the release for the license, and then click Continue.
5 Download or email the license file and save it to a folder on the computer where the previous

RoadRunner license was located. When you have completed this step, click Done.
6 Launch RoadRunner, and then click License to update the license on your computer.
7 When prompted for the license file, enter the path to the license file you just downloaded.
8 Follow any additional prompts to complete the updated license activation.
9 Restart RoadRunner.

Update RoadRunner Network Licenses
When you receive a new license from MathWorks because the products or seat counts have changed,
plan to update the license file on the network server at a time when users are least likely to be
accessing a RoadRunner license.

To update the license:

1 Make a copy of the existing RoadRunner network license on the license server.
2 Go to License Center on the MathWorks website. Sign in to your MathWorks Account, if

prompted.
3 On the Install and Activate tab, under Get License File, click the down arrow next to

RoadRunner Server.
4 Download or email the license file and save it to a folder on the computer where the previous

RoadRunner network license is located. When you have completed this step, click Done.
5 Stop the network license manager.
6 Open the existing license on the server and the new license in an editor. You are going to copy

most of the new license into the old license with these instructions:

a In the existing license, delete all content except the SERVER and DAEMON lines at the top of
the file.

b In the new license, copy all content starting from below the SERVER and DAEMON lines to the
end.
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c Paste the copied content into the existing license below the SERVER and DAEMON lines.
d Save the existing license. You can store the new license as a backup, remembering that the

SERVER and DAEMON lines must be replaced with those specific to your organization.
7 If you have an options file, depending on how it is configured, you might have to update it. If you

do not have an options file, skip this step.
8 Start the network license manager.
9 Have end users restart RoadRunner.

See Also

More About
• “Install or Update Network License Manager for RoadRunner” on page 1-11
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Install or Update Network License Manager for RoadRunner

Note If you are an end user on a Named Network User or Concurrent license:

These instructions are for license administrators. If you are an end user on a network license and
have been asked to install and/or activate RoadRunner yourself, follow the instructions in “Install and
Activate RoadRunner” on page 1-4.

Install and Configure Network License Manager for RoadRunner
Before You Begin

Before you or your end users install and activate RoadRunner, install a network license manager to
manage the RoadRunner network license. MathWorks uses FlexNet® Publisher (FLEXlm®), a license
manager from Flexera Software, to manage its network licenses.

Step 1. Download Network License

1 Go to the License Center on the MathWorks website.

If prompted, sign in to your MathWorks Account.
2 Select the RoadRunner license.
3 On the Install and Activate tab, click Activate to Retrieve License File. (The File Installation

Key workflow does not apply to RoadRunner network licenses.)
4 Fill out the form that is displayed and click Continue.
5 Download or email the license file and save it to a folder on the computer where you will install

RoadRunner.
6 Click Done to continue.

Step 2. Install MathWorks Network License Manager Daemons

1 If you have not already done so, install the FLEXlm license manager from Flexera Software.

If you are already running the FLEXlm license manager, you do not need to re-install it.
2 Download the MathWorks-specific license manager daemons from License Manager Files on the

MathWorks website.

Step 3. Customize Network and End User Licenses

The network license that you download from the License Center is designed to work with the network
license manager on your license server. There are two tasks associated with customizing license files.

1 Customize the network license on the server to identify the server and point to the license
manager daemon.

a Open the network license file for editing.
b The SERVER line identifies the server (host and port number). .Add a SERVER line to the top

of the license file, as follows:

SERVER host hostid port

 Install or Update Network License Manager for RoadRunner
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An example of this syntax is:

SERVER Server1 0123abcd0123 1711
c The DAEMON line identifies the name of the network license manager daemon.. Add the

DAEMON line with the name of the network license manager daemon to the next line, as
follows:

DAEMON MLM <path to MLM.exe>

An example of this syntax is:

DAEMON MLM $lmroot/etc/glnxa64/MLM

$lmroot is where you installed the network license manager.
2 Create a license file for RoadRunner installation on end user computers that points to the server

that has the network license for RoadRunner.

a Create a text file, and name it network.lic.
b From the network license file, copy the SERVER line and paste it into the new license file as

the first line. This server line specifies the host, hostID, and port of the license server and
has the following format:

SERVER host hostid port

An example of this syntax is:

SERVER Server1 0123abcd0123 1711

By copying the line rather than recreating it, you are less likely to mistype the information.
c For the second line, add:

USE_SERVER
d Save the license file.
e Put the network.lic file on the end user computer, using one of two options.

• Option 1: If the end user will be performing the activation, give the license file to them.
• Option 2: On the end user's computer, put the license file in an accessible folder and set

the "MLM_LICENSE_FILE" environment variable to specify the path to the file (or the
folder containing it).

Step 4. Configure Options File (Network Named User Licenses)

This procedure is for Network Named User licenses only. If you have a Concurrent license, setup is
complete and you can go to “Next Steps” on page 1-13.

1 “Set Up Named User Licensing” with an options file. This option file is used by the network
license manager to identify the specific named users to whom you have assigned right-to-use
privileges.

2 Make sure the DAEMON line in the license file you downloaded during network license installation
contains the correct path to the options file. See “Check the Options File”.

When you have completed this step, you have finished installing and configuring the network license
manager for use with RoadRunner.
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Next Steps

Your next step should be to install RoadRunner software on individual computers.

Note Consider first installing and activating RoadRunner on a test computer. If your test is
successful, you can start the individual installations with confidence.

You have the following options for installing RoadRunner:

• You can install and activate each installation yourself. See “Install and Activate RoadRunner” on
page 1-4 and follow all steps in the procedure.

• You can install RoadRunner on each computer but have the end user activate it. See “Install and
Activate RoadRunner” on page 1-4 and follow “Get License and Product Installer” on page 1-4 and
“Install RoadRunner” on page 1-5, leaving “Activate License” on page 1-6 for the end user. For this
workflow, you will need to let the end user know where the license is stored on their computer.

• You can have each end user perform their own installation and activation. Give each user a copy of
the network license file and the platform-specific product installer and have them follow all steps
in “Install and Activate RoadRunner” on page 1-4.

Update Network License Manager Software for RoadRunner
Installation
You must be a network license administrator to perform this procedure. Updating the network license
manager software requires you to stop and restart the license manager.

To update the network license manager software, see “Update Network License Manager Software”.
Follow the procedure for downloading the license manager daemons. There are instructions for
Windows and Linux.

See Also

More About
• “Install and Activate RoadRunner” on page 1-4
• “Update RoadRunner Network Licenses” on page 1-9
• “Network Named User License Administration”
• “Concurrent License Administration”

External Websites
• License Center
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Start Page

The Start Page is displayed when RoadRunner is launched. It lists recently opened “Scenes” on page
3-25 and provides helpful links. You can quickly load a recently saved scene by clicking on an entry
in the Recent Scenes list.

You can also create a new scene or open a scene by clicking the corresponding button.

Click the Output tab to view the “Output Panel” on page 2-25. Use this option to view more
information about scene or project load failures.
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Window Layouts
The RoadRunner UI is organized into panels. You can customize the layout of the panels to meet your
preferences by resizing the panels and moving them into different configurations. RoadRunner
preserves the window layout from session to session.

You can save and name up to five different layouts. You can restore saved layouts by using the layout
controls at the bottom of the window menu.

Switch Between Tabbed Panels

Panels can be stacked on top of each other. By default, the “Output Panel” on page 2-25 and “Library
Browser” on page 2-13 panel are tabbed.

To switch between tabbed panels, click the applicable tab at the bottom of the panel.
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Undock a Panel

You can move a panel to a separate window (for example, to move it to a different monitor) by
clicking and dragging the top of the panel. After moving a panel to a new window, you can move and
resize this panel independently from the main application.
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Dock a Panel

You can change where panels are docked in the application. This option can be useful for making
better use of screen real estate on wide monitors.

1 Click and drag the top of the panel (this action works for docked and undocked panels).
2 Hover over the edge of the application where you would like to dock the panel.

• If you hover over the edge of the application without an existing panel, the panel will be
docked to that edge.

• If you hover over the middle of another panel, the panel will be docked on top of that panel
(that is, the panels will be tabbed).

• If you hover over the left or right side of a bottom panel (or the top or bottom of a side panel),
then both panels will be displayed next to each other.

Save the Current Window Layout
1 Select the Window > Save Layout menu option. A dialog box prompts you to name the layout. If

you already have five layouts saved, saving another layout will replace the oldest saved layout.
2 Type in the desired name of the layout. If you type in the name of an existing layout, the new

layout will replace that existing layout.
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Restore a Saved Window Layout
Select the Window > Apply Layout > (layout) menu option, where (layout) is the name of the
layout you want to restore.

Delete a Saved Window Layout
Select the Window > Delete Layout > (layout) menu option, where (layout) is the name of the
layout you want to delete.

Reset the Window Layout to the Default Layout
Select the Window > Reset Layout menu option.
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Title Bar

The Title Bar displays this information:

• The name of the current scene ("New Scene" in this figure)
• The name of the current project ("Sample Project" in this figure)
• The RoadRunner version number (R2020b in the figure)

The exact appearance of the Title Bar can vary based on the operating system.

 Title Bar
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Menu Bar

The Menu Bar provides assorted editing and viewing operations. The Menu Bar includes these top-
level menus:

• File: Open and save scenes, change projects, export scenes, and perform other core scene
operations.

• Edit: Undo, redo, delete, and other editing operations.
• View: Display modes, camera settings.
• Tools: Global scene tools and settings.
• Assets: Asset creation and operations. Also available in the right-click context menu of the

“Library Browser” on page 2-13.
• Window: User interface panels, layout controls (see “Window Layouts” on page 2-3).
• Help: Helpful links, including documentation and the About dialog box.
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Tool Bar

The Tool Bar is used to select the current editing tool. The current tool determines what you can
interactively select and edit within the “3D Edit Window” on page 2-11.

Refer to the “Tools” page for documentation of all RoadRunner tools.

Change the Current Tool
Click the desired tool button on the Tool Bar.

Certain actions automatically change the active tool. For example, dragging certain types of assets
from the “Library Browser” on page 2-13 into the scene adds that asset to the scene and
automatically switch to an appropriate tool for that asset.

 Tool Bar
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Sub-Tool Bar

This context-sensitive vertical bar displays additional operation buttons for the current editing tool
selected from the “Tool Bar” on page 2-9.
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3D Edit Window

The 3D Edit Window is the primary mechanism for creating, modifying, and deleting elements in a
scene. The specific contents displayed in the 3D Edit Window depends on the active tool on page 2-9.
However, most tools display the 3D graphics scene, along with a visual representation of the objects
that can be modified within the tool.

The camera is an essential part of using the 3D Edit Window. For more details on the use of the
camera, see “Camera” on page 3-6.

 3D Edit Window
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2D Edit Window

The 2D Edit Window displays context-sensitive information and provides additional editing
capabilities. The 2D Edit Window can display an assortment of data, such as road profiles on page 5-
102, road cross sections on page 5-24, extrusions on page 4-5, and signs on page 5-140. The
specific information displayed in the 2D Edit Window depends on the currently active tool and the
selected objects.

For example, if the Road Height Tool is selected, then the 2D Edit Window displayed the profile of the
currently selected road. Each of these modes has its own editing controls.

Most of the camera controls documented in “Camera” on page 3-6 apply to the 2D Edit Window,
though most 2D Edit Window modes do not provide full 3D movement.
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Library Browser

The Library Browser is used to browse and create assets in the current project on page 3-22. With
the Library Browser, you can select, view, edit, move, rename, and delete project assets. You can drag
some asset types from the Library Browser directly into the 3D Edit Window to place them in the
current scene.

The Library Browser is divided into two panels. The panel on the left displays the directory structure
within the Assets folder, enabling you to quickly navigate in the folder hierarchy. The panel on the
right displays the contents of the currently selected folder.

Only files recognized by RoadRunner as assets are displayed. Other system files and auxiliary files in
the directory are not shown.

View an Asset
To view an asset, select the asset in the Library Browser. Attributes for the selected asset display in
the “Attributes Panel” on page 2-20, and a preview of the asset displays in the “Asset Viewer” on
page 2-18.

Changes made to the attributes of individual assets are saved when either the current scene or
project are saved.

Rename an Asset
1 Right-click the asset in the Library Browser and select Rename (or press F2).
2 Enter a new name and press Enter.

 Library Browser
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Move Assets or Folders
1 Select the assets or folders in the Library Browser.
2 Click and drag the assets or folders to a different folder in either the left or right panel.

Moving an asset automatically updates asset references in the current scene, but other saved scenes
might still reference the old asset location. Refer to “Find Moved Assets” on page 2-16.

Create a New Folder
1 Right-click in the Library Browser and select New > Folder. Alternatively, select the Assets >

New > Folder menu option.
2 Enter a name and press Enter.

Create a New Asset
Create an Asset from Within RoadRunner

You can create some assets from directly within the Library Browser, such as materials and road
styles. Follow these steps:

1 Navigate to the folder in the Library Browser where you want to create the new asset.
2 Right-click in the Library Browser and select New > (Asset Type). Alternatively, select the

Assets > New > (Asset Type) menu option.
3 Enter a name and press Enter.

Create an Asset from a File Created Outside Runner

Some assets depend on files created outside of RoadRunner, such as a texture image saved as a PNG
file or a 3D tree saved as an FBX file. To create such assets for use in RoadRunner, drag the
dependent file into the Library Browser. Follow these steps:

1 Navigate to the folder in the Library Browser where you want to add the new asset.
2 In the File Explorer window for your operating system, navigate to the location of the dependent

file (for example, the texture image or the 3D model).
3 Select the file (and any associated files or folders) in the File Explorer.
4 Drag the files (and any associated files or folders) into the Library Browser.
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This operation copies (rather than moves) the selected files into the directory of the current project.

Alternatively, you can perform these steps by using the File Explorer window. Copy and move the files
somewhere under the "Assets" directory of your project. This option can be useful if you want to move
(rather than copy) the files or if you want to use an external script.

Modify an Asset
The steps to modify an asset differ depending on the specific type of asset (refer to the documentation
for the specific asset type).

In most cases, you can modify an asset by following these steps:

1 Select the asset in the Library Browser.
2 View and modify the asset attributes displayed in the “Attributes Panel” on page 2-20.

Some assets (such as “Sign Assets” on page 4-33) are modified using the “2D Edit Window” on page
2-12.

Modifications made to an asset are saved only when the project on page 3-22 is next saved.

Duplicate an Asset
1 Right-click the asset in the Library Browser and select Duplicate.
2 Enter a name for the new asset and press Enter.

You can use these steps only for assets created within RoadRunner (for example, a material or road
style asset). If you want to duplicate an asset that depends on another file (for example, a texture
image or 3D model), duplicate the dependent file only (not the rrmeta file) by using the File Explorer
for your operating system.
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Delete an Asset or Folder
1 Select the assets or folders in the Library Browser.
2 Right-click and select Delete. Alternatively, select the Edit > Delete menu option or press

Delete.

Add an Asset to a Scene
The steps to add an asset to a scene on page 3-25 differ depending on the specific tool on page 2-9
and type of asset. Refer to “Digitizing (Creating) Objects” on page 3-19.

Most assets can be added to a scene by dragging them into that scene. Click and drag an asset from
the Library Browser into the “3D Edit Window” on page 2-11. RoadRunner automatically switches
the current editing tool to the appropriate tool for that asset.

Reload Modified Assets
If you change an asset by using an external application (for example, if you modified a texture file
using an image editor), you can force RoadRunner to reload the asset. Right-click in the Library
Browser and select Update Assets. Alternatively, select the Assets > Update Assets menu option.

Find Moved Assets
If an asset or asset folder has been moved or renamed, then existing scene files might still refer to
the old location. If a scene cannot find an asset, RoadRunner replaces references to that asset with a
visually distinct fallback asset (for example, props display as pink barrels, and textures display as
striped red and blue images).
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If you encounter this situation, RoadRunner can search for the missing references and attempt to
relink them. Follow these steps:

1 Open the scene file containing missing asset references.
2 Right-click in the Library Browser and select Update Assets. Alternatively, select the Assets >

Update Assets menu option.

This search finds moved assets only if the corresponding rrmeta file was also moved or renamed and
was left intact.

 Library Browser

2-17



Asset Viewer

The Asset Viewer enables you to visualize the currently selected asset in the “Library Browser” on
page 2-13. The Asset Viewer automatically appears below the “Attributes Panel” on page 2-20 when
a single asset is selected in the Library Browser.

The Asset Viewer displays different asset types in different ways. For example, a 3D model asset is
displayed differently than a 2D image asset.

Move the Camera in the Asset Viewer
If the selected asset type supports a 3D display, you can move the camera by using the same controls
listed in “Camera” on page 3-6.

Unlike the other render windows, you do not need to hold Alt to adjust the camera in the Asset
Viewer.

Change the Asset Display Type
Some types of assets support additional viewing options. For example, “Material Assets” on page 4-
10 can be displayed on different types of geometry, and “Prop Model Assets” on page 4-17 can be
displayed as a point, curve, or collection.

To change the asset display type, click the display type at the top-right corner of the Asset Viewer.
Then, select the display type you want.
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Attributes Panel

The Attributes Panel displays information and editable attributes for the currently selected items. If
multiple different types of items are selected, each type of item is grouped separately in the
Attributes Panel. If multiple items of the same type are selected, the Attributes Panel indicates the
number of selected items and whether their properties have matching values.

Common Widget Types
The Attributes Panel includes common types of widgets, such as those described in this section.
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Spin Boxes

Typically, spin boxes are used to modify integer or floating-point values. You can modify spin box
values in one of these ways:

• Click and drag the attribute name ("Speed Limit" in the previous figure).
• Click the up or down arrow buttons on the right side of the spin box value.
• Click the value ("40 mph" in the previous figure) and type or paste a value directly.

Radio Buttons

Radio buttons are used to select between a specified list of enumerated values.

Combo Boxes

Combo Boxes are another way to select between a specified list of enumerated values. Typically,
combo boxes are used for infrequently used attributes and attributes with a large number of potential
values.

Toggles

Toggles are used to toggle Boolean (on or off) attributes.

Buttons

Buttons are used to run operations on the selected objects. Some buttons are displayed in the
Attributes Panel, while others are displayed on the “Sub-Tool Bar” on page 2-10.

Color Pickers

 Attributes Panel
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Color pickers are used to select a color. To use a color picker, click the displayed color to open a color
selection dialog box.

In this dialog box, you can:

• Select a color from a predefined set of basic colors ("Basic colors" at the top-left)
• Free-form select a color (color palette at the top-middle)
• Change the color intensity (intensity slider at the top-right)
• Select a color displayed anywhere on your screen ("Pick Screen Color" button)
• Select from your own set of custom colors ("Custom colors" at the bottom-left)
• Add a color to your own set of custom colors ("Add to Custom Colors" button replaces the last-

selected custom color with the current displayed color)
• Explicitly specify a color using Hue/Saturation/Value channels
• Explicitly specify a color using Red/Green/Blue channels
• Explicitly specify an HTML hex color (of the form #RRGGBB)
• Change the transparency of a color ("Alpha channel")

Asset Pickers

Asset pickers are used to reference an asset from the “Library Browser” on page 2-13.

To assign an asset to an asset picker, follow these steps:
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1 Locate the desired asset in the “Library Browser” on page 2-13.
2 Click and drag the asset into the asset picker.

Note  Most asset pickers accept only certain types of assets. For example, you can assign “Prop
Model Assets” on page 4-17 and “Extrusion Assets” on page 4-5 (among others) to a Prop Curve
on page 5-88, but you cannot assign a “Material Assets” on page 4-10.

Some asset pickers enable you to have no asset assigned. To remove an asset from an asset picker,
right-click the asset picker and select Clear. Alternatively, click the asset picker and press Delete.

To quickly locate the currently displayed asset in the “Library Browser” on page 2-13, click the asset
picker. The asset is selected in the “Library Browser” on page 2-13.

Although the asset is selected, its attributes do not display. To see and modify the asset attributes,
click the selected asset in the “Library Browser” on page 2-13.

View and Edit Attributes of a Single Object
1 Select the object in one of the main panels (such as the “3D Edit Window” on page 2-11, “2D Edit

Window” on page 2-12, or “Library Browser” on page 2-13).
2 View or modify the attributes displayed in the Attributes Panel.

View and Edit Attributes of Multiple Objects
If you select multiple objects in one of the main panels (such as the “3D Edit Window” on page 2-11,
“2D Edit Window” on page 2-12, or “Library Browser” on page 2-13), the Attributes Panel provides
additional features for interacting with multiple objects.
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This image shows the Attributes Panel after selecting two Prop Points on page 5-90. For this figure,
note these important aspects:

• The group label ("Prop Instance (2)") shows the number of selected objects (2 in this case).
• The Prop Style asset picker is grayed and dimmed, which indicates that the two props have
different assets assigned.

• The asset picker shows the style of the first selected object.
• If the asset picker value is changed, it will modify all selected objects (and the asset picker will

no longer be grayed/dimmed).
• The selected objects have different Position.X and Position.Y values, but their height

(Position.Z) value is the same. Modifying the Position.X or Position.Y values applies the
same value to all selected objects.

• Clicking a button (such as the Add Sign button in the figure) applies the operation to all selected
objects.
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Output Panel

The Output Panel prints a log of information, warnings, and errors relating to RoadRunner
operations. This information can be helpful for debugging certain problems, especially problems
related to loading asset files.

The buttons on the left of the panel provide these basic features:

• Save Output: Saves the output to file
• Clear Output: Clears the output panel (useful for reducing clutter when investigating a specific

issue)
• Show Info/Warnings/Errors: Toggles display of different message types
• Show Details: Shows more detailed information and debugging messages

A separate Output Panel is displayed when performing export operations. That separate panel reports
messages that occur only during the export operation. These messages are also reported to the main
Output Panel.

The Output Panel is also accessible from the “Start Page” on page 2-2. This access point is useful for
viewing error messages when loading a scene or project fails.

All Output Panel messages are saved to a log file, which you can find in the Tools > Debug > Open
Log Folder menu option. This log file can be useful for reporting issues to MathWorks Technical
Support.

 Output Panel
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Status Bar

The Status Bar displays feedback, error messages, and other information. The Status Bar normally
displays brief instructions for using the active tool. The bar sometimes displays success or failure
information related to the most recent user action (for example, saving the scene). Typically, these
status messages are cleared on the next click.
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Coordinate Space and Georeferencing

Local Coordinate System

3D coordinates are displayed and edited in a right-handed Cartesian coordinate system. All spatial
units are represented in meters, and angles are represented in degrees.

The 'X' and 'Y' dimensions represent 'Easting' and 'Northing' directions, respectively. The 'Z'
dimension is height.

This table illustrates local object transformations along each axis (for example, when using the “Prop
Point Tool” on page 5-90). Each image shows a transformation of the prop in the image in the
positive direction for each axis.

 X (Easting) Y (Northing) Z (Height)
Move

Rotate

Scale
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Georeferencing (Geographic Coordinates and Projections)

RoadRunner scenes on page 3-25 can be optionally georeferenced, which means that coordinates in
the scene can be mapped to locations on the Earth. This mapping is important when you want to
model a real-world location by using GIS reference data.

Georeferencing Basics

Georeferencing is a varied and complex topic. RoadRunner hides most of this complexity, especially if
you are using well-formed GIS reference data.

In many cases, georeferencing data is carried through when exporting. If you want to align exported
data with other GIS data (such as a GPS trace), then a basic familiarity with geospatial
transformations is required.

To perform geospatial coordinate transformations, RoadRunner uses the PROJ library, which is a
robust and industry-standard library for transforming horizontal and vertical coordinate systems. If
you need to work with georeferenced data in your own application stack, you can use PROJ for
optimal robustness and compatibility (or use a library that uses PROJ internally, such as GDAL or
PDAL).

Georeference a Scene

To add or modify a scene's location on the Earth, use the “World Settings Tool” on page 5-165. An
initial location is also applied automatically when first dragging any GIS Asset into a
nongeoreferenced scene.

Georeferenced Coordinate System

RoadRunner supports a variety of input projections and datums when loading external GIS data.
However, all editing and displaying is performed in a specific georeferenced coordinate system.

Any external GIS data is transformed automatically into this coordinate system before it is displayed.

Horizontal Georeferenced Coordinate System

To map the X and Y coordinates of the Local Coordinate System on to the Earth, an application must
define a horizontal coordinate system (typically by defining a geospatial projection and datum).

RoadRunner uses a coordinate system that reduces scale and rotational distortion surrounding
(within ~100 km of) a latitude/longitude point of interest. You can control the latitude/longitude point
(using the “World Settings Tool” on page 5-165), but control over the projection is not permitted.

 Coordinate Space and Georeferencing
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Specifically, RoadRunner uses a Transverse Mercator projection (with a scale factor of 1.0) over the
WGS84 datum. For example, a scene centered at a latitude of 32.0 and a longitude of -118 has a
horizontal georeferenced coordinate system defined as (in Proj syntax):
+proj=tmerc +lat_0=32.0 +lon_0=-118.0 +k=1 +x_0=0 +y_0=0 +datum=WGS84 +units=m

Vertical Georeferenced Coordinate System

To map Z (height) coordinates of the Local Coordinate System on to the Earth, an application must
define a vertical coordinate system.

Roadrunner uses heights over the EGM96 Geoid, as defined by a 15-minute grid (such as the one
found here). Grid files are used to convert between WGS84 ellipsoid heights and geoidal heights.

You can find the exact grid file used by RoadRunner by searching for the "egm96_15.gtx" file in the
RoadRunner installation directory.

The vertical coordinate system is also defined in the PROJ string. The full PROJ string for the example
in the horizontal section above is:
+proj=tmerc +lat_0=32 +lon_0=-118 +k=1 +x_0=0 +y_0=0 +datum=WGS84 +units=m +geoidgrids=egm96_15.gtx +vunits=m +no_defs 

Georeferencing and Exported Data

In addition to the information in the Georeferencing Basics section, this section provides information
about georeferencing information in data exported from RoadRunner.

To align data exported from RoadRunner with other GIS data (or to transform between latitude/
longitude coordinates and coordinates in the export data), you must know the projection and datum
of each data source. RoadRunner expresses this information as a Proj syntax or WKT string.

Many export formats also include projection information. For example, OpenDRIVE on page 7-18
data exported from RoadRunner includes a <georeference> tag defining the projection information
as a PROJ string.

Note  In almost all cases, it is not possible to align two georeferenced data sets by simply shifting
them. Projection transformations are more complicated than a simple shift and scale. Instead, rely on
a library like PROJ.

RoadRunner exports data in the same georeferenced coordinate system used by the scene (see
Georeferencing Basics). You can view the PROJ/WKT strings for the current scene in the “World
Settings Tool” on page 5-165. Control for transforming data into a different projection during export
is not supported.

Exported Data and Grid Files

The exported data also uses the same vertical coordinate system as the scene itself (see
Georeferencing Basics). To interpret the elevations in the exported data, you might need to make use
of the same grid files used by RoadRunner. This might require supplying the grid files to your
external application (if not already present).

In some specific cases, you might be able to ignore the grid files. Examples of these types of cases
include if you do not need to vertically match exported RoadRunner data and external GIS data or if
all of your external GIS data is already using the same vertical datum as the RoadRunner scene.
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If you are confident that you do not need the grid files in your external application, you can remove
the +geoidgrids=egm96_15.gtx portion of the PROJ string in any exported data. Because there
can be upwards of a 30 m vertical difference between geoidal heights and ellipsoidal heights, if you
are confident in how the data is to be used downstream.
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Camera

Camera Control
RoadRunner uses a single window with an adjustable camera to view the 3D scene. The camera is
based on a polar viewing model centered on a point of interest with an adjustable distance, azimuth
angle, and incline angle.

You can adjust the camera at any time and from within any tool by pressing and holding the Alt key
(or Windows/Command key) and moving the pointer.

Note In Ubuntu 16.04, the Alt key and Windows/Command keys have special purposes. If you use
Ubuntu 16.04, see “Camera Movement in Linux or Ubuntu” on page 8-7.

Rotate the Camera Around the Point of Interest

1 Press and hold the Alt key.
2 Click and drag the pointer to rotate the camera.

Zoom In and Out from the Point of Interest

1 Press and hold the Alt key.
2 Right-click and drag to zoom in and out.
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Move the Point of Interest in the Ground (XY) Plane

1 Press and hold the Alt key.
2 Right-click and click and drag to move the point of interest.

Alternatively, you can middle-click and drag to move the point of interest.

Raise or Lower the Point of Interest Vertically

1 Press and hold the Alt key and the Shift key.
2 Right-click and click and drag to raise or lower the point of interest.

Frame the Camera on the Selected Objects
RoadRunner can center (that is, frame) the camera on the currently selected objects in any tool.

1 Select one or more objects (for example, the road, control node, prop, lane, and so on, depending
on the current tool).

2 Press the F key, or select View > Frame Selected from the “Menu Bar” on page 2-8 to frame the
camera's point of interest on the selected object.

Change View Projections
The RoadRunner camera can use either a perspective or orthographic viewing projection.
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• The perspective projection is the normal viewing projection causing distant objects to appear
smaller than close objects.

• The orthographic projection is similar to what you might find in a CAD tool. It is useful for precise
positioning, usually from a top-down point of view. In orthographic mode, objects do not change
apparent size as they get closer or further away.

The camera controls work the same in both projection modes.

Set the Camera Into Perspective View Mode

Press the P key or select View > Perspective from the “Menu Bar” on page 2-8.

Set the Camera Into Orthographic View Mode

Press the O key or select View > Orthographic from the “Menu Bar” on page 2-8.

Set the Camera View Direction
You can set the view direction to due north, south, east, west, or top-down directions. Select the
directional option you want by selecting View > Direction menu from the Menu Bar.

Toggle View Options
Various draw settings for the 3D display window can be toggled through the View menu. Examples of
these various draw settings include:

• Wireframe: Displays outlines of rendered triangles
• Topographic: Displays topographic lines based on altitude
• Measurements: Displays measurement indicators defined in the “Measurement Tool” on page 5-

77

To toggle view options, select View from the Menu Bar and choose the desired setting.
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Segmentation

Segmentation Overview
RoadRunner has the ability to export scene geometry by category for easy generation of
segmentation training data.

Segmentation categories are identified in the export scene by using suffixes applied to each material
name. For example, a material named "Concrete" that is applied to a curb is named "Concrete_Curb"
on export. The exported material inherits the built-in segmentation category suffix "Curb", which
uniquely distinguishes it from the material "Concrete_Sidewalk" applied to neighboring sidewalk
geometry.

Toggle Segmentation Display
1 To enter segmentation display, select View > Sensor > Segmented.
2 To exit segmentation display, select View > Sensor > Camera.

Categories
RoadRunner uses a default set of segmentation categories when building geometry within a scene.
These categories include: Road, Sidewalk, Curb, Gutter, Marking, Ground, Building, Vehicle, Bike,
Pedestrian, Sign, Signal, Foliage, and Prop.

Additionally, you can extend these categories and assign them to the following project asset types:
Props, Signals, Lane Markings, Polygon Markings, Stencils.

Add a Custom Category

1 In a text editor, open the SegmentationCategories.xml file located in the project's "Project" folder.
If the file does not exist, create one.

2 Add a new Category entry. Include a name and color attribute, which are used during export and
segmentation display, respectively.

3 Existing categories can also be modified or removed. Changing the name of an existing category
is equivalent to removing the old category and adding a new one. Existing assets referencing this
old name will default.

4 Save the file and restart RoadRunner. New categories are available only after the project is
reloaded.

This code shows an example SegmentationCategories.xml file.

<?xml version="1.0"?>
<CustomSegmentationCategories>
    <Category name="Bush" color="#7BA269"/>
    <Category name="Tree" color="#0F5F32"/>
    <Category name="Crosswalk" color="#963"/>
    <Category name="DashedMarking" color="#369"/>
    <Category name="SolidMarking" color="#48a"/>
    <Category name="DoubleMarking" color="#69b"/>
</CustomSegmentationCategories> 
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Export Scene Geometry Grouped for Segmentation

On export, RoadRunner supports grouping materials by segmentation category or separating them
into individual meshes. To toggle between these options, follow these steps.

1 Select File > Export and select a triangulated format, such as Filmbox or OpenFlight.
2 In the export dialog box, fill out the file location and any tiling options.
3 Optionally use the Split by Segmentation toggle in the Options group to control whether each

mesh is split by category or remains grouped.
4 Click Export.

Assign a Category to an Asset

1 Select the asset in the Library Browser.
2 In the “Attributes Panel” on page 2-20, under Segmentation, select the appropriate category.
3 Select File > Save Project in the Menu Bar.
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Selecting Objects
You can select objects in the “3D Edit Window” on page 2-11 and “2D Edit Window” on page 2-12.

Most operations in RoadRunner require selecting one or more objects to act on. Attributes of selected
objects are displayed in the “Attributes Panel” on page 2-20. Many operations (for example, those in
the “Sub-Tool Bar” on page 2-10) apply to the currently selected objects.

The current tool on page 2-9 defines which types of objects are selectable. For example, the “Road
Plan Tool” on page 5-108 permits the selection of roads (but not props), whereas the “Prop Point
Tool” on page 5-90 permits the selection of prop points (but not roads).

Some types of objects can be selected only after first selecting a parent object. For example, in the
“Road Plan Tool” on page 5-108, you must first select a road before the control points for that road
are displayed.

RoadRunner enables multiple objects to be selected together. Some tools permit the selection of
multiple different types of objects at once.

Example Scene

The instructions in this section use images from the simple scene above.

This screenshot was taken in the “Prop Polygon Tool” on page 5-92. The scene contains four prop
polygons, which are displayed as light purple outlines.
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Selection Colors

Most tools on page 2-9 in RoadRunner use a common color language to indicate the selection state.
The image above shows objects in three different selection states.

• Unselected (light purple): Objects that are not currently selected.
• Selected (red): Objects that currently selected.
• Hovered (yellow): Object that the mouse is hovering over. This hover state provides a visual

indication of the object that will be selected if the mouse is clicked.

A fourth color (gray) is also used when selecting overlapping objects.

Select a Single Object

To select an object, click the object in the scene. Any previously selected objects are deselected (in
this example, the bottom polygon is no longer red), and the object the mouse is pointing to is
selected.
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Add an Object to the Selected Objects

To select an additional object, hold Shift and click an unselected object in the scene. Alternatively,
hold Shift and perform a box select (see below).

Remove an Object from the Selected Objects

To remove an object from selection, hold Ctrl+Shift, and then click a selected object in the scene.
This action removes that object from the selected objects, leaving the remaining objects selected.
Alternatively, hold Shift and perform a box select (see below).

Box-Select a Group of Objects
To perform a box selection, draw a rectangle on the screen to select objects. There are two types of
box-selection options:

• Overlap Box-Selection: Any objects that touch the box will be selected.
• Containment Box-Selection: Only objects that are fully contained within the box are selected.

The direction that you draw the box dictates which selection type is used. This table indicates the
selection type according to the direction that the box is drawn.
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Toward top-left

Containment

Toward top-right

Overlap
Toward bottom-left

Overlap

Toward bottom-right

Overlap

Overlap Box-Selection

To select objects that touch a rectangular region (note how both polygons are selected in the image
above):

1 Click and drag in one of the directions indicated by the red boxes in the previous table. A red box
appears, and any objects touching that box are selected.

2 Optional: Hold Shift to add the objects to the selected set.
3 Optional: Hold Ctrl+Shift to remove the objects from the selected set.

Tip  If no box appears, then it is likely that you started the box on or inside a draggable object in the
scene. If you hold Shift prior to the click, a box selection will occur (even if your drag starts outside
of a selectable object).

Containment Box-Selection
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To select objects fully contained within a rectangular region (note how the left polygon is not selected
in the image above):

1 Click and drag toward the upper-left direction. A purple box appears, and any objects fully
contained within that box are selected.

2 Optional: Hold Shift to add the objects to the selected set.
3 Optional: Hold Ctrl+Shift to remove the objects from the selected set.

If no box appears, then it is likely that you started the box on or inside a selectable object in the
scene. Ensure that your drag starts outside of a selectable object.

Select All Objects

To select all objects in the scene, select the Edit > Select All option in the “Menu Bar” on page 2-8,
or press Ctrl+A.

The behavior of a select-all action depends on which objects you currently have selected.

• If you have no objects selected, then all selectable objects in the scene will be selected.
• If you have objects selected, and any of those objects have unselected child objects, then the

unselected child objects will be selected.

• For example, if you select a single Prop Polygon on page 5-92, then the points on that polygon
will be displayed (but will not be selected). Performing a select-all operation will select all the
points on that polygon (not other polygons in the scene).

• If you have objects selected, and all child objects are already selected (or no child objects exist),
then all selectable objects in the scene will be selected.
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Deselect All Objects

To deselect all objects in the scene, select the Edit > Deselect All option in the “Menu Bar” on page
2-8, or press Ctrl+D.

Cycle-Select Overlapping Objects

Sometimes multiple selectable objects overlap each other. For example, the previous image shows
three overlapping Prop Polygon on page 5-92 objects.

In these cases, you can cycle between the different objects by repeatedly clicking on the overlapping
portion. Each click selects the next overlapping object.

1 Move the pointer over overlapping objects (in this case, in the middle of the three overlapping
polygons). The selected object displays in yellow, while the other overlapping objects display in
gray.
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2 Click the overlapping portion to select the object. The selected object displays in red, and the
object that will be selected on the next click displays in yellow.

3 Continue clicking to cycle through selecting overlapping objects until you reach the object you
want to select.
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Dragging (Moving) Objects
Many tools on page 2-9 enable you to move objects in the scene by selecting and dragging them.

To drag objects:

1 Select on page 3-11 one or more objects.
2 Click and drag a selected object to move it. If multiple objects are selected, dragging one object

drags all of the selected objects.

The exact behavior when dragging objects depends on the specific tool on page 2-9 and type of
object. For example:

• Props dragged in one of the “Prop Tools” will have their heights automatically projected to the
ground surface.

• Lane marking nodes dragged in the “Lane Marking Tool” on page 5-53 will be constrained to lie
along the lane boundary curve.

• Dragging a road control point in the “Road Plan Tool” on page 5-108 might automatically update
other roads to enforce tangential continuity.

Many objects can also be dragged during initial creation. Refer to “Digitizing (Creating) Objects” on
page 3-19.
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Digitizing (Creating) Objects
Many tools on page 2-9 provide the ability to create objects.

The type of object created and the specific creation steps depend on the tool. For steps on creation,
see the documentation for the specific tool.

In most cases, you can right-click either an existing object or an empty location in the scene to create
an object. Often, you can keep holding down the right-click button to simultaneously create and drag
the object (refer to “Dragging (Moving) Objects” on page 3-18).

Depending on the specific tool, you might need to first select an appropriate asset in the “Library
Browser” on page 2-13. Some tools require an asset to be selected, while others will change their
behavior depending on whether an asset is selected.

Some types of objects can be created by dragging an asset from the “Library Browser” on page 2-13
into the scene by clicking and dragging the object. For example, dragging a Prop Asset on page 4-17
into the scene adds a prop point to the scene and automatically switches the currently selected tool to
the “Prop Point Tool” on page 5-90.
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Deleting Objects
Most tools enable you to delete selected objects. You can refer to the documentation for a specific
tool on page 2-9 to learn about deleting objects. However, the steps are often similar to these steps:

1 Select on page 3-11 one or more objects.
2 Select the Edit > Delete option in the “Menu Bar” on page 2-8, or press Delete.

If an object cannot be deleted, an instructive error message is typically displayed in the “Status Bar”
on page 2-26.
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Undo/Redo
Almost all RoadRunner operations can be undone or redone. RoadRunner has an infinite undo stack,
which enables undo and redo of almost all operations performed in the “2D Edit Window” on page 2-
12 and “3D Edit Window” on page 2-11. Many operations elsewhere in the RoadRunner interface also
have undo and redo support.

Note Most operations performed in the “Library Browser” on page 2-13 (such as deleting or
renaming assets) do not have undo and redo support.

Undo and redo also applies to most selection on page 3-11 and tool change on page 2-9 actions.

The undo stack is related to the current scene on page 3-25. Operations that change the current
scene (such as loading a scene or creating a new scene) will remove all actions from the undo stack.

Note If there are no remaining operations to undo (or redo), an error message is displayed in the
“Status Bar” on page 2-26.

Undo an Operation
Select the Edit > Undo option in the “Menu Bar” on page 2-8, or press Ctrl+Z.

Redo an Operation
Select the Edit > Redo option in the “Menu Bar” on page 2-8, or press Ctrl+Y.
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Project System
A project folder contains assets (such as 3D models and texture maps) that are shared by multiple
RoadRunner scenes on page 3-25.

Project assets include various components that are created from files such as 3D models, texture
maps, and vector graphics. They also include various files specific to RoadRunner, such as materials
and road marking styles.

A current project is always active in RoadRunner. When you run RoadRunner, you must select or
create a project. The current project is displayed on the “Title Bar” on page 2-7.

Most projects contain the default assets included with RoadRunner. These assets include a small
assortment of materials, models, and other assets. You can also separately purchase the “RoadRunner
Asset Library”, which comes with a large array of generic and country-specific assets.

The Project Folder
A project folder contains these subdirectories:

• The Project directory contains a single file named "Project.rrproj", which defines a unique
reference ID for the project. This file should not be modified or moved.

• The Scenes directory stores individual scenes that use this project (refer to “Scenes” on page 3-
25). When you first create a project, this folder contains several sample scenes. When you save a
new scene, RoadRunner defaults to this directory.

• The Exports directory is the default location to write out exported data from RoadRunner, so this
directory is empty when a project is first created. You are not required to use this directory for
exported data. For more information, see “Exporting”.

• The Assets directory stores all asset files available for use in a scene. These assets appear in the
“Library Browser” on page 2-13.

Note  It is recommended that you place the entire project folder under version control. Refer to
“Project and Scene Version Control” on page 3-27.

Asset Types
RoadRunner supports a variety of asset types. For a full list, refer to “Assets”.

3 Fundamentals

3-22



Asset Metafiles
For every asset within the "Assets" directory tree, RoadRunner automatically creates an associated
metafile with the ".rrmeta" file extension.

The metafile contains additional data associated with the asset, the details of which vary for different
asset types. The metafile also contains a unique ID that can be used to identify a specific asset (even
if the asset is renamed or moved into a different directory within the "Assets" tree).

This file should always be kept in the same location as the asset itself. Asset operations performed
with the “Library Browser” on page 2-13 automatically update the corresponding metafiles.

Create a New Project from the Start Page
1 Open the RoadRunner application.
2 Click the New Scene button on the “Start Page” on page 2-2. Another menu will appear asking

you to select a project.
3 In this second menu, click the New Project button. A file browser will appear asking you to

select a directory in which to create the project.

Note If you create a project that is on a network drive, changes made to asset files might not be
automatically reflected in the Library Browser. In addition, performance might be slower. For
improved performance and full Library Browser functionality, create a project on a local disk.

4 In the file browser, choose (or create) an empty directory in which to create your project.
5 In the dialog box, select whether to install the “RoadRunner Asset Library” assets in your project.

If you have a RoadRunner Asset Library license, click Yes to populate the Assets folder with the
library assets. If you do not have a license, this option is disabled. Instead, click No to populate
the Assets folder with a set of default assets included with RoadRunner.

Create a New Project from Within RoadRunner
1 Select File > Change Project on the Main Menu. A menu will appear asking you to select your

project.
2 Jump to step 3 in the Create a New Project from the Start Page section.

Change the Current Project
1 Select File > Change Project on the Main Menu. A menu will appear asking you to select your

project.
2 If your project is listed on the "Recent Projects" list, then select it directly. Alternatively, click the

Open Project button to open a file browser and select your project.
3 Choose the root directory of the existing project to which you want to switch. This action changes

the current project and creates a new scene.

Create, Modify, and Delete Assets
Refer to the “Library Browser” on page 2-13 documentation.
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Save the Current Project
Modified assets are not saved until the current project is saved. To save the current project, select
the File > Save Project menu option. Alternatively, save your current scenes on page 3-25, and the
current project will save automatically.

See Also

More About
• “Project and Scene Version Control” on page 3-27
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Scenes
A scene file contains an area created in RoadRunner that contains roads, surfaces, props, and so on.
It is the main type of file edited in RoadRunner. Scenes can represent anything from a small area,
such as a single intersection, to a large area such as a portion of a city. A scene can contain multiple
roads, intersections, road markings, props, terrain sections, and more.

Individual scenes are saved as .rrscene files, typically under the "Scenes" directory of a project. You
can create many scenes within the same project, and the scenes can share assets within the project
(refer to “Project System” on page 3-22).

RoadRunner has exactly one scene active at any given time. The name of the current scene is
displayed in the Title Bar. If the scene has not yet been saved, it will display "New Scene."

If you have unsaved changes in your current scene, RoadRunner prompts you to save your current
scene before starting a new scene, loading an existing scene, or exiting the program.

Create a New Scene
To create a new scene while working in an existing scene, on the “Menu Bar” on page 2-8, select File
> New Scene. Alternatively, press Ctrl+N.

To create a new scene from the “Start Page” on page 2-2, follow these steps:

1 Click the "Scenes" tab.
2 Click the "New Scene" button.
3 Select a previous project, or click "New Project" to create a new one (refer to “Project System”

on page 3-22).

Open an Existing Scene
To open an existing scene that was recently opened, open it directly from the File > Recent Scenes
menu.

Alternatively, if the scene was not recently opened, follow these steps:

1 Select File > Open Scene on the “Menu Bar” on page 2-8, or press Ctrl+O.
2 Navigate to the correct directory, if necessary.
3 Select the scene file you want to open.

If you choose a scene file from a different project, RoadRunner automatically switches projects
accordingly.

You can also open a scene from the “Start Page” on page 2-2. Follow these steps:

1 Click the "Scenes" tab.
2 Select a scene from the "Recent Scenes" list, or click the "Open Scene" button to browse for a

scene file.

If the selected scene file is in the "Scenes" directory of a project folder, that project will automatically
be loaded. If your scene is saved elsewhere, the scene will store the relative path to the project
directory.
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If the project cannot be found or loaded, you will have the option of selecting a previous project or
browsing for one.

Save the Current Scene Using the Existing Name
Select File > Save Scene on the Main Menu, or press Ctrl+S, to save the current scene using its
current name.

Saving a scene will also save any changes you have made to the current project on page 3-22.

Save the Current Scene with a Different Name or in a Different
Directory
1 Select File > Save Scene As on the Main Menu, or press Ctrl+Shift+S to open a file browser

that defaults to the "Scenes" directory of the current project.
2 Navigate to the correct directory, if necessary.
3 Enter the desired name of the scene.

Saving a scene also saves any changes you have made to the current project on page 3-22.
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Project and Scene Version Control
When multiple people are making changes to project assets or scenes, using a revision control system
(such as Git™) is recommended. If a revision control system is used, these policies are recommended:

• Manage files within the project tree with the revision control system. Metafiles (.rrmeta) should
be included as well.

• All RoadRunner internal files are binary and so should not be merged. Only one user should make
changes to any particular file at any time.

See Also

More About
• “Project System” on page 3-22
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Triangulation Settings
You can modify tolerances and construction parameters to affect curve sampling and scene
triangulation. To modify these parameters, use the Triangulation Settings dialog box.

Positional Tolerance
The Positional Tolerance parameter controls the maximum deviation (in meters) between sampled
polylines and their underlying analytical representation. As this value decreases, the number of
samples and triangles produced increases.
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Positional Tolerance: 0.005

Positional Tolerance: 0.01

Positional Tolerance: 0.1
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Max Length
The Max Length parameter controls the maximum length between any two samples in the curve
triangulation.

Max Length: 50.0

Max Length: 10.0
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Max Length: 1.0

Height Field Sampling Parameters
Height Tolerance

The Height Tolerance parameter controls whether to include elevation samples in terrain
triangulation (not roads) relative to the elevation of neighboring samples. Height tolerance is in
meters. As the tolerance decreases, the difference between samples and the underlying elevation
field with respect to elevation decreases. Typically, a low tolerance produces a large number of
triangles.

Height Tolerance: 0.5
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Height Tolerance: 0.05

Height Tolerance: 0.005

Height Min Spacing

The Height Min Spacing parameter controls the minimum distance (in meters) between samples
and their neighbors. In general, the lower the tolerance, the closer the samples are allowed to be.
Typically, a lower tolerance produces a greater number of triangles.
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Height Min Spacing: 5.0

Height Min Spacing: 1.0

Height Min Spacing: 0.1
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Height Max Spacing

The Height Max Spacing parameter controls the maximum distance (in meters) between samples
and their neighbors. In general, the lower the tolerance, the closer the samples are required to be.
Typically, a lower tolerance produces a greater number of triangles.

Height Max Spacing: 5.0

Height Max Spacing: 2.0
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Height Max Spacing: 0.5

Road to Surface Blend Range

The Road to Surface Blend Range parameter controls the amount of distance (in meters) between
the surface triangles and any adjacent edge.

Road to Surface Blend Range: 5.0
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Road to Surface Blend Range: 1.0

Marking Projection
Every marking in RoadRunner is projected onto the underlying road or terrain surface to improve
visual quality and avoid rendering issues such as z-fighting. The following pictures illustrate the
result of projecting markings onto a complex road surface.

SLOW road marking stencil projected onto a road with an exaggerated height bump.
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Outline of the original source marking stencil. The original flat stencil does not line up well with the
underlying surface.

Marking triangulation that results after projecting the source marking outline onto the road surface.

Marking Construction Type

The Marking Construction Type parameter controls whether to stitch markings into the underlying
road and terrain surface or to float the markings a small distance above the surface once they are
projected. Floating markings (also known as decals) have the advantage of producing less triangles
overall and allow for a more regular road surface triangulation. However, floating markings might
require more handling once exported from RoadRunner to avoid z-fighting.
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Markings produced with the Cut Out option enabled. The asphalt surface is triangulated around the
marking.

Markings produced with the Floating option enabled. The asphalt surface triangulation passes
beneath the marking geometry.

Floating Marking Offset

The Floating Marking Offset parameter controls how much to float a marking above the underlying
surface. The lower the value, the smaller the gap between the markings and the surface, but the
likelihood of rendering artifacts, such as z-fighting, increases.
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Floating Marking Offset: 0.01

Floating Marking Offset: 0.5
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Geometry Issues
You can enable visualization of geometric issues related to triangulation. To modify geometry issue
settings, use the Geometry Issue Settings dialog box under the Tools menu.

Angle Threshold
The Angle Threshold parameter controls the angle threshold (in degrees) at which geometric issues
are displayed. This angle directly translates into the angle between adjacent faces of the road mesh.
These images show the same road section with different Angle Threshold values used for displaying
geometric issues. As the Angle Threshold value increases, the number of issues that are detected
decreases.

Angle Threshold: 1 degree
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Angle Threshold: 10 degrees

Angle Threshold: 30 degrees

Show Edge Visualization
The Show Edge Visualization parameter enables visualization of the geometric issues. This toggle
is applied when the dialog box is closed and corresponds directly to the View > Geometric Issues
menu option.
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Edge visualization disabled

Edge visualization enabled

Detect Geometry Issues
Running Detect Geometry Issues prints the current state of the geometric issues to its own output
panel, and to the RoadRunner standard Output panel. Each issue contains its own URL that focuses
the camera on each issue.
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Aerial Image Assets

Aerial image assets are used to add GIS satellite and aerial imagery to a scene, typically for visual
reference.

Creation
Create an asset by using one of the supported file formats shown. Then, drag the file into the
RoadRunner “Library Browser” on page 2-13.

Supported Formats:

• “Image File Types” on page 4-38. GeoTiff, JPEG 2000, and IMG are most common for
georeferenced imagery.

Refer to the “Aerial Imagery Tool” on page 5-18 for instructions on adding and adjusting aerial
images in your scene.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.
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Crosswalk Marking Assets

Crosswalk marking assets describe the general properties of a crosswalk marking, such as color,
width, spacing, and so on. These assets are used by features such as the “Crosswalk And Stop Line
Tool” on page 5-26 and the “Marking Curve Tool” on page 5-72.

Creation
Create these assets from within the RoadRunner “Library Browser” on page 2-13.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.

Crosswalk Asset Attributes
Attribute Description
Width Width between the centers of the left/right

stripes.
Border Width Width of the left/right stripes.
Dash Length Length of each dash in ladder-style crosswalks.

If zero, no dash will be present.
Dash Gap Length between dashes in ladder-style

crosswalks.
Default Material Material on page 4-10 used by crosswalk

instances. This material will be used by any
crosswalk instances that do not have an
overriding material (that is, crosswalks that do
not have an assigned "Material" attribute in the
Marking Curve Attributes on page 5-72.)

Changing this value will impact any existing
crosswalk instances (except those that have an
overriding material assigned).

Category “Segmentation” on page 3-9 type for this marking
asset.
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Elevation Map Assets

Elevation Map Assets are used to add GIS raster elevation data to a scene.

Creation
Create an asset by using one of the supported file formats shown. Then, drag the file into the
RoadRunner “Library Browser” on page 2-13.

Supported Formats:

• DEM (.dem)
• IMG (.img)
• TIF / GeoTIFF (.tif, .tiff)

Refer to the “Elevation Map Tool” on page 5-35 for instructions on adding and adjusting elevation
maps in your scene.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.
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Extrusion Assets

Extrusion assets are used to create extruded geometry for features such as walls, guard rails, and
fences.

Creation
Create these assets from within the RoadRunner “Library Browser” on page 2-13.

Extrusions can combine an extruded cross section (such as the metal railing of a guard rail) with
regularly spaced props (such as the wooden posts of the guard rail). These extrusions can be placed
along curves using the “Prop Curve Tool” on page 5-88, and along road spans using the “Prop Span
Tool” on page 5-93.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.

Extrusion Asset Attributes
Attribute Description
Default Spacing Controls how often a prop is placed along the

extrusion.
Instance Offset An offset (in the space of the curve) applied to all

props placed along the extrusion.
Item 0, 1, and so on Refer to: Add a Repeating Prop to an Extrusion.

You can add a constant offset to all props placed along the extrusion by adjusting the "Instance
Offset" attribute in the “Attributes Panel” on page 2-20.
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Edit the Shape of an Extrusion

1 Select an extrusion style in the “Library Browser” on page 2-13 to view the extrusion profile in
the “2D Edit Window” on page 2-12.

2 See “Curve Editing” on page 5-3.

The editing controls for extrusions differ from most curve-based tools. For example, there is no
explicit tangent control or tangent locking/unlocking. To create a sharp angle, you would create two
curves and drag the endpoints of one until it snaps to the end of the other.

Assign Materials to an Extrusion
1 Select an extrusion style in the “Library Browser” on page 2-13 to view the extrusion profile in

the “2D Edit Window” on page 2-12.
2 Select an extrusion curve in the “2D Edit Window” on page 2-12.
3 Modify any of the following attributes in the “Attributes Panel” on page 2-20.

Attribute Description
Material Material Asset on page 4-10 to apply to the

selected extrusion curve.
Texture Size Texture coordinate scale for the selected

extrusion curve.
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Two Sided Whether the material applies to both sides of the
selected extrusion curve or a single side.

Two-sided is typically only used for thin fences
(for example, chain link fences).

Add a Repeating Prop to an Extrusion
You can add regularly spaced props along an extrusion. This is useful to add posts and other supports
along the extrusion.

Note that extrusion assets behave much like “Prop Set Assets” on page 4-24. Refer to that
documentation for instructions on adding and removing prop items on an extrusion asset.
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Lane Marking Assets

Lane marking assets describe the properties of lane markings, such as color, width, dash spacing, and
so on. These assets are used by features such as the “Lane Marking Tool” on page 5-53, “Marking
Curve Tool” on page 5-72, and the “Marking Polygon Tool” on page 5-76. Making a change to a lane
marking style will affect all instances that use that style.

Creation
Create these assets from within the RoadRunner “Library Browser” on page 2-13.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.

Lane Marking Asset Attributes
Attribute Description
Marking Type Line marking pattern.

"Solid" is a continuous unbroken line, while
"Dashed" refers to a broken line with separate
controls for gap and dash lengths.

Width Width of each marking stripe.
Separation Gap between marking stripes (for marking types

with more than one stripe).
Dash Length Length of marking dashes (for "Dashed" marking

types).
Dash Spacing Length of gaps between dashes (for "Dashed"

marking types).
Curve Space Texture If true, the marking material will be applied in

the space of the curve. The vertical axis of the
texture will be mapped along the curve, and the
horizontal axis will span the total width of the
marking.

If false, then the marking material will be applied
in 'world space', where the vertical axis of the
texture will be mapped based on the global 'Y'
axis, and the horizontal axis will be mapped
based on the global 'X' axis.
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Attribute Description
Default Color Initial color to assign to marking instances. Refer

to the "Color" attribute in the Marking Curve
Attributes on page 5-72.

Modifying this value in the asset does not impact
any existing marking instance.

Default Material Material on page 4-10 used by lane markings in
the scene. This material will be used by any
marking instances that do not have an overriding
material (that is, markings that do not have an
assigned "Material" attribute in the Marking
Curve Attributes on page 5-72.)

Changing this value will impact any existing
marking instances (except those that have an
overriding material assigned).

Default Start Blend Distance Initial Start Blend Distance to use for marking
instances. Refer to the "Start Blend Distance"
attribute in the Marking Curve Attributes on page
5-72.

Modifying this value in the asset does not impact
any existing marking instance.

Default End Blend Distance Initial End Blend Distance to use for marking
instances. Refer to the "End Blend Distance"
attribute in the Marking Curve Attributes on page
5-72.

Modifying this value in the asset does not impact
any existing marking instance.

Category “Segmentation” on page 3-9 type for this marking
asset.
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Material Assets

Material assets are used to define the visual properties of surfaces, sidewalks, lanes, and other
objects.

Creation
Create these assets from within the RoadRunner “Library Browser” on page 2-13.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.
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Point Cloud Assets

Point cloud assets are used to add aerial or vehicular point clouds to a scene, typically for visual
reference.

Creation
Create an asset by using one of the supported file formats shown. Then, drag the file into the
RoadRunner “Library Browser” on page 2-13.

Supported Formats:

• LAS / LAZ (.las, .laz)
• PCD (.pcd)

Note: LAZ files version 1.4 or higher might not load correctly. In these cases, you might need to
decompress the files to LAS files. For more details, see “Decompress LAZ Files” on page 8-10.

Refer to the “Point Cloud Tool” on page 5-86 for instructions on adding and adjusting point clouds in
your scene.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.
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Polygon Marking Assets

Polygon marking assets describe the properties of space-filling road markings, such as crosshatch
and chevron markings.

Creation
Create these assets from within the RoadRunner “Library Browser” on page 2-13.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.
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Post Assets

Post assets are used for building support posts of varying height, primarily for bridges and
overpasses.

Creation
Create these assets from within the RoadRunner “Library Browser” on page 2-13.

You cannot change the material, customize the extrusion profile, or add caps to post assets.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets
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Prop Assembly Assets

Prop assembly assets are hierarchical collections of prop instances stored as a single asset that can
itself be instantiated within the scene.

Creation
Create these assets from within the RoadRunner “Library Browser” on page 2-13.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.
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Create a Prop Assembly

1 Select the “Prop Point Tool” on page 5-90.
2 Select the root node of a hierarchical prop (a point prop with one or more props attached to it).
3 Click the "Create Assembly" button in the “Attributes Panel” on page 2-20.

A new assembly asset will appear in the current directory of the Library Browser. Rename your asset
as you see fit.

The selected prop node will be automatically replaced by this new assembly.

Expand a Prop Assembly
After placing a prop assembly instance in the scene, you can expand it to separate it into its
individual components, which breaks the instance's link to the prop assembly asset).
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This is useful when you want to modify only a single instance of the assembly. For example, if you
want to move a traffic signal head on a traffic assembly.

1 Select the “Prop Point Tool” on page 5-90.
2 Select a prop point with a prop assembly assigned to it.
3 Click the "Expand Assembly" button.
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Prop Model Assets

Prop model assets reference external 3D model files that can be placed within the scene.

Creation
Create an asset by using one of the supported file formats shown. Then, drag the file into the
RoadRunner “Library Browser” on page 2-13.

Supported Formats:

• glTF (.gltf, .glb)
• Filmbox (.fbx)
• OpenFlight (.flt)
• OpenSceneGraph (.osg, .osgt, .osgb, .ive)
• Wavefront (.obj)

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.

Refer to “Prop Tools” for details on adding prop model assets to the scene.
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Prop Attributes

All prop assets have a set of options that affect the way the props are placed. For example, some
props will always align vertically, such as a traffic signal. Other props will align to the surface they
are placed on, such as a garbage can sitting on a sloped sidewalk. (This option can be toggled on a
prop-by-prop basis.) Other options include the ability to randomly rotate the prop around the vertical
axis, which is useful for varying the orientation of trees and plants.

To set the default attributes for a particular prop asset, first select the prop in the Asset Browser. The
prop's attributes will then appear in the Attribute Panel, where they can be interactively adjusted.

Prop Attachment Curves
An attachment curve is a spline associated with a prop that RoadRunner uses as a cue when
attaching objects to each other.

As an example, note the green highlight line in the following signal pole prop. The image on the right
is a close-up that shows this detail.
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When you pick another prop from the Library Browser and bring it sufficiently close to the
attachment curve, they snap together at that point. In this case, a signal mast arm has been attached.
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Creating Prop Attachment Curves

RoadRunner does not have a user interface for creating prop attachment curves directly. However, if
you have access to a third-party tool like Maya® or Blender®, you can create these yourself on any
prop. Add a spline named "attachment" into the object hierarchy.

4 Assets

4-20



If the attachment curve is not appearing in RoadRunner, you may need to add more curve points so
that it can be detected. In Maya, this option is under Curve > Rebuild.
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Format Details
FBX Details

• Layered Textures are not supported and will not be connected to the imported materials.
• Texture transformations (scale, rotation, and translation) are not supported and will be ignored.
• RoadRunner supports importing FBX Lambertian and Phong materials.
• Multiple UV sets are not supported. These extra UVs must be removed in a program like Maya

before being imported into RoadRunner.
• Importing lights from FBX files is not supported.
• Levels of Detail (LODs) are based on the node name. During import, RoadRunner checks if the

node name ends with "_med", "_low", or "_verylow".

Note  RoadRunner does not render lower LODs, so nodes that end in "_med", "_low", or
"_verylow" will not be visible.

glTF Details

• Texture sampler settings are not imported and defaults to "repeat" on both axes.
• Sparse accessors are not supported.
• Point and line primitive modes are not supported.
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OpenSceneGraph Details

• When importing materials, osg::Textures are loaded as materials. These single texture
materials will take precedence over osg::Materials when generating the mesh.

• Only "Overall" and "Per Vertex" color bindings are supported.
• Multiple UVs are not supported. Only the first texture coordinate array is used.
• Point and line PrimitiveSet modes are not supported.

Advanced Details
Textures

Most 3D models have associated image files (such as texture maps or normal maps). Place these
image files in the same directory as the prop model itself, or (in certain formats, such as FBX) they
can also be embedded into the actual prop file.

Unit Scale and Coordinate System

• RoadRunner uses meter units. Imported FBX files will automatically convert units if needed.
• RoadRunner uses the Maya Z-up coordinate system: +Z is up, +X is right, and -Y is toward the

camera.

Note  Imported FBX files will automatically rotate to match the coordinate system. However, FBX
files created in a left-handed coordinate system will not be converted properly.
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Prop Set Assets

Prop set assets reference collections of different props that have a random distribution. For example,
you can create a prop set of trees that contains a collection of different tree models. Prop sets specify
a relative distribution for each item in the set. This influences the likelihood of that item appearing
when the prop set is added to the scene. Prop sets can be placed on points, curves, polygons, and
spans.

Creation
Create these assets from within the RoadRunner “Library Browser” on page 2-13.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.

Create a Prop Set
See Create an Asset from Within RoadRunner on page 2-13.

If you have one or more prop assets selected when you create the new prop set, those assets are
automatically added to the new prop set. If no prop assets are selected, an empty prop set is created.

Add an Item to a Prop Set
1 Select a prop set in the “Library Browser” on page 2-13.
2 Click the "Add Prop" button in the “Attributes Panel” on page 2-20. A new (empty) item will be

added to the end of the items.
3 Assign a prop style asset to the "Prop" Asset Picker for the new item (see Assign an Asset to an

Asset Picker on page 2-20).

You can use any of the following asset types as a prop set item:

• “Prop Assembly Assets” on page 4-14
• “Prop Model Assets” on page 4-17
• Prop Set Assets

Remove an Item from a Prop Set
1 Select a prop set in the “Library Browser” on page 2-13.
2 Click the "Remove Prop" button below the item you want to remove in the “Attributes Panel” on

page 2-20
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Road Style Assets

Road Style Assets are templates that define the properties used when creating new roads.

Creation
Create these assets from within RoadRunner. For more details, see the “Create a Road Style Asset”
on page 4-25 section.

These properties include the number of lanes, lane types, lane widths, lane marking materials, and
road cross section information. It also contains information about extrusions, such as barriers and
repeated props.

Road style assets are typically used only when initially creating a road. After that point, you can use
the “Road Tools” to customize any aspect of the created road.

A selection of road styles is included with RoadRunner. You can create new road styles and modify
existing ones.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.

Road style creation and editing differs from many other asset types. Refer to the steps listed here.

Apply a Road Style to a New Road
Refer to the “Road Plan Tool” on page 5-108 documentation.

Apply a Road Style to an Existing Road
Click and drag the road style from the “Library Browser” on page 2-13 onto the road you want to
change.

This operation changes the entire road and overwrites any local changes previously made to the road,
such as lane edits, marking edits, attribute edits, cross section edits, and more. Therefore, it is
recommended that you use it only when first creating a road.

Create a Road Style Asset
You can create a style from any road in your RoadRunner scene.

1 Find or create a road and customize it to your liking using the “Road Tools”.
2 Select the “Cross Section Tool” on page 5-24.
3 Select the road.
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4 Right-click a location along the road to create a cross section (or click an existing cross section).
5 Click the Make Road Style button on the “Attributes Panel” on page 2-20 to create a road style

in the current “Library Browser” on page 2-13 folder.
6 Rename the road style asset, if desired.

Edit a Road Style Asset
You can replace the contents of a road style asset with a new road style. This will not impact any
previously created roads.

1 Find or create a road and customize it to your liking using the “Road Tools”.
2 Select the “Cross Section Tool” on page 5-24.
3 Select the road.
4 Right-click a location along the road to create a cross section (or click an existing cross section).
5 Click the Update Selected Style button on the “Attributes Panel” on page 2-20.
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Signal Assets

Signal assets are 3D models that allow for dynamic traffic signal heads with lights.

Creation
Create an asset by using one of the supported file formats shown. Then, drag the file into the
RoadRunner “Library Browser” on page 2-13.

Supported Formats:

• Filmbox (.fbx)
• Wavefront (.obj)

In many regards, signal assets are similar to “Prop Model Assets” on page 4-17. For example, the
same steps are used to add signal assets to the 3D scene.

The “RoadRunner Asset Library” includes a variety of signals. You can also add your own custom
signal models (refer to the Create a Custom Signal Prop section below).

Signal assets include the notion of variants, which allow the same 3D model to be configured with
multiple different bulb layouts. For example, a single 3-bulb model could have one variant for
green/red/yellow ball lights, and another for green/red/yellow left turn lights. Variants require two
Texture Atlases on page 4-35 that define the on and off state for all bulbs available for that signal.

Each variant defines a set of supported turn types that are used to automatically map signals to
maneuvers with the “Signal Tool” on page 5-130.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.

Create a Signal Variant
1 Select a signal asset in the “Library Browser” on page 2-13.
2 Click "Add Variant" in the “Attributes Panel” on page 2-20.
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Set Bulb Textures
1 Select a signal asset in the “Library Browser” on page 2-13.
2 Assign Texture Atlases on page 4-35 to the "On Texture" and "Off Texture" asset pickers in the

“Attributes Panel” on page 2-20.

Name or Rename a Signal Variant
1 Select a signal asset in the “Library Browser” on page 2-13.
2 Choose the variant to edit in the "Variant" drop-down list in the “Attributes Panel” on page 2-20.
3 Set the "Name" of the variant in the “Attributes Panel” on page 2-20.

Set or Change a Bulb Type
1 Select a signal asset in the “Library Browser” on page 2-13.
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2 Select a bulb in the “2D Edit Window” on page 2-12.
3 Choose a bulb type ("Variant Bulb Type") in the “Attributes Panel” on page 2-20.

Specify Supported Turn Types
1 Select a signal asset in the “Library Browser” on page 2-13.
2 Choose the variant to edit in the "Variant" drop-down list in the “Attributes Panel” on page 2-20.
3 Check the boxes that correspond to the controlled turn types for this signal.
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Remove a Signal Variant
1 Select a signal asset in the “Library Browser” on page 2-13.
2 Choose the variant to remove in the "Variant" drop-down list in the “Attributes Panel” on page 2-

20.
3 Click "Remove Variant".

Create a Signal State
1 Select a signal asset in the “Library Browser” on page 2-13.
2 Click "Add State" in the “Attributes Panel” on page 2-20.

Name or Rename a Signal State
1 Select a signal asset in the “Library Browser” on page 2-13.
2 Choose the variant to edit in the "Variant" drop-down list in the “Attributes Panel” on page 2-20.
3 Choose the state to edit in the "State" drop-down list.
4 Set the "Name" of the state in the “Attributes Panel” on page 2-20.

Specify State Supported Turn Types
1 Select a signal asset in the “Library Browser” on page 2-13.
2 Choose the variant to edit in the "Variant" drop-down list in the “Attributes Panel” on page 2-20.
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3 Choose the state to edit in the "State" drop-down list.
4 Set the signal mode for each supported turn type in the "State Turn Types" group.

Remove a Signal State
1 Select a signal asset in the “Library Browser” on page 2-13.
2 Choose the variant to edit in the "Variant" drop-down list in the “Attributes Panel” on page 2-20.
3 Choose the state to edit in the "State" drop-down list.
4 Click "Remove State".

Create a Custom Signal Prop
1 Model the signal in a 3D modeling program.
2 Create bulb meshes for each bulb.
3 Prefix the name of each bulb mesh with "light_"
4 Construct the UVs of the bulb mesh using the full UV grid size (0 to 1).
5 Export as FBX.
6 Add the asset file using the “Library Browser” on page 2-13.
7 Right-click the asset and set the "Default Type" to "Signal".
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Tips
• If automatic detection in the “Signal Tool” on page 5-130 does not choose the correct state for a

signal, try adjusting the supported turn types for the state or variant.
• Make a red state first, because this will be the default.
• If the signal bulbs do not display correctly, ensure that the on and off textures are set and that

both of those textures are Texture Atlases on page 4-35 with the correct grid size.

4 Assets

4-32



Sign Assets

Sign Assets are used to create and edit standard and custom street signs.

Creation
Create an asset by using one of the supported file formats shown. Then, drag the file into the
RoadRunner “Library Browser” on page 2-13.

Supported Formats:

• “Image File Types” on page 4-38

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.
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Stencil Marking Assets

Stencil marking assets are used to place road paint features, such as arrows, text, and symbols.

Creation
Create an asset by using one of the supported file formats shown. Then, drag the file into the
RoadRunner “Library Browser” on page 2-13.

Supported Formats:

• SVG (.svg, .svgz)

Refer to the “Marking Point Tool” on page 5-74 for more information about using stencil marking
assets as point markings.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.

Create a Stencil Marking Asset
1 Add the asset file using the “Library Browser” on page 2-13.
2 Right-click the asset and set the "Default Type" to "Stencil Marking".

The SVG parser used for stencil markings is limited. Many SVG elements are not supported. If your
SVG is not supported and you want to use the stencil as a point marking, you can convert it to any of
the supported non-SVG “Image File Types” on page 4-38 and use the “Marking Point Tool” on page
5-74 to add the resulting “Texture Assets” on page 4-35 to the scene.
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Texture Assets

Texture assets are image files that are typically used as texture channels for “Material Assets” on
page 4-10.

Creation
Create an asset by using one of the supported file formats shown. Then, drag the file into the
RoadRunner “Library Browser” on page 2-13.

Supported Formats:

• “Image File Types” on page 4-38

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.

Texture Asset Attributes
Attribute Description
Default Width Default spatial size of the texture, in meters.

Used (for example) as the default sign size when
the texture file is used as a Sign Asset on page 4-
33.

Is Texture Atlas Refer to: Create a Texture Atlas.

Create a Texture Atlas
A texture atlas is a single texture image that contains multiple uniformly spaced sub-images (such as
the image below).

These are used as textures for “Signal Assets” on page 4-27 and Point Markings on page 5-74.
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To set texture atlas properties for a texture asset:

1 Select one or more texture assets in the “Library Browser” on page 2-13.

2 Select the "Is Texture Atlas" option in the “Attributes Panel” on page 2-20.

3 Set the grid size of the texture (these specify the number of sub-image rows and columns) in the
"Atlas Tiles" option.
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Vector Data Assets

Vector Data Assets are used to add GIS shapefiles and other vector data to a scene, typically for
visual reference.

Creation
Create an asset by using one of the supported file formats shown. Then, drag the file into the
RoadRunner “Library Browser” on page 2-13.

Supported Formats:

• GeoJSON (.geojson, .json)
• GPS Exchange (.gpx)
• OpenStreetMap® (.osm, .pbf)
• Shapefile (.shp, .dbf, .prj)
• Keyhole Markup Language (.kml, .kmz)

Refer to “Vector Data Tool” on page 5-162 for instructions on adding and adjusting vector data in
your scene.

Refer to the “Library Browser” on page 2-13 page for general instructions to create, edit, and delete
assets.

 Vector Data Assets

4-37



Image File Types
RoadRunner supports a variety of image file types. These file types are used for assets such as the
“Texture Assets” on page 4-35.

The supported image file types are:

• Bitmap (.bmp)
• DEM (.dem) - typically used only for “Aerial Image Assets” on page 4-2 or “Elevation Map Assets”

on page 4-4
• GIF (.gif)
• GTX (.gtx)
• ICO (.ico)
• IMG (.img)
• JPEG 2000 (.jp2)
• JPEG (.jpg, .jpeg)
• PPM / PGM / PBM (.ppm, .pgm, .pbm)
• PNG (.png)
• RGB (.rgb, .rgba)
• SVG (.svg, .svgz)
• TGA (.tga)
• TIF / GeoTIFF (.tif, .tiff)
• WEBP (.webp)
• X Bitmap Graphic (.xbm)
• X PixMap (.xpm)
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Point Editing

Some RoadRunner objects, such as prop instances, are modeled as points. This topic provides
common steps to create, destroy, and modify these point instances.

For general information about selecting and deleting objects, see “Fundamentals”.

Create a New Point
1 Select the point tool that corresponds to the type you want to create (for example, select the

“Prop Point Tool” on page 5-90 for editing prop point instances).
2 Some tools will require an appropriate asset to be selected in the “Library Browser” on page 2-13

before a curve can be created (for example, select a Prop Model Asset on page 4-17 if you are
creating a prop instance).

3 Right-click to create a point. The new point is automatically assigned to the selected asset.
4 Optional: Continue holding the mouse button and drag to move the point after initial creation.

Move a Point
1 Select the point tool that corresponds to the type you want to modify (for example, select the

“Prop Point Tool” on page 5-90 for editing prop point instances).
2 Click and drag a point to move it to a new location.
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Curve Editing

Some RoadRunner data models are built on top of curve sequences, including roads, prop curves, and
marking curves. This topic provides common steps to create, destroy, and modify these curve
instances.

For general information about selecting and deleting objects, see “Fundamentals”.

Create a New Curve
1 Select the curve tool that corresponds to the type you want to create (for example, select the

“Marking Curve Tool” on page 5-72 if you want to build a marking curve).
2 Some tools will require an appropriate asset to be selected in the “Library Browser” on page 2-13

before a curve can be created (for example, select a Lane Marking Asset on page 4-8 to create a
marking curve).

3 Ensure that no objects are selected (for example, by using the Edit > Deselect All option in the
“Menu Bar” on page 2-8).

4 Right-click (and optionally drag) to create a curve with a single starting point. The new curve will
automatically be assigned the selected asset.

5 Right-click (and optionally drag) to extend the curve by adding additional control points.

Extend a Curve at Its Ends by Adding Control Points
1 Select the curve tool that corresponds to the type you want to modify (for example, select the

“Marking Curve Tool” on page 5-72 to build a marking curve).
2 Select the curve you want to edit.
3 Click a control point at the end that you want to extend.
4 Right-click (and optionally drag) to add an additional control point.
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Add Control Points to the Interior of a Curve
1 Select the curve tool that corresponds to the type you want to modify (for example, select the

“Marking Curve Tool” on page 5-72 to build a marking curve).
2 Select the curve you want to edit.
3 Right-click (and optionally drag) the curve at the location where you want to insert a new control

point.

Move a Control Point
1 Select the curve tool that corresponds to the type you want to modify (for example, select the to

“Marking Curve Tool” on page 5-72 build a marking curve).
2 Select the curve you want to edit.
3 Click and drag a control point to move it to a new location.

Change the Tangents of a Curve
See “Tangent Editing” on page 5-7.
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Polygon Editing

Some RoadRunner data models are polygon based, such as prop and marking polygons. This topic
provides common steps to create, destroy, and modify these polygon instances.

For general information about selecting and deleting objects, see “Fundamentals”.

Create a New Polygon
1 Select the polygon tool that corresponds to the type you want to create (for example, select the

“Marking Polygon Tool” on page 5-76 to build a marking polygon).
2 Some tools require an appropriate asset to be selected in the “Library Browser” on page 2-13

before a polygon can be created (for example, select a Polygon Marking Asset on page 4-12 if you
are creating a marking polygon).

3 Ensure that no objects are selected (for example, by using the Edit > Deselect All option in the
“Menu Bar” on page 2-8).

4 Right-click (and optionally drag) to create a polygon with a single starting point. The new
polygon will automatically be assigned the selected asset.

5 Right-click (and optionally drag) to extend the polygon and add additional control points.

Add Control Points to a Polygon
There are two ways to add control points to a polygon.

Insert a Control Point Next to an Existing Point

1 Select the polygon tool that corresponds to the type you want to modify (for example, select the
“Marking Polygon Tool” on page 5-76 to build a marking polygon).

2 Select the polygon you want to edit.
3 Select a control point next to the point you want to add.
4 Right-click (and optionally drag) to add additional control points.
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Insert Control Points by Splitting a Polygon Edge

1 Select the polygon tool that corresponds to the type you want to modify (for example, select the
“Marking Polygon Tool” on page 5-76 if you want to build a marking polygon).

2 Select the polygon you want to edit.
3 Right-click (and optionally drag) the polygon edge where you want to insert a new control point.

Move a Control Point
1 Select the polygon tool that corresponds to the type you want to modify (for example, select the

“Marking Polygon Tool” on page 5-76 to build a marking polygon).
2 Select the polygon you want to edit.
3 Click and drag a control point to move it to a new location.

Change the Tangents of a Polygon
See “Tangent Editing” on page 5-7.
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Tangent Editing

Some RoadRunner data models are built on top of curves and curve sequences, including roads, prop
curves and polygons, marking curves and polygons, and the terrain surface graph. The control points
of these curves contain tangents that can be adjusted to smooth or kink the resulting boundaries.
This topic provides common steps for editing tangents and enforcing tangent continuity.

Adjust a Tangent
1 Click the parent object to expose the tangent views.

Note  For some data types, such as road height profiles, the tangents are exposed once the
parent is selected.

For other data types, such as curves or polygons, this might require clicking the parent object
first to expose the control points.

2 Click the end point of the tangent handle.
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3 Click and drag to set the direction and scale of the tangent.

Make Tangents Continuous
To automatically enforce continuity, use the Connect Tangents operation:

1 Click the parent object to expose the tangent views.
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Note  For some data types, such as road height profiles, the tangents are exposed once the
parent is selected.

For other data types, such as curves or polygons, this might require clicking on the parent object
first to expose the control points.

2

Click the Connect Tangents button. 

Tangents will now be enforced, even through additional edits.

 Tangent Editing

5-9



Make Tangents Discontinuous
To remove automatic continuity constraints, use the Disconnect Tangents operation:

1 Click the parent object to expose the tangent views.

Note  For some data types, such as road height profiles, the tangents are exposed once the
parent is selected.

For others, such as curve or polygons, this might require clicking the parent object first to expose
the control points.

2

Click the Disconnect Tangents button. 
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Span Editing

Various attributes are represented as parametric spans along lanes, roads, and other objects. This
topic provides common steps to create, destroy, and modify these span instances. Various tools use
span editing concepts, such as the “Lane Marking Tool” on page 5-53, “Prop Span Tool” on page 5-
93, or “Road Construction Tool” on page 5-96.

Span Overview
Span-based attributes are defined by the following components.

Parent Object

Span-based attributes are defined parametrically along a curve-based parent object. Typically, the
parent object is either a road (as in the “Road Construction Tool” on page 5-96) or a lane (as in the
“Lane Marking Tool” on page 5-53).

Span Nodes

Span nodes (red circles) selected in the “Lane
Marking Tool” on page 5-53. These nodes
indicate locations where the marking type
changes along the lane.

Span nodes (red lines) selected in the “Road
Construction Tool” on page 5-96. These nodes
indicate where bridges start and end along a
road.

Span nodes are parametric objects along a parent curve that define where attribution changes. The
visual representation of nodes differs depending on the tool (as shown in the previous images).

Span nodes can be moved along the parent curve. Nodes can also be added along a curve, and
existing nodes can be deleted.

Node locations are automatically updated when the parent curve is modified (for example, when the
parent road's shape is changed).
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Span End Nodes

Span end nodes selected in the “Road Construction Tool” on page 5-96.

Span end nodes are a special type of span node that lie at the beginning and end of the parent curve.
For most types of span-based attributes, these span end nodes are automatically created and cannot
be deleted.

Spans

Span selected in the “Lane Marking Tool” on
page 5-53. This span defines the lane marking
type between two nodes.

Span selected in the “Road Construction Tool” on
page 5-96. This span defines the construction
type (for example, bridge) between two nodes.

A span is a range along a parent curve bounded by two span nodes. For most types of span-based
attributes, the span is automatically created between the span end nodes and cannot be deleted.

Select a Span or Span Node
The steps to select a span differ slightly depending on the tool, but the steps are typically similar to
the following.

1 Select the parent object containing the span (typically either a road or a lane on a road).
2 Select the desired span or span node.

Create a New Span Node
New span nodes are created by splitting a span into two spans.

1 Select the parent object containing the span.
2 Right-click an existing span at the location where you want to insert the new node.

Note  In most cases, any attributes stored in the span are copied into the two new spans.
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Edit Attributes of a Span or Span Node
1 Select a span or span node.
2 Adjust the properties in the “Attributes Panel” on page 2-20.

Alternatively, for asset-based attributes such as in the “Lane Marking Tool” on page 5-53 and “Prop
Span Tool” on page 5-93, click and drag a compatible asset type from the “Library Browser” on page
2-13 to the span or span node.

Note  Some span-based attributes only store data on the spans, others only store data on the span
nodes, and some store data on both.

Span nodes always have a "Distance" attribute that defines the distance of the node along the parent
curve.

Move a Span Node
1 Select the parent object containing the span.
2 Click and drag the node along the parent curve.

Alternatively:

1 Select the parent object containing the span.
2 Select the span node.
3 Adjust the "Distance" attribute in the “Attributes Panel” on page 2-20.

Note  Most span nodes cannot be moved past another node, and must remain a minimum distance
from surrounding nodes.

Delete a Span Node
1 Select the parent object containing the span.
2 Select the span node.
3 Delete the span node.

Tips for Deleting Nodes
• In most cases, the span end nodes (the nodes at the end of the parent curve) cannot be deleted.
• Deleting a span node combines the two attached spans into a single span. In most cases, the

single span receives the attributes of the longer span. The shorter span is removed.
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Region Graph Editing

Some RoadRunner data models are built on top of graphs of curve-bounded regions. This topic
provides common steps to create, destroy, and modify these region graphs.

Many of the editing concepts for region graphs are similar to the concepts for “Curve Editing” on
page 5-3. For example, you can create, edit, and delete curve-based graph edges that behave like
most curves in RoadRunner.

Region graphs differ in two regards:

• Edge Connectivity: Graph edge curves can be connected end-to-end.
• Regions: Whenever a closed loop of graph edges is formed, a region is created in the interior.

Refer to the “Fundamentals” page for general information about selecting and deleting objects.

Create a Graph Edge Curve
1 Select the graph region tool that corresponds to the type you want to create (for example, select

the “Surface Tool” on page 5-151 if you want to edit surfaces).
2 If you want to start the new edge at an existing node, select the existing node. Otherwise:

a Ensure that no objects are selected (for example, by using the Edit > Deselect All option in
the “Menu Bar” on page 2-8).

b Right-click (and optionally drag) to create an initial graph node.
3 Optional: Move the pointer over an existing node if you want to end the curve at that node.
4 Right-click (and optionally drag) to create a second graph node and a graph edge curve in

between.

Split a Graph Edge Curve
1 Select the graph region tool that corresponds to the type you want to create (for example, select

the “Surface Tool” on page 5-151 to edit surfaces).
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2 Right-click a graph edge curve to split it into two curves.

Move a Graph Node
1 Select the graph region tool that corresponds to the type you want to create (for example, select

the “Surface Tool” on page 5-151 to edit surfaces).
2 Click and drag the graph node you want to move.

Change the Tangents of a Graph Edge Curve
See “Tangent Editing” on page 5-7.

Create a Region
Regions are automatically created whenever a closed loop of graph edges is formed:

Sequence of connected graph edge curves (no
region)

Region is automatically created when the open
ends are connected.

Split a Region
Each closed loop of graph edges automatically forms a region, so one region can be split into two by
forming a path of graph edge curves between two of the points on the region exterior:

Single region Region is automatically split into two regions
when two closed loops are formed.
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Regions With Holes
Only the “Surface Tool” on page 5-151 fully supports holes.
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Aerial Imagery Tool

The Aerial Imagery Tool manages the import and configuration of aerial imagery files. RoadRunner
can import geolocated aerial imagery for use as a visual reference and for texture mapping onto
surfaces. Geolocated imagery files can be imported through a variety of common formats, such as
GeoTIFF (.tif, .tiff) and JPEG 2000 (.jp2), which contain the necessary map projection information to
accurately position them on the Earth's surface.

Refer to the “Aerial Image Assets” on page 4-2 page for a list of the supported file types.

This tool can also be used to import and adjust nongeoreferenced imagery (for example, JPG
screenshots).

Multiple images can be imported for an area to provide full coverage. This might cause some of the
imported maps to overlap in certain regions. The priority of each image can be adjusted to determine
which one takes priority in overlapping areas.

For links and examples about obtaining GIS data compatible with RoadRunner, see “GIS Data
Resources for RoadRunner” on page 8-13.

Import a Georeferenced Aerial Image
1 Click the Aerial Imagery Tool button.
2 In the “Library Browser” on page 2-13, navigate to the directory containing the aerial image on

page 4-2 file you want to import.
3 Right-click the asset and make sure that the Default Type is set to Aerial Image.
4 Click and drag the asset from the Library Browser into the 3D scene.

Note If the geographic position has not yet been set for this scene, the scene center is set to the
latitudinal and longitudinal center of the image. You can change the scene center using the “World
Settings Tool” on page 5-165.

If the geographic position has already been set, but the imported image is outside of the maximum
range of the scene, an error dialog box appears and cancels the import.

Import a Nongeoreferenced Aerial Image
To correctly display satellite imagery in RoadRunner, the program must know how to position the
image on the Earth. Obtaining satellite imagery that contains geolocation information (by using a
format such as GeoTIFF or JPEG 2000) is strongly recommended. For links and examples about
obtaining GIS data compatible with RoadRunner, see “GIS Data Resources for RoadRunner” on page
8-13.

If your imagery does not have geolocation information, it is possible to manually set geolocation
information using the following steps.
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If You Already Know the Projection

If you already know the specific projection to be used (that is, you have a 'proj' or 'wkt' projection
string), you can set it on the file as follows:

1 Click the Aerial Imagery Tool button.
2 In the “Library Browser” on page 2-13, navigate to the directory containing the image file you

want to import.
3 Right-click the file asset and make sure that the Default Type is set to Aerial Image.
4 Click the Set Custom Projection button in the “Attributes Panel” on page 2-20.
5 Paste your 'proj' or 'wkt' string into the text field.
6 Click OK.
7 Scale the image by adjusting the Resolution to match the meters per pixel of the image.

8 Click and drag the image asset from the Library Browser into the 3D scene.

If You Do Not Know the Projection

If you do not know the projection, you can experimentally try different projection values on the file.
These instructions apply a Transverse Mercator projection to the file.

These steps enable you to use arbitrary images, such as a screenshot from a separate application.
However, the result will not be highly accurate.

1 Click the Aerial Imagery Tool button.
2 In the “Library Browser” on page 2-13, navigate to the directory containing the image file you

want to import.
3 Right-click the file asset and make sure that the Default Type is set to Aerial Image.
4 Press the Set Custom Projection button in the “Attributes Panel” on page 2-20.
5 Determine the latitude and longitude of the center point of your image, then adjust the latitude

and longitude values in the Custom Projection window, beside the Use Transverse Mercator At
button, to match.
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6 Click Use Transverse Mercator At. Then, click OK.
7 Scale the image by adjusting the Resolution to match the meters per pixel of the image.

8 Click and drag the image asset from the Library Browser into the 3D scene.

Remove an Aerial Image
1 Click the Aerial Imagery Tool button.
2 Click the aerial image you want to delete. The selected image is highlighted with a red bounding

box.
3 Press the Delete key or select Edit > Delete from the Main Menu.

Adjust the Resolution of the Loaded Aerial Imagery
1 Click the Aerial Imagery Tool button.
2 Under the Global Aerial Imagery Settings in the Attributes Panel, adjust the Meters Per Texel

value as desired.

Adjust the Properties of an Aerial Image
1 Click the Aerial Imagery Tool button.
2 Click the aerial image you want to edit.
3 Adjust the aerial image attributes as desired through the Attributes Panel.

Note  When more than one aerial image overlaps at a location, the system needs to decide which one
to use. Selecting an aerial image and clicking the Push to bottom or Bring to top buttons in the
Attributes Panel adjusts a particular image's priority to resolve overlaps.

Assign an Aerial Imagery Material to a Surface
By default, aerial imagery is displayed only as a visual reference. You can optionally apply the aerial
imagery to terrain surfaces by creating a new material and applying it to the surfaces.
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Create a New Material

1 Click the Aerial Imagery Tool button. The global aerial imagery settings appear in the
Attributes Panel.

2 Press the Generate Material button in the Attributes Panel.

This action generates a new image file called "Overlay.png" and a new material file called
"Overlay.rrmtl" inside the current directory within the Library Browser. It is necessary for the system
to create a new image because the original aerial imagery might be in an incompatible projection or
made up from multiple separate images. The Generate Material operation combines the multiple
aerial images into one final image that can be mapped orthographically to the terrain surface.

Assign the Material to One or More Surfaces

1 Click the Surface Tool button.
2 Click and drag the material to assign it to a surface.

Toggle Display of Aerial Imagery
Select View > Aerial Imagery on the Main Menu or press the F4 key.

Tips for Aerial Images in Large Areas
RoadRunner renders aerial images with a single texture image. In some cases, the size of the texture
exceeds the maximum size supported by the graphics card and the imagery fail to render. This
situation can be accompanied by an error message similar to this one:

ERROR: Unable to load overlay: Max byte count exceeded. Max: 16k x 16k texels
with 4 channels.

Here are a few tips that can help with handling imagery of large areas.

Ensure Your Workspace Size Is No Larger Than Needed

The portion of the image that is loaded is determined by the Workspace and World Origin settings
in the “World Settings Tool” on page 5-165. Ensure that your workspace covers only your area of
interest.

In particular, if you georeferenced your scene by dragging an Aerial Image Asset on page 4-2 into the
scene, the scene is centered on the middle of the image. If you care only about a portion of the scene
in the corner of the image, do not just increase the workspace extents. Instead, try one of the
following:

• Set your latitudinal and longitudinal center of interest (using the “World Settings Tool” on page 5-
165) before dragging in the aerial image.

• Move the workspace to the center of interest (using the “World Settings Tool” on page 5-165) and
then adjust the extents to cover the area of interest. Imagery is loaded only within the workspace
extents.

Decrease the Imagery Sampling Rate

The Meters Per Texel option in the Aerial Imagery Tool controls the sampling rate of the imagery.
Increase this value to enable viewing of larger areas at the expense of lower image quality.
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Adjust the Workspace as You Work

If you have high-resolution imagery and want to create a large area, you can adjust the workspace
based on the current area you are working on. For example, you can adjust the workspace to cover
the northwest portion of your area when you need to edit the northwest area. Then, you can adjust
the workspace again when you need to work on the northeast area.

If you use this approach, be sure to increase the workspace to cover your entire area when you
export.
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Corner Tool

The Corner Tool is used to adjust the shape and materials of junction corners.
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Cross Section Tool

The Cross Section Tool allows you to edit the shape of the road cross section in order to manipulate
super-elevation (banking), crowning, curb shapes, and sidewalk heights.

By default, all roads have a cross section defined at the start and the end of the road. New cross
sections can be added at arbitrary points along the road. These cross section nodes can be
individually edited and the resulting road interpolates the shape between nodes.

View the Cross Section at Any Location Along a Road
1 Click the Cross Section Tool button.
2 Click the road you want to view.
3 Move the pointer along the road to view the cross section at any location.

Insert a New Cross Section
1 Click the Cross Section Tool button.
2 Click the road you want to edit.
3 Right-click the road at the location you want to add a new cross section node.

Delete a Cross Section
1 Click the Cross Section Tool button.

5 Tools

5-24



2 Click the road you want to edit.
3 Press the Delete key or select Edit > Delete from the Main Menu.

Move a Cross Section Along the Road
1 Click the Cross Section Tool button.
2 Click the road you want to edit.
3 Click and drag the cross section to a new location along the road. Note that you cannot drag a

cross section past another cross section and you cannot drag a cross section past the start or end
of a lane.

Alternatively:

1 Click the cross section node you want to move and open the node properties display on the
Attributes Panel.

2 Select the Distance property and enter the desired distance along the road to locate the cross
section. Note that entering a value for the distance has the same restrictions as manually
dragging.

Modify the Shape of a Cross Section
To modify the shape of a cross section (super-elevation, crowning, and so on):

1 Click the Cross Section Tool button.
2 Click the road you want to edit.
3 Click the cross section node you want to edit. The details of the node shape display in the 2D

View Panel.
4 Click and drag points in the 2D View Panel to adjust the cross section gradient. Note that the

midpoint is fixed and cannot be adjusted.

Alternatively:

1 Click in the 2D View Panel on the line segment corresponding to the lane you want to adjust.
2 Select the Slope value on the Attributes Panel, and enter the desired cross section slope for the

selected lane.
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Crosswalk And Stop Line Tool

The Crosswalk and Stop Line Tool can be used to add crosswalks and stop lines between corners at
intersections.

Note  Free-form crosswalks can be created using the “Marking Curve Tool” on page 5-72. Where
possible, use the Crosswalk And Stop Line Tool instead. Crosswalks and stop lines created in this tool
have more semantic linkage to the road topology.

Add a Single Crosswalk to a Junction
1 Click the Crosswalk and Stop Line Tool button.
2 Optionally, select a desired crosswalk style in the “Library Browser” on page 2-13.
3 Click the corner of a junction that you want the crosswalk to start from.
4 Right-click the corner that you want the crosswalk to end at (in the same junction).

Tip  If you need to create a standalone crosswalk (that is, a crosswalk along a road that does not
involve an intersection), you can use the “Custom Junction Tool” on page 5-31 to create a junction
along a single road.

You can also create free-form crosswalks anywhere in your scene using the “Marking Curve Tool” on
page 5-72 (with a Crosswalk Marking Asset on page 4-3 selected). Note that free-form crosswalks
might lack certain export-related functionality.

Quickly Add All Crosswalks to a Junction
1 Click the Crosswalk and Stop Line Tool button.
2 Check that no junctions are selected.
3 Optionally, select a desired crosswalk style in the “Library Browser” on page 2-13.
4 Right-click a junction to add crosswalks across each road.
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Delete a Crosswalk
1 Click the Crosswalk and Stop Line Tool button.
2 Select a crosswalk.
3 Press the Delete key or select Edit > Delete from the “Menu Bar” on page 2-8.

Assign a Style to a Crosswalk
1 Enter the Crosswalk and Stop Line Tool.
2 Select the crosswalk you want to edit.
3 Click and drag a Crosswalk Marking Asset on page 4-3 from the “Library Browser” on page 2-13

onto the Crosswalk Style widget in the “Attributes Panel” on page 2-20.

Alternatively, click and drag a Crosswalk Marking Asset on page 4-3 from the “Library Browser” on
page 2-13 onto a crosswalk in the scene.

Adjust the Location of a Crosswalk
After creating a crosswalk, you can move the locations of the crosswalk's end points (for example, to
create crosswalks that cross a road at an angle).

1 Click the Crosswalk and Stop Line Tool button.
2 Select the crosswalk you want to edit.
3 Click and drag a point at the end of the crosswalk. Alternatively, adjust the Left Corner Offset

and Right Corner Offset values in the “Attributes Panel” on page 2-20.

 Crosswalk And Stop Line Tool

5-27



Note  The points at the end of a crosswalk must lie within the extents of the junction. Note that you
can expand the extents of a junction by extending the corners using the “Corner Tool” on page 5-23.

Stopping Locations
Stopping locations are computed for all lanes approaching a junction. Stopping locations define the
starting location of all maneuvers.

Stopping locations shown as blue chevrons:

View Stopping Locations for a Junction
1 Click the Crosswalk and Stop Line Tool button.
2 Select the junction you want to edit.
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Add Stop Lines to a Junction
Preview shows where stop line will appear: The new stop line updates the stopping

locations:

1 Click the Crosswalk and Stop Line Tool button.
2 Select the junction you want to edit.
3 Right-click the road at the location where you want to add a new stop line node.

Stop Line Editing
1 Click the Crosswalk and Stop Line Tool button.
2 Select the junction you want to edit.
3 Stop line editing is similar to marking curves. See “Marking Curve Tool” on page 5-72 for

documentation on how to edit stop lines.

Multiple Stop Lines
Multiple stop lines can be added to a single approach to add unique stopping locations for each lane.
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Custom Junction Tool

The Custom Junction Tool is used to override the RoadRunner automatic junction functionality for
advanced cases. It enables the creation of junctions where no overlaps are present. Junctions that are
automatically created by RoadRunner are referred to as automatic junctions. These junctions are
automatically created, updated, and removed as necessary. Junctions that are manually created by
this tool are referred to as locked junctions. These junctions are manually created and must be
manually removed. It is sometimes desirable to convert an automatic junction to a locked junction,
either to add more roads to the junction or to change the default stop locations.

The default stop location represents the start or end of a junction along a road. It is the location
where newly created maneuver roads automatically stop and the default distance where corners
begin. The default stop location has a direction that points out from the junction. This direction is
used for determining which roads need to be connected by using corners.

Create a Junction Between Roads That Do Not Overlap

1 Click the Custom Junction Tool button.
2 Right-click the end of each road that will be part of the junction.
3 Press Spacebar to create the junction.

Remove a Locked Junction
1 Click the Custom Junction Tool button.
2 Click the desired junction.
3 Press Delete.

Note  Removing a locked junction can result in an automatic junction in its place if roads are
overlapping.
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Convert an Automatic Junction to a Locked Junction
1 Click the Custom Junction Tool button.
2 Click the desired junction.
3 In the Attributes Panel, press Convert to Locked Junction.

Convert a Locked Junction to an Automatic Junction
1 Click the Custom Junction Tool button.
2 Click the desired junction.
3 In the Attributes Panel, press Convert to Automatic Junction.

Note  A locked junction cannot always be converted to an automatic junction. If no automatic
junction is possible, the junction will be removed during conversion.

Add a Road to a Locked Junction
1 Click the Custom Junction Tool button.
2 Right-click the end of the road to add to the junction.
3 Right-click the junction.
4 Press Spacebar to add the road.

Remove a Road from a Locked Junction
1 Click the Custom Junction Tool button.
2 Click the desired junction.
3 Click the Default Stopline of the road that you want to remove.
4 Press Delete.

Create a Junction Between Two Parallel Roads
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1 Click the Custom Junction Tool button.
2 Right-click at the start of the junction on one road and then the end of the junction on the same

road.
3 Right-click at the start of the junction on the other road and then the end of the junction on the

same road.
4 Press Spacebar to create the junction. If the corners do not appear correctly, see the

Troubleshooting Locked Junctions section.

Merge Two or More Junctions

1 Click the Custom Junction Tool button.
2 Right-click each junction to be merged.
3 Press Spacebar to merge the junctions together.
4 Click any extraneous default stop lines on the inside of the junction and press Delete.

Create a Junction Along a Single Road

Creating junctions along a single road is useful for creating standalone crosswalks. To create a
junction along a single road:

1 Click the Custom Junction Tool button.
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2 Right-click the road at the start of the junction and at the end of the junction. If you are making a
crosswalk, the start and end of the junction roughly correspond to each side of the crosswalk.

3 Press Spacebar to create the junction. If the junction does not appear correctly, see the
Troubleshooting Locked Junctions section.

4 Optionally, if you are making a crosswalk:

a Select the Crosswalk Tool.
b Click the outer side of the junction.
c Right-click the other side of the junction to create the crosswalk.

Adjust a Default Stop Location
1 Click the Custom Junction Tool button.
2 Click the desired junction.
3 If the junction is automatic, convert the junction to locked.
4 Click and drag the desired stop location.

Change the Direction of a Default Stop Location
1 Click the Custom Junction Tool button.
2 Click the desired junction.
3 Click the desired default stop location.
4 Press Flip Direction in the Attributes Panel.

Troubleshooting Locked Junctions
RoadRunner attempts to make a reasonable locked junction based on the specified default stop
locations, but the software might be unable to determine the necessary corners to make a reasonable
junction. Here are a few steps to take if a locked junction's corners are not computed correctly:

• Check that all default stop locations point outward from the junction. If a default stop location has
been placed manually on a road, the initial direction might be flipped.

• Check that the default stop locations are not too close together. Try dragging the locations farther
apart and pressing Sort Rays to redetermine the corners.

• Try using multiple smaller locked junctions instead of one large one. Remove roads from the
junction as necessary.

• Try using overlaps instead of making the junction manually.
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Elevation Map Tool

The Elevation Map Tool manages the import and configuration of DEM elevation files. RoadRunner
can import elevation map data from a variety of file formats, such as DEM, IMG, JPEG 2000, and TIFF.
Some of these formats support georeferencing and can be automatically positioned accordingly.

Refer to the “Elevation Map Assets” on page 4-4 page for a list of the supported file types.

Multiple elevation maps can be imported for an area to provide full coverage. This can cause some of
the imported maps to overlap in certain regions. You can adjust the priority of each map to determine
which one takes priority in overlapping areas.

Import a Georeferenced Elevation Map
1 Click the Elevation Map Tool button.
2 In the “Library Browser” on page 2-13, navigate to the directory containing the “Elevation Map

Assets” on page 4-4 you want to import.
3 Right-click the assets and make sure that the Default Type is set to Elevation Map.
4 Click and drag the assets from the “Library Browser” on page 2-13 into the “3D Edit Window” on

page 2-11.

Note If the geographic position has not yet been set for this scene, the scene center is set to the
latitudinal and longitudinal center of the image. You can change the scene center using the “World
Settings Tool” on page 5-165.

If the geographic position has already been set, but the imported image is outside of the maximum
range of the scene, an error dialog box appears and cancels the import.

Import a Nongeoreferenced Elevation Map
To correctly display an elevation map in RoadRunner, the program must know how to position the
map on the Earth. For best accuracy, obtaining elevation data that contains geolocation information
(by using a format such as GeoTIFF or JPEG 2000) is strongly recommended. For links and examples
about obtaining GIS data compatible with RoadRunner, see “GIS Data Resources for RoadRunner” on
page 8-13.

If your elevation map does not have geolocation information, it is possible to manually set geolocation
information using the following steps.

If You Already Know the Projection

If you already know the specific projection to be used (that is, you have a 'proj' or 'wkt' projection
string), you can set it on the file as follows:
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1 Click the Elevation Map Tool button.
2 In the “Library Browser” on page 2-13, navigate to the directory containing the elevation map file

you want to import.
3 Right-click the file asset and make sure that the Default Type is set to Elevation Map.
4 Click the Set Custom Projection button in the “Attributes Panel” on page 2-20.
5 Paste your 'proj' or 'wkt' string into the text field.
6 Click OK.
7 Scale the data by adjusting the Resolution to match the meters per pixel of the elevation map.

8 Click and drag the elevation map asset from the Library Browser into the 3D scene.

If You Do Not Know the Projection

The following steps enable you to use arbitrary grayscale images for elevation, such as a screenshot
from a separate application. However, the result will not be highly accurate.

If you do not know the projection, you can experimentally try different projection values on the file.
These instructions apply a Transverse Mercator projection to the file.

1 Click the Elevation Map Tool button.
2 In the Library Browser, navigate to the directory containing the image file you want to import.
3 Right-click the file asset and make sure that the Default Type is set to Elevation Map.
4 Click the Set Custom Projection button in the Attributes Panel.
5 Determine the latitude and longitude of the center point of your elevation data. Then, adjust the

latitude and longitude values in the Custom Projection window to match.

6 Click Use Transverse Mercator At. Then, click OK.
7 Scale the data by adjusting the Resolution to match the meters per pixel of the image.
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8 Click and drag the elevation map asset from the Library Browser into the 3D scene.

Remove an Elevation Map
1 Click the Elevation Map Tool button.
2 Click the elevation map you want to delete.
3 Press the Delete key or select Edit > Delete from the Main Menu.

Adjust the Properties of an Elevation Map
1 Click the Elevation Map Tool button.
2 Click the elevation map you want to edit.
3 Adjust the elevation map attributes as desired through the Attributes Panel.

Note  When more than one elevation map overlaps at a location, the system needs to decide which
one to use. Selecting an elevation map and clicking the Push to bottom or Bring to top buttons in
the Attributes Panel adjusts a map's priority to resolve overlaps.

Toggle the Display of Elevation Maps
Select View > Elevation from the Main Menu, or press F5.

Project Roads and Other Objects to Elevation Maps
Many RoadRunner objects can be projected to an elevation map surface. The specific steps are
documented in the appropriate tools. For example, the steps for projecting roads to elevation maps
can be found here: Project Roads to Elevation Maps on page 5-105.

In most cases, the steps are the same:

1 Select the appropriate tool.
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2 Select one more objects in the “3D Edit Window” on page 2-11.
3 Click the appropriate projection button in the “Sub-Tool Bar” on page 2-10.

Include Elevation Maps in Surface Triangulation
By default, the elevation maps are displayed as a white topographic surface. This surface is not
included in the exported scene.

To include the visual influence of the elevation maps in the scene, you must create terrain surfaces on
page 5-151 covering the area, and then enable global elevation.

For more information, refer to Control Whether a Surface Uses Elevation Samples on page 5-159 .

Sample Global Elevation: Off
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Sample Global Elevation: On
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Junction Surface Tool

The Junction Surface Tool is used to control how road elevations and cross sections influence the
interior triangulation of the intersection.

View Road Samples Within a Junction

1 Click the Junction Surface Tool button.
2 Select a junction. This selection displays all the individual road surface spans that overlap the

junction.
3 Click a road span. When selected, a road span draws the portion of the road that overlaps the

junction and the samples that it includes.

Include or Exclude Samples from a Road Span
You can include or exclude samples from specific spans from the triangulation.

1 Click the Junction Surface Tool button.
2 Select a junction. This selection displays all the individual road surface spans that overlap the

junction.
3 Click a road span. When selected, a road span draws the portion of the road that overlaps the

junction and the samples that it includes.
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4 Toggle the Include Samples check box in the Attributes Panel to include or exclude the
samples.

Triangulation with Road Span Samples Included

Road Span Samples Toggled Off

 Junction Surface Tool

5-41



Triangulation with Road Span Samples Toggled Off

Change the Sorting of Road Span Samples
Sorting one span above another prevents the lower samples from being included.

1 Click the Junction Surface Tool button.
2 Select a junction. This selection displays all the individual road surface spans that overlap the

junction.
3 Click a road span. When selected, a road span draws the portion of the road that overlaps the

junction and the samples that it includes.
4 Press the Raise or Lower button in the Attributes Panel to raise or lower the Sort Index of the

selected road span relative to the others.
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Road Span with Occluded Samples

Road Span Samples Raised in Priority
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Neighboring Road Span Now Has Occluded Samples
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Lane Add Tool

The Lane Add Tool is used to add a fully formed lane along a road.

Note Note: To create a new forming lane or an ending lane, use the “Lane Form Tool” on page 5-
51.

Add a New Lane to a Road
1 Click the Lane Add Tool button.
2 Click the road you want to edit.
3 Select the desired lane type in the Options panel.

Note  If the lane type is set to Automatic, then the new lane copies the lane type of the
neighboring lane.

4 Move the pointer near where you want to add a lane until you see a light blue line indicating
where the new lane will be added. If you are pointing near the center reference curve of the
road, you can choose which side of the road the new lane will go by moving the pointer to one
side or the other of the center curve.

Note  By default, the new lane will be added only between the two nearest intersections. To
force the new lane to add along the entire road, hold the Ctrl key.
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5 Right-click to add a new lane.
6 Optionally, you can hold the right-click button down and drag to adjust the width of the new lane.
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Lane Carve Tool

The Lane Carve Tool is used to create a tapering cut in a lane, such as the dedicated turn lanes in a

median.

Carve a Tapering Cut Into a Lane
1 Click the Lane Carve Tool button.
2 Click the road you want to edit.
3 Move the pointer to where you want to start the carve. The lane highlights and a light blue point

indicates where the carving will start.
4 Right-click and drag the pointer to carve the lane. You can move up or down the road and left or

right along the lane to determine where the carving ends. A light blue curve indicates where the
carve will take place.

Note  A lane cut always starts at the boundary of a lane. It can end either at the opposite side of
the lane or in the middle of the lane.

5 When you have moved to the desired end location of the carve, release the right-click button.

Modify the Carve Location After Performing a Carve
If you have performed a lane carve and later want to change where the carve starts or ends, follow
the steps in Move the End of a Lane on page 5-62 and adjust the ends of a lane by using the Lane
Width Tool.

Depending on which end of the carve you are adjusting, you might need to move both the tapered end
of one lane and the width marker on the adjacent lane. These moves can be tricky, but the simplest
approach is to box select on page 3-11 both elements together before dragging.

This image shows a box selection of two UI elements together. After selecting, you can click and drag
them or adjust the Distance value in the “Attributes Panel” on page 2-20.
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Modify the Lane Widths After Performing a Carve
See the “Lane Width Tool” on page 5-58.
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Lane Chop Tool

The Lane Chop Tool can be used to cut a single lane into two lanes at a desired location. Chopping
does not have an immediately visible effect, but it enables you to make instantaneous changes in lane
properties or have lanes start or end abruptly.

Chop a Lane
1 Click the Lane Chop Tool button.
2 Click the road you want to edit.
3 Move the mouse cursor to the location you want to chop. You will see a light blue line indicating

where the chop operation will take place.
4 Right-click to chop the lane at the desired location.
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Lane Form Tool

The Lane Form Tool is used to add a forming or ending lane along a road.

Note  To create a fully formed lane, use the “Lane Add Tool” on page 5-45.

Add a New Lane to a Road
1 Click the Lane Form Tool button.
2 Click the road you want to edit.
3 Select the desired lane type in the Options panel.

Note  If the lane type is set to Automatic, then the new lane copies the lane type of the
neighboring lane.

4 Move the pointer near where you want to add a lane until you see a light blue line indicating
where the new lane will be added. If you are pointing near the center reference curve of the
road, you can choose which side of the road the new lane will go by moving the pointer to one
side or the other of the center curve.

By default, the new lane will be added only between the two nearest intersections. To force the
new lane to add along the entire road, hold the Ctrl key.
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5 Right-click and drag outward from the center of the road to create the new lane and adjust the
end of the tapering section.

6 Optionally, you can drag up or down the length of the road to switch between a forming lane and
an ending lane.
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Lane Marking Tool

The Lane Marking Tool adds linear markings to lane boundaries. To assign marking styles to a lane
marking, you must first create some marking styles in the Asset Browser. The RoadRunner sample
project has several common marking styles pre-defined in the Assets/Markings directory. You can
create and modify your own marking styles and add them to the project as well.

Create and Modify Lane Markings Along a Lane
See “Span Editing” on page 5-12.

Note  Lane marking spans store Lane Marking Asset on page 4-8 data, which can be directly
dragged onto a lane span from the “Library Browser” on page 2-13. This operation works in any tool.
The Lane Marking Tool is activated when the mouse is released.

Lane Marking Span Attributes
See Marking Curve Attributes on page 5-72.
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Lane Offset Tool

The Lane Offset Tool is used to adjust the location of the center lane of a road. This tool is nearly
identical to the Lane Width Tool, except that it operates only on the center lane. For more information
on usage, see the “Lane Width Tool” on page 5-58.
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Lane Split Tool

The Lane Split Tool is used to split a lane lengthwise into two lanes. Splitting a lane automatically
adds a default lane marking that can be changed or removed with the “Lane Marking Tool” on page 5-
53.

Split a Lane Lengthwise
1 Click the Lane Split Tool button.
2 Click the road you want to edit.
3 Move the pointer to the location you want to split. A light blue line indicates where the split

operation will take place.

By default, the lane split affects only the lane between the two nearest intersections. To force the
lane split to occur along the entire road, hold the Ctrl key.
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4 Right-click to split the lane.
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Lane Tool

The Lane Tool is used to delete lanes and make changes to lane attributes, such as the lane type and
travel direction.

Change Lane Type
1 Click the Lane Tool button.
2 Click the road containing the target lane.
3 Click a lane to display its attributes. The selected lane is highlighted in red.
4 Select a lane type in the “Attributes Panel” on page 2-20.

Change Lane Travel Direction
1 Click the Lane Tool button.
2 Click the road containing the target lane.
3 Click a lane to display its attributes. The selected lane is highlighted in red.
4 Select a travel direction in the “Attributes Panel” on page 2-20.

Delete a Lane
1 Click the Lane Tool button.
2 Click the road containing the target lane.
3 Click a lane.
4 Press the Delete key or select Edit > Delete from the Main Menu.
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Lane Width Tool

The Lane Width Tool is used to adjust lane widths at any location along a road. The width of
individual lanes can be varied across the entire lane or more locally at specified locations. Width
values are stored on lane width markers, which can be positioned independently along lanes. The
width of the lane on the sections between markers is interpolated from the marker widths.

All lanes will automatically have lane width markers at the beginning and end of the lane.

When the Lane Width tool is selected and a road is highlighted, all the lane width markers for the
road will be displayed.

Note  The Lane Width Tool does not allow adjustments to the center lane. To adjust the center lane,
use the “Lane Offset Tool” on page 5-54.

Create a New Lane Width Marker

1 Click the Lane Width Tool button.
2 Click the road you want to edit.
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3 Move the pointer over the lane where you want to insert the marker. A light blue line appears,
indicating where the marker will be inserted.

4 Right-click to add a new width marker.
5 Optionally, press the right-click button and drag to adjust the marker. If you initially right-click

near the lane boundary, you can drag the lane width at the marker. If you initially right-click near
the inside of the lane, you can drag the position of the width marker.

Adjust the Width at a Marker

1 Click the Lane Width Tool button.
2 Click the road you want to edit. The lane width markers will be displayed on the picked road.
3 Click and drag the point on the outer boundary of the width marker you want to edit.
4 Optionally, once the width marker is selected, you can type the desired width directly into the

Width slider in the “Attributes Panel” on page 2-20.

Adjust the Width of a Lane Section Between Two Markers

1 Click the Lane Width Tool button.
2 Click the road you want to edit. The lane width markers and lane boundary lines are displayed

for the selected road.
3 Click and drag the lane border curve to move it in or out. The action automatically adjusts the

markers at the start and end of the section.
4 Optionally, once the lane section is picked, you can type the desired width directly into the Width

slider in the “Attributes Panel” on page 2-20 to set the width at the start and end of the lane
section.

 Lane Width Tool

5-59



Adjust the Angle at a Marker

1 Click the Lane Width Tool button.
2 Click the road you want to edit. The lane width markers are displayed on the selected road.
3 Click a lane width marker. Two new angle points are displayed.
4 Click and drag an angle point to adjust the slope.
5 Optionally, once the angle point is picked, you can type the desired slope value directly into the

Slope slider in the “Attributes Panel” on page 2-20.

Create Sharp Angles

By default, the slope on either side of a lane width marker is kept continuous. You can create sharp
angles by disconnecting the slopes as follows:

1 Click the Lane Width Tool button.
2 Click the road you want to edit. The lane width markers are displayed on the selected road.
3 Click a lane width marker. Two new angle points are displayed.
4 Click the Disconnect Tangents button. The angle points are no longer kept continuous, and you

can control the slopes on either side independently.

Tip  When you click Disconnect Tangents, the slopes are always set to point at the next or previous
width marker, even if the slopes are already disconnected.
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Remove Sharp Angles

To convert a sharp angle into a smooth angle at a lane width marker, connect the slopes as follows:

1 Click the Lane Width Tool button.
2 Click the road you want to edit. The lane width markers are displayed on the selected road.
3 Click a lane width marker. Two new angle points are displayed.
4 Click the Connect Tangents button. The angle points are now kept continuous.

Move a Width Marker

1 Click the Lane Width Tool button.
2 Click the road you want to edit. The lane width markers are displayed on the selected road.
3 Click and drag near the middle of the line of the width marker that you want to move.
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Move the End of a Lane

1 Click the Lane Width Tool button.
2 Click the road you want to edit. The lane width markers will be displayed on the selected road.
3 Click and drag the horizontal tick at the end of the lane.

Note It can be difficult to select the horizontal tick because the UI favors selecting the width point at
the same location. Rather than clicking directly on the tick, move the pointer to the side of the tick
until the tick is highlighted in yellow.

Delete a Width Marker
1 Click the Lane Width Tool button.
2 Click the road you want to edit. The lane width markers and lane boundary lines are displayed on

the selected road.
3 Press the Delete key or select Edit > Delete from the Main Menu.

Note  You cannot delete the markers at the start or end of the entire lane.

Stacked and Unstacked Boundaries
Lane boundaries behave differently depending on whether they are stacked or not.

Stacked boundaries are offset from their neighboring lanes. In this way, adjusting a lane boundary
affects all lanes facing outward from the center lane.

When a boundary is not stacked, its width is determined as an offset from the road's center lane, not
its neighboring lanes.
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Set Stacked and Unstacked Behavior

1 Click the Lane Width Tool button.
2 Click the road containing the target lane.
3 Click a lane boundary to select it and display its attributes. The selected lane boundary is

highlighted in red.
4 Toggle the Stacked attribute in the “Attributes Panel” on page 2-20.

Moving a lane where the outermost boundary is stacked:
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Moving a lane where the outermost boundary is not stacked:
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Maneuver Tool

The Maneuver Tool enables the manipulation of the various individual maneuver roads (paths) within
a junction. These maneuver roads do not affect the geometry of the road model, but they do affect
traffic behavior. Maneuver roads export to formats such as OpenDRIVE®.

By default, maneuver roads are created automatically whenever roads cross in a junction, and by
default, the system will make reasonable assumptions about which roads should be connected by
maneuvers. However, it is occasionally necessary to add or remove maneuvers manually. The
Maneuver Tool gives you the power to do so.

Maneuver roads are similar to normal roads, but they have certain restrictions. Maneuver roads are
Slip Roads on page 5-146 at both ends, which means that their start and end locations and start and
end directions are constrained to align with the anchor roads that they are attached to.
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View Maneuver Roads Within a Junction

1 Click the Maneuver Tool button.
2 Select a junction. This selection displays all the individual maneuvers within the junction.

Maneuver Road Attributes
Attribute Description
Turn Type Identifies the semantic turn type for the

maneuver road (left turn, U-turn, and so on).

This type is computed automatically based on the
geometry of the junction, but there might be
some complex junctions where the type is
computed incorrectly (for example, a sharp left
turn is perceived as a U-turn).

This turn type affects the maneuver road's role in
junction signalization. See “Signal Tool” on page
5-130.
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Attribute Description
Lock Geometry See Enable/Disable Automatic Maneuver

Geometry on page 5-67.

Enable or Disable Automatic Maneuver Creation
By default, maneuver roads within a junction are automatically created or removed. Various
operations cause maneuver roads to be recomputed, such as moving road geometry, adding or
removing lanes, or changing lane travel directions.

Turn Automatic Maneuver Creation Off

Add a new maneuver road on page 5-68 or delete a maneuver road. These actions disable automatic
maneuver creation for the junction.

Turn Automatic Maneuver Creation On

1 Click the Maneuver Tool button.
2 Click the junction you want to examine. When a junction is selected, it displays all of the

individual maneuvers allowed within the junction.
3 Click Rebuild Maneuver Roads to recreate all maneuver roads and re-enable automatic

maneuver creation.

Enable or Disable Automatic Maneuver Geometry
By default, maneuver road geometry is automatically updated. Various operations cause maneuver
road geometry to be updated, such as moving road geometry or changing lane widths.

Turn Automatic Maneuver Geometry On

Perform an action that modifies the geometry of the maneuver road, such as adjusting the start/end
location of a maneuver road on page 5-69 or moving a maneuver road control point on page 5-70.
The geometry of that maneuver road locks and no longer updates automatically.

Alternatively, follow these steps:

1 Click the Maneuver Tool button.
2 Click the junction you want to examine. When a junction is selected, it displays all the individual

maneuvers allowed within the junction.
3 Click the maneuver road you want to edit.
4 Select the Lock Geometry check box.

Turn Automatic Maneuver Geometry Off

1 Click the Maneuver Tool button.
2 Click the junction you want to examine. When a junction is selected, it displays all the individual

maneuvers allowed within the junction.
3 Click the maneuver road you want to edit.
4 Clear the Lock Geometry check box.
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Add a New Maneuver Road

1 Click the Maneuver Tool button.
2 Click the junction you want to edit. All the individual maneuvers within the junction are

displayed.
3 Click the node point where you want the maneuver to begin.
4 Right-click the node point where you want the maneuver to end. The new maneuver road is

created and visible.
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Adjust the Start or End Location of a Maneuver Road

1 Click the Maneuver Tool button.
2 Click the junction you want to edit. All of the individual maneuvers within the junction will be

displayed.
3 Click the maneuver road you want to edit.
4 Click and drag the start or end line to adjust the shape of the maneuver road. Each line is

constrained to lie along the anchor road the line is attached to.
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Move a Maneuver Road Control Point

1 Click the Maneuver Tool button.
2 Click the junction you want to edit. All the individual maneuvers within the junction are

displayed.
3 Click the maneuver road you want to edit.
4 Click and drag the desired control point to move it. Because maneuver roads are Slip Roads on

page 5-146, the first and last control points are constrained to lie along a fixed direction.
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Insert a New Control Point Within an Existing Maneuver Road

If you need to define more complex trajectories through a junction, you can insert additional control
points as follows:

1 Click the Maneuver Tool button.
2 Click the junction you want to edit. All of the individual maneuvers within the junction will be

displayed.
3 Click the maneuver road you want to edit.
4 Move the pointer over the blue control line at the location you want to insert a node.
5 Right-click to insert a new node within the control line of the maneuver road.
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Marking Curve Tool

The Marking Curve Tool can be used to place straight or curved markings at arbitrary locations.

Marking curves show up on both road surfaces and terrain surfaces. They use the same linear
marking style assets as the “Lane Marking Tool” on page 5-53.

Although you can create free-form crosswalks with this tool, use the “Crosswalk And Stop Line Tool”
on page 5-26 where possible, because crosswalks created in that tool have more semantic linkage to
the road topology.

Edit Marking Curves
See “Curve Editing” on page 5-3.

Note  When creating a new marking curve, you must have a Lane Marking Asset on page 4-8 or
Crosswalk Marking Asset on page 4-3 selected in the Library Browser.

Marking Curve Attributes
Attribute Description
Marking Style The Lane Marking Asset on page 4-8 or

Crosswalk Marking Asset on page 4-3 assigned.
Flip Side If true, the order of the marking stripes is

reversed (for marking types with more than one
stripe).

Note that this value is initially computed based
on the neighboring lane travel directions when a
Lane Marking Asset on page 4-8 is assigned with
the “Lane Marking Tool” on page 5-53.

Start Blend Distance If nonzero, the start of the marking is gradually
faded to transparent over this distance.

Note that the start is dependent on the
digitization direction of the marking curve or
road.

This option has an effect only if the material's
diffuse texture contains transparent (nonopaque)
content.
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Attribute Description
End Blend Distance If nonzero, the end of the marking will be

gradually faded to transparent over this distance.

See the additional comments in "Start Blend
Distance".

Phase Shift This is used to offset dashed marking types along
the curve. This is useful for synchronizing the
spacing of dashes where two roads meet.

Color Color multiplied by the material color.
Material Material on page 4-10 to use for this marking

instance. If set, this will override the material in
the Lane Marking Asset on page 4-8. If not set,
the marking asset's material is used instead.

Texture Scale Scale to apply to each dimension of the marking's
texture coordinates.

Note Note that the texture coordinate space
depends on the value of the Curve Space
Texture option in the Lane Marking Asset on
page 4-8.

Texture Rotation If nonzero, specifies an additional rotation to
apply to the marking's texture coordinates.

Texture Offset If nonzero, specifies an additional offset to apply
to each dimension of the marking's texture
coordinates.

Sort Index When markings of any type overlap, this value is
used to determine which markings appear on top.
Given two overlapping markings, the marking
with the higher sort index is drawn on top.

Change the Marking on a Curve
1 Click the Marking Curve Tool button.
2 Select the marking curve you want to change.
3 Click and drag a Lane Marking Asset on page 4-8 or Crosswalk Marking Asset on page 4-3 from

the “Library Browser” on page 2-13 onto the Marking widget in the “Attributes Panel” on page
2-20.

Alternatively, click and drag a Lane Marking Asset on page 4-8 or Crosswalk Marking Asset on page
4-3 from the “Library Browser” on page 2-13 directly onto the desired marking curve. You do not
need to select the Marking Curve Tool first to perform this operation, because it works from any
tool. Once done, RoadRunner automatically enters the Marking Curve Tool and selects the changed
marking curve for further editing.
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Marking Point Tool

The Marking Point Tool enables you to place point markings (or stencils), such as arrows and words,
on road surfaces. Point markings can be added as either free-form markings, or anchored to the
center of a lane. Both “Stencil Marking Assets” on page 4-34 and “Texture Assets” on page 4-35 can
be used as point markings.

Stencil Markings and Texture Assets
Both “Stencil Marking Assets” on page 4-34 and “Texture Assets” on page 4-35 can be used as point
markings. The distinctions are as follows.

Stencil Marking Assets

The marking outline is a group of polygons defined by the polygons in the SVG file. This results in
more geometry, but less overdraw when rendering. No alpha channel is required.

“Stencil Marking Assets” on page 4-34 also support optional materials to fill the interior of the
polygonal region.

Texture Assets

The marking outline is a rectangle. This allows any image file on page 4-38 to be used as a point
marking, but requires an alpha channel and more rendering overdraw to control the transparent
portions of the marking.

Create a Road Point Marking Anchored to a Lane
1 Click the Marking Point Tool button.
2 Select a Stencil Marking Asset on page 4-34 or Texture Asset on page 4-35 in the “Library

Browser” on page 2-13.
3 Move the pointer over the center of a lane. A lane center curve is displayed.
4 Right-click to add a new road point marking and anchor it to the lane.

Alternatively, click and drag a Stencil Marking Asset on page 4-34 from the “Library Browser” on
page 2-13 onto the center curve of the desired lane.

Note  This operation works from any tool. Once done, it automatically selects the Marking Point Tool
and selects the new point marking for further editing.
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Create a Free-Form Road Point Marking
1 Click the Marking Point Tool button.
2 Select a Stencil Marking Asset on page 4-34 or Texture Asset on page 4-35 in the “Library

Browser” on page 2-13.
3 Check that the point is not over the center of a lane. The lane center curve must not display.
4 Right-click to add a new free-form road point marking.

Move a Road Point Marking Anchored to a Lane
1 Click the Marking Point Tool button.
2 Click and drag the marking you want to move to the desired location. The marking slides along

the center of the lane.

Move a Road Point Marking
1 Click the Marking Point Tool button.
2 Click and drag the marking you want to move to the desired location.

Note  The marking point applies only to a road surface if it has a similar height as the road surface.

You can use the Project Control Point button in the “Sub-Tool Bar” on page 2-10 to automatically
set the height of a point marking. You can also adjust the height manually by using the "Z" value in
the “Attributes Panel” on page 2-20.
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Marking Polygon Tool

The Marking Polygon Tool can be used to define areas of asphalt patches or repeated marking stripes
on roads and terrain surfaces. Marking polygons support the assignment of polygon marking styles,
which define the marking appearance.

Edit Marking Polygons
See “Polygon Editing” on page 5-5.

Note To create a new marking polygon, you must have a Polygon Marking Asset on page 4-12
selected in the “Library Browser” on page 2-13.

Change the Marking on a Polygon
1 Click the Marking Polygon Tool button.
2 Click the marking polygon you want to change.
3 Click and drag a polygon marking asset from the Library Browser onto the Marking widget in

the “Attributes Panel” on page 2-20.

Alternatively, click and drag a polygon marking asset from the Library Browser directly onto the
desired marking polygon.

Note  This operation works from any tool. Once done, RoadRunner automatically enters the
appropriate tool and selects the object for further editing.
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Measurement Tool

The Measurement Tool enables you to measure positions, distances, and angles. You can make
multiple individual measurements can place them in the scene. Measurements remain visible in other
tools, although they can be selected and modified only within the Measurement Tool. Measurements
are not permanent and are not exported with the scene.

Measure the XYZ Position at a Single Point
1 Click the Measurement Tool button.
2 If another measurement is already picked, click away from any measurements to unpick it.
3 Right-click the point you want to query. The XYZ location of the point is displayed next to it. The

location is relative to the scene origin (0,0,0). The X value is positive in the north direction. Y is
positive in the east direction. Z is positive in the up direction.

Measure the Distance Between Two Points
1 Click the Measurement Tool button.
2 If another measurement is already picked, click away from any measurements to unpick it.
3 Right-click the first point. The XYZ location of the point is displayed next to it.
4 Right-click the second point. The distance between the two points is displayed. If the two points

are at roughly the same altitude, then only the 3D distance is displayed. If the two points are at
different altitudes, then the horizontal and vertical distances are also displayed.

Measure an Angle Between Three Points
1 Click the Measurement Tool button.
2 If another measurement is already picked, click away from any measurements to unpick it.
3 Right-click the first point. The XYZ location of the point is displayed next to it.
4 Right-click the second point. The distance between the two points is displayed.
5 Right-click the third point. The angle between the three points is displayed.

Measure the Distance Along Multiple Points
1 Click the Measurement Tool button.
2 If another measurement is already picked, click away from any measurements to unpick it.
3 Right-click to create points along the distance you want to measure.
4 Look at the number floating above the middle point of the measurement to see the distance the

set of points covers.
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Delete a Measurement
1 Click the Measurement Tool button.
2 Click the measurement you want to delete.
3 Press the Delete key or select Edit > Delete from the Main Menu.

Delete All Measurements
1 Click the Measurement Tool button.
2 If any measurements are already selected, press Ctrl+D or select Edit > Deselect All to clear

the selection set.
3 Press Ctrl+A or choose Edit > Select All to select all measurements.
4 Press the Delete key or select Edit > Delete from the Main Menu.
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OpenDRIVE Export Preview Tool

The OpenDRIVE Export Preview Tool is used to visualize and validate an OpenDRIVE export of the
current scene and to load external OpenDRIVE files. Upon entering the tool, the OpenDRIVE export
dialog box is displayed. After clicking Export, the current scene is exported to a temporary
OpenDRIVE file, which is then loaded, validated, and displayed.

Validations are run both before export and after loading the exported data. This validation output is
printed to the “Output Panel” on page 2-25. Most validation errors or warnings include hyperlinks in
the message. Click on a link to focus on the object or issue.

To avoid visual clutter, click the Show Background Scene button to toggle display of the scene
meshes. The Show OpenDRIVE Lane Markings button toggles display of the OpenDRIVE lane
marking attributes, which are displayed only when a road curve is selected.

You can also use the OpenDRIVE Export Preview Tool to validate and display existing OpenDRIVE
files. This can be useful for validating files from other sources or previewing an OpenDRIVE file prior
to import.

OpenDRIVE Export Preview Tool with Visual
Scene On

OpenDRIVE Export Preview Tool with Visual
Scene Off

Preview OpenDRIVE Data for the Current Scene
1 Click the OpenDRIVE Export Preview Tool button to open a dialog box with some OpenDRIVE

options.
2 Choose the options you want and click Export. RoadRunner exports the current scene to

OpenDRIVE and displays the resulting OpenDRIVE roads and lanes.

Load an External OpenDRIVE File for Display
See “OpenDRIVE Viewer Tool” on page 5-81.

Note  This feature does not interpret any georeferencing data in the loaded file.
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This feature is purely for viewing and validating an OpenDRIVE file. To import an OpenDRIVE file into
RoadRunner for editing, see “Importing OpenDRIVE Files” on page 6-2.

View the Attributes of OpenDRIVE Features
From within the OpenDRIVE Export Preview Tool, select on page 3-11 lanes and other objects in the
“3D Edit Window” on page 2-11 to view their attributes in the “Attributes Panel” on page 2-20.

Toggle the Display of 3D Scene Geometry
From within the OpenDRIVE Export Preview Tool (or any tool), select the View > Scene option in the
“Menu Bar” on page 2-8 or press the F8 key.

Selectively Display OpenDRIVE Lanes
By default, the OpenDRIVE Export Preview Tool displays all OpenDRIVE lanes and objects in the
scene. The tool optionally provides a mode to display lanes and objects for only the selected
OpenDRIVE roads.

From within the OpenDRIVE Export Preview Tool:

1 Click the Show All Lanes button on the “Sub-Tool Bar” on page 2-10.
2 The tool now displays on the OpenDRIVE road plan curves by default. When you select a road

curve, the lanes and objects for that road are displayed.

View Validation Results
From within the OpenDRIVE Export Preview Tool, examine the validation report output in the
“Output Panel” on page 2-25. Most errors or warnings include a hyperlink. Click on a link to focus on
the object or issue.

Search for OpenDRIVE Features
From within the OpenDRIVE Export Preview Tool:

1 Click the Search button in the “Sub-Tool Bar” on page 2-10.
2 Enter the desired search properties into the search dialog box.
3 Press the Find Next button on the search dialog box.

This feature is useful for debugging problems if a separate application reports an issue with a specific
road ID.

5 Tools

5-80



OpenDRIVE Viewer Tool

The OpenDRIVE Viewer Tool is used to visualize OpenDRIVE data for import.

The OpenDRIVE Viewer Tool has a similar interface as the “OpenDRIVE Export Preview Tool” on page
5-79. OpenDRIVE data brought in to the tool is visible in the scene, along with any other vector data.

Load an External OpenDRIVE File for Display
1 Click the OpenDRIVE Viewer Tool button.
2 Click and drag the desired OpenDRIVE file from the “Library Browser” on page 2-13.

View the Attributes of OpenDRIVE Features
From within the OpenDRIVE Viewer Tool, select on page 3-11 lanes and other objects in the “3D Edit
Window” on page 2-11 to view their attributes in the “Attributes Panel” on page 2-20.

Toggle the Display of 3D Scene Geometry
From within the OpenDRIVE Viewer Tool (or any tool), select the View > Scene option in the “Menu
Bar” on page 2-8 or press the F8 key.

Toggle the Display of Loaded OpenDRIVE Data (Outside of OpenDRIVE
Viewer Tool)
From within any tool other than the OpenDRIVE Viewer Tool, select the View > Vector option in the
“Menu Bar” on page 2-8 or press the F7 key.

Import an OpenDRIVE File
1 Click the OpenDRIVE Viewer Tool button.
2 Click the visualized file's bounding rectangle.

Alternatively:

• Hold the Ctrl key and click to select multiple files.
• Deselect all files to import all OpenDRIVE files.

3 Click the Convert Roads button.

 OpenDRIVE Viewer Tool

5-81



4 Select desired options.

View Validation Results
From within the OpenDRIVE Viewer Tool, examine the validation report output in the “Output Panel”
on page 2-25. Most errors or warnings include a hyperlink. Click a link to focus on the object or issue.

Search for OpenDRIVE Features
From within the OpenDRIVE Viewer Tool:

1 Click the Search button in the “Sub-Tool Bar” on page 2-10.
2 Enter the desired search properties into the search dialog box.
3 Press the Find Next button on the search dialog box.

See Also
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Parking Tool

The Parking Tool can be used to define parking spaces or other parking-related markings. You can
assign marking styles to the boundaries of spaces and parking nodes of parking spaces.

Parking spaces are created as a curve on page 5-3, where spaces are automatically created along the
curve. Parking curves are automatically created for lanes of type parking.

Parking spaces are modeled as a region graph on page 5-15, where each closed region represents a
parking space.

Markings can be placed on the graph edge curves to represent painted boundaries.

A graph edge curve can be optionally marked as an Entry Edge. This indicates that a vehicle can
enter the parking space from that edge.

Create a New Parking Curve
1 Select the Parking Tool.
2 Check that no objects are selected. For example, you can use the Edit > Deselect All option in

the “Menu Bar” on page 2-8.
3 Right-click (and optionally drag) to create a curve with a single starting point. The new curve is

automatically assigned to the selected asset.
4 Right-click (and optionally drag) to extend the curve by adding additional control points.

For lanes with type parking, parking curves are automatically created and updated. For more
details, see “Lane Tool” on page 5-57.
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Create a Single Parking Space
1 Select the Parking Tool.
2 Create a parking curve with two points.
3 Check that the second point is close enough to create only one parking space.

Change the Marking on a Parking Curve
1 Select the Parking Space Tool.
2 Select the parking curve you want to change.
3 Click and drag a Lane Marking Asset on page 4-8 from the “Library Browser” on page 2-13 onto

the Marking widget in the “Attributes Panel” on page 2-20.

Alternatively, click and drag a Lane Marking Asset on page 4-8 from the “Library Browser” on page 2-
13 directly onto the desired parking space edge.

Create a Parking Lot
1 Select the Road Plan Tool.
2 Create roads with driving lanes to define the drivable areas of the parking lot.
3 Select the Parking Tool.
4 Create parking curves for each set of spaces.

Change the Width of Parking Spaces
1 Select the Parking Space Tool.
2 Select the desired parking curve
3 In the “Attributes Panel” on page 2-20, set the desired Width.

Create Angled Parking Spaces
1 Select the Parking Space Tool.
2 Create a new parking curve or select an existing parking curve.
3 In the “Attributes Panel” on page 2-20, set the desired Angle.
4 Assign marking styles to the desired edges.
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Assign a Stencil Marking Style to a Parking Space
1 Select the Parking Space Tool.
2 Click a parking curve.
3 Click and drag a stencil marking style onto the parking curve or assign it in the “Attributes Panel”

on page 2-20.

 Parking Tool

5-85



Point Cloud Tool

The Point Cloud Tool manages the import and configuration of lidar point cloud files. RoadRunner can
import a variety of point cloud file formats, such as LAS, LAZ, and PCD. Some of these formats
support georeferencing and can be automatically positioned accordingly.

Refer to the “Point Cloud Assets” on page 4-11 page for a list of supported formats.

Point clouds often come from lidar scans, typically from an aerial flyover, a static terrestrial scan, or
from a moving ground vehicle.

RoadRunner can import multiple point clouds and display them all in the same 3D space, for use as
visual reference. The positioning and properties of each point cloud can be adjusted individually
using this tool.

PCD Loading

• For PCD files to load points properly, the file format must have SIZE 4 and TYPE F (float) for
coordinate FIELDS of x, y, and z. The data can be ASCII, binary, or compressed.

• For intensity, the file format must have FIELDS intensity, SIZE 4, and TYPE F.
• For color, the file format must have FIELDS rgba, SIZE 4, and TYPE U.

Import a Georeferenced Point Cloud
1 Click the Point Cloud Tool button.
2 In the “Library Browser” on page 2-13, navigate to the directory containing the point cloud on

page 4-11 file you want to import.
3 Click and drag the asset from the Library Browser into the 3D scene.

Note If the geographic position has not yet been set for this scene, the scene center is set to the
latitudinal and longitudinal center of the image. You can change the scene center using the “World
Settings Tool” on page 5-165.

If the geographic position has already been set, but the imported image is outside of the maximum
range of the scene, an error dialog box appears and cancels the import.

Note  Certain newer LAZ files are not supported in RoadRunner. As a workaround, decompress the
LAZ files into the LAS format. For instructions, see “Decompress LAZ Files” on page 8-10.

Remove a Point Cloud from a Scene
1 Click the Point Cloud Tool button.
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2 Click within the bounding box of the point cloud you want to delete.
3 Press the Delete key or select Edit > Delete from the Main Menu.

Adjust the Properties of a Point Cloud
1 Click the Point Cloud Tool button.
2 Click the point cloud you want to edit. The attributes of the point cloud appear in the Attributes

Panel.
3 Adjust the point cloud attributes as desired through the Attributes Panel.

Note  The attributes of a point cloud are associated with the current scene, not to the point cloud file
itself. This means that any modifications to the attributes affects only the point cloud as it appears in
the current scene. These modifications do not affect if or how it appears in other scenes.

Toggle the Display of Point Clouds
Select View > Point Clouds on the Main Menu or press the F6 key.

 Point Cloud Tool

5-87



Prop Curve Tool

The Prop Curve Tool is used to place props and extrusions along free-form curves. By default, props
and extrusions are aligned with the surface terrain.

Edit Prop Curves
See “Curve Editing” on page 5-3.

Note  When creating a new prop curve, you must have a compatible asset (“Prop Model Assets” on
page 4-17, “Prop Set Assets” on page 4-24, “Extrusion Assets” on page 4-5, and so on) selected in the
“Library Browser” on page 2-13.

Change the Prop Asset on a Curve
1 Click the Prop Curve Tool button.
2 Click the prop curve you want to change.
3 Click and drag a prop asset from the

“Library Browser” on page 2-13 onto the Prop widget in the “Attributes Panel” on page 2-20.

Alternatively, click and drag a prop asset from the Library Browser directly onto the desired prop
curve. (Note: You do not need to select the Prop Curve Tool first to perform this operation, because
it works from any tool.) Once done, RoadRunner automatically enters the Prop Curve Tool and
selects the changed prop curve for further editing.

Convert Props Along a Prop Curve Into Individual Instances
1 Click the Prop Curve Tool button.
2 Click the prop curve you want to change.
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3 Click the Bake button in the Attributes Panel. This will turn all instances of a prop along the prop
curve into individual instances. This operation also deletes the existing prop curve and
automatically enters the “Prop Point Tool” on page 5-90.
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Prop Point Tool

The Prop Point Tool is used for placing individual props in the scene or connecting them to other
props.

To place a prop, select the prop in the Asset Browser and right-click in the 3D scene. The prop should
appear in the scene and be positioned on whatever surface the mouse cursor is over. In this way,
props are automatically positioned on the terrain surface. If the Align Normal option is set for the
prop, it will also rotate itself to align with the surface it is placed on.

If any of the Rotation Variance or Scale Variance attributes are set for the prop, then these
properties will be randomized when the prop is placed. For example, for trees and plants, it is very
useful to set the Z-value of the Rotation Variance to 360 degrees, causing the prop to be randomly
rotated around the vertical axis and making it easier to reuse the same plant models in multiple
places without the repetition being obvious. In addition, setting the Uniform Scale Variance to 0.1
will cause a 10% randomization in the overall size of the plant.

Edit Prop Points
See “Point Editing” on page 5-2.

To create a new prop point, you must have a compatible asset (“Prop Model Assets” on page 4-17,
“Prop Set Assets” on page 4-24 and so on) selected in the “Library Browser” on page 2-13.

Add a Prop Point to the Scene
To add a prop point, follow the steps in the “Point Editing” on page 5-2 page. Alternatively, click and
drag a compatible asset directly from the “Library Browser” on page 2-13 onto the 3D scene.

Note  This operation works from any tool. Once done, RoadRunner automatically enters the
appropriate tool and selects the object for further editing.

Attach a Prop to Another Prop

Simple props can be combined and attached to one another to form more complex groups of attached
props. For example, a custom traffic signal can be constructed by combining a post, a mast, and
multiple signal heads.

1 Click the Prop Point Tool button.
2 Click and drag a compatible asset directly from the “Library Browser” on page 2-13 onto the

green prop attachment curve of another prop in the scene.

For more information about prop attachment curves, see Prop Attachment Curves on page 4-18.
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Prop Assemblies
A group of connected props can be saved as an asset. This allows a complex group of attached objects
to be quickly re-instantiated in the scene.

For more details, see “Prop Assembly Assets” on page 4-14.
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Prop Polygon Tool

The Prop Polygon Tool allows props to be placed within arbitrarily shaped regions.

Note  Prop polygons are limited to producing 10,000 individual prop instances each.

Edit Prop Polygons
See “Polygon Editing” on page 5-5.

To create a new prop polygon, you must have a compatible asset (“Prop Model Assets” on page 4-17,
“Prop Set Assets” on page 4-24, “Extrusion Assets” on page 4-5, and so on) selected in the “Library
Browser” on page 2-13.

Change the Prop Asset on a Polygon
1 Click the Prop Polygon Tool button.
2 Click the prop polygon you want to change.
3 Click and drag a prop asset from the “Library Browser” on page 2-13 onto the prop widget in the

“Attributes Panel” on page 2-20.

Alternatively, click and drag a prop asset from the Library Browser directly onto the desired prop
polygon. (You do not need to select the Prop Polygon Tool first to perform this operation, because it
works from any tool.) Once done, RoadRunner automatically enters the Prop Polygon Tool and
selects the changed prop polygon for further editing.

Convert Props Along a Prop Polygon Into Individual Instances
1 Click the Prop Polygon Tool button.
2 Click the prop polygon you want to change.
3 Click the Bake button in the Attributes Panel. This operation turns all instances of a prop within

the prop polygon into individual instances. This operation also deletes the existing prop polygon
and automatically enters the “Prop Point Tool” on page 5-90.
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Prop Span Tool

The Prop Span Tool is used to place props and extrusions along a road.

Unlike the “Prop Curve Tool” on page 5-88, props placed along spans remain anchored to the road
and update automatically when the road is moved.

Create and Modify Prop Spans Along a Lane
See “Span Editing” on page 5-12.

Prop spans store prop assets (“Prop Model Assets” on page 4-17, “Prop Set Assets” on page 4-24,
“Extrusion Assets” on page 4-5, and so on), which can be directly dragged on to a lane span from the
“Library Browser” on page 2-13 in this tool.

Note  Only a single prop asset can be assigned to a given span (although you can split a span into
two spans). To assign two prop assets (for example, a guardrail on the edge of the road and a row of
trees behind it), you can work around this limitation by assigning props to a span curve on a different
lane, and then adjusting the Offset value to shift the props.

For example, you can assign a tree asset to the inner sidewalk curve, and then increase the Offset
value to push the trees outward past the outer edge of the sidewalk.
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Road Chop Tool

The Road Chop Tool chops a single road into two connected roads.

Chop a Road
1 Click the Road Chop Tool button.
2 Click the road you want to chop. Once selected, a light blue line following the pointer appears,

indicating where the chop will occur.
3 Move the pointer so that the blue line is at the location you want to chop. Then, right-click to

chop the road.
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Road Circle Tool

The Road Circle Tool builds a closed, circular loop based on the currently selected road style. It can
be used to build roundabouts and other circular road features. The tool builds the circle from four
connected roads, each making a single 90-degree turn.

Build a Circular Road

1 Click the Road Circle Tool button.
2 Optionally, click the desired road style in the “Library Browser” on page 2-13 if you want to build

a road of a particular style. If no road style is picked, a basic default style is used.
3 Right-click and drag from the location of the center of the circle to the desired radius.
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Road Construction Tool

The Road Construction Tool enables you to specify how a section of road is physically constructed.
Currently, only standard (on terrain) and bridge types are supported. Tunnels, channels, and
abutments are not supported.

You can set the construction type for individual spans along the road. The spans are bounded by
construction nodes, which you can insert and move to arbitrary locations along the road reference
curve.

Note You cannot create intersections for bridges. Raised intersections, merges, and splits are not
supported.

Create and Modify Construction Types Along a Road
See “Span Editing” on page 5-12.

Fix Bridges Along a Road
When you create scenes that have bridges, or build scenes that have bridged roads such as by using
“RoadRunner Scene Builder”, the initially created bridge spans might not form correctly. This
example shows how to use the Road Construction Tool to fix such a bridge span in a scene.

Create two intersecting roads by using the “Road Plan Tool” on page 5-108.
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Click one of the roads to select it. In the 2D Editor pane, drag the selected road until it is 10 meters
above the other road.
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Create ground terrain around the roads by using the “Surface Tool” on page 5-151. Move the camera
to view the road intersection. The ground attaches to the elevated road, which produces visual
artifacts. These visual artifacts occur because the section of road above the other road is not
designated as a bridge span.
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To fix the visual artifacts, set the elevated road to be a bridge span. The Surface Tool ignores bridge
road spans and does not attach to these spans.

1 Click the Road Construction Tool button.
2 Click the elevated road to select it.
3 In the subtool bar on the right, click the Auto Assign Bridges button.
4 In the Auto Bridge Span window, use the Bridge Span Inflation option to optionally set the

length of the bridge span. By default, the tool extends the bridge span by 20 meters on either
side of the bottom road. If the remaining road length to the left or right of the road is less the
Bridge Span Inflation value, then the bridge span extends to the end of the road. Click OK.

5 In the Auto Bridge Span Results window, confirm that the road was updated. Remember:

• If you selected the bottom road, then the tool processes the road but does not create a bridge
span.

• If you previously created a bridge span for the elevated road, then the tool overrides that
original bridge span.

Close the window and view the road that has the created bridge span.
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With the Road Construction Tool still selected, if you select the middle portion of the road, the
Attributes panel shows that this portion has its Construction Span value set to Bridge. The other
two portions are set to Standard.

If you have multiple bridges to fix, then you can select multiple roads and use Auto Assign Bridges
to fix all of them at once. If you are building scenes by using RoadRunner Scene Builder, then you can
use the Auto Detect Bridges option to fix bridges. Using this option is similar to running the Auto
Assign Bridges operation on all bridges in a scene. For more details, see “Scene Builder Tool” on
page 5-124.
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Road Construction Span Attributes
Attribute Description
Construction Span • Standard — This portion of the road is at

ground level. The surrounding terrain
attaches to the sides of the span.

• Bridge — This portion of the road is elevated.
The surrounding terrain is not connected to
the sides of the span. A bridge underside
mesh is generated along the span.

When you select this option, the resulting
bridge span might be too long. To address this
issue, choose one of these options:

• Use the “Road Chop Tool” on page 5-94 to
divide the road into sections. Then, select
the section that you want to convert into a
bridge and set Construction Span to
Bridge.

• Use the Auto Assign Bridges button to
create a bridge span.

Material Material Asset on page 4-10 to be used for the
sides and underside of the bridge.

See Also
“Scene Builder Tool” on page 5-124
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Road Height Tool

The Road Height Tool allows the manipulation of the vertical profile of roads.

The height profile is defined relative to the distance along the road and is constructed of straight line
sections and quadratic (parabolic) blend sections. The height profile can also be converted to a
sequence of cubics with tangents on nodes.

For tips on dealing with height alignment in intersections, see “Resolve Triangulation Issues in
Junctions” on page 8-8.

Insert a New Height Node
1 Click the Road Height Tool button.
2 Click to select a road.
3 Right-click the road curve at which you want to insert a height node.
4 Optionally, you can hold the right-click button and drag the height node to the desired height.

Alternatively, insert a height node from the 2D View Panel.

1 Click the Road Height Tool or Road Plan Tool button.
2 Click to select a road.
3 In the 2D View Panel, right-click the road curve where you want to insert a height node.

Adjust the Height of a Node
1 Click the Road Height Tool button.
2 Click to select a road.
3 Click and drag the node you want to edit to the desired height.
4 Optionally, click the node and type the desired height into the Attributes Panel.

Alternatively:
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1 Click the Road Height Tool or Road Plan Tool button.
2 Click to select a road.
3 In the 2D View Panel, click and drag the node along the vertical axis.

Move a Height Node Along the Road
1 Click the Road Height Tool button.
2 Click to select a road.
3 Click to select a node.
4 Adjust the Distance value in the Attributes Panel.

Alternatively:

1 Click the Road Height Tool or Road Plan Tool button.
2 Click to select a road.
3 In the 2D View Panel, click and drag the node along the horizontal axis.

Delete a Road Height Node
1 Click the Road Height Tool button.
2 Click to select a road.
3 Click to select a node.
4 Press the Delete key or select Edit > Delete from the Main Menu.

Adjust the Height of a Section Between Nodes
1 Click the Road Height Tool button.
2 Click to select a road.
3 Click and drag the curve section you want to edit to the desired height.
4 Optionally, click the curve section and type the desired height into the Attributes Panel. This

value sets the height of the nodes at the start and end of the curve section.

Alternatively:

1 Click the Road Height Tool or Road Plan Tool button.
2 Click to select a road.
3 In the 2D View Panel, click and drag the curve section along the vertical axis.

Adjust the Size of a Quadratic Blend Section
1 Click the Road Height Tool button.
2 Click to select a road.
3 Click the height node in the middle of the blend section you want to edit. Two green dots appear

at the limits of the blend region.
4 Click and drag either of the green dots to adjust the range of the blend region.
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5 Optionally, you can type the desired blend range into the Attributes Panel. This value sets the
height of the nodes at the start and end of the curve section.

Convert the Profile to Cubic Interpolation
1 Click the Road Height Tool button.
2 Click to select a road.
3 Click Use Cubic Interpolation.

Convert the Profile to Quadratic Interpolation
1 Click the Road Height Tool button.
2 Click to select a road.
3 Click Use Quadratic Interpolation.

Adjust the Tangent of a Height Node
1 Click the Road Height Tool button.
2 Click to select a road.
3 Click the height node.
4 Click and drag either of the green dots to adjust the slope.

Disconnect the Tangents of a Height Node
1 Click the Road Height Tool button.
2 Click to select a road.
3 Click the height node.
4 Click Disconnect Tangents.
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Connect the Tangents of a Height Node
1 Click the Road Height Tool button.
2 Click to select a road.
3 Click the height node.
4 Click Connect Tangents.

Project Roads to Elevation Maps
RoadRunner can project one or more roads down to the height of an Elevation_map on page 4-4. This
process samples the elevation data under the road and performs a constrained fit of the road
elevation to the trace of the elevation data beneath the road.

Before Height Projection: Note the blue trace,
which shows the height of the elevation map
underneath the road.

After Height Projection:. Note how the road
height (red trace) now aligns with the elevation
map (blue trace) underneath the road.

1 Click the “Road Plan Tool” on page 5-108 button.
2 Select the roads you want to project. (You can perform a Select All operation to select all roads

in the scene).
3 Click the Project Roads button on the “Sub-Tool Bar” on page 2-10.

There are two types of height projection that can be performed: a relaxed fit and a tight fit. The type
of fit used depends on whether the road uses quadratic or cubic interpolations.
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Relaxed Fit

If a road is using quadratic interpolation on page 5-104, a relaxed, approximate fit is used. This
interpolation is best when the terrain data is either noisy or low resolution.

Tight Fit

If a road is using cubic interpolation on page 5-104, a much tighter fitting method is used. This
interpolation is best when you want the road to closely match the heights of the elevation map.
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Road Offset Tool

The Road Offset Tool is used to adjust the connection between two end-to-end roads. Roads can be
shifted laterally to align the lanes of each road.

Note  Slip roads cannot be offset using this tool. Slip roads will automatically align to the side of the
road from which they originate.

Offset a Road
1 Click the Road Offset Tool button.
2 Click the desired road. The road must be connected to another road at its other end.
3 Click and drag the arrows at the desired end of the road.

Note  Holding the Ctrl key disables lane snapping.
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Road Plan Tool

The Road Plan Tool is the primary tool for creating and laying out roads. It allows for creation and
manipulation of the 2D reference curve that the road layout is based on. The height of the road can
be manipulated independently using the “Road Height Tool” on page 5-102. Intersections are created
automatically where roads overlap.

Roads and Terrain Surfaces
Roads automatically participate in the terrain surface graph. For more information about this
interaction, refer to the “Surface Tool” on page 5-151.

Create a New Road
1 Click the Road Plan Tool button.
2 If another road is already selected, click away from any road to unselect it.
3 Optionally, click the desired road style in the Assets Browser to build a road of a particular style.

If no road style is picked, a basic default style will be used.

a For more information about road styles, refer to the “Road Style Assets” on page 4-25
documentation.

4 Right-click at the location you want to start a new road.
5 Right-click additional times to create additional road control points to extend and shape the road.
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Move Road Control Point

1 Click the Road Plan Tool button.
2 Click the road you want to edit. The road is highlighted, and the control points are displayed and

connected by light blue lines.
3 Click and drag the desired control point to move it.
4 Optionally, you can click to select the point, and then type a precise position in the Attributes

Panel.

Note The end control points and the first interior control points have some special properties when
roads are connected end-to-end:

• Moving the end control point of one of the roads will move the end of the connected road and
update the first interior control point of the other road to ensure that the road directions remain
aligned at this end, as shown here:
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• Moving the first interior control point of one of the roads will move the first interior control point
of the other road (by rotating it about the end point) to ensure that the road directions remain
aligned at this end, as shown here:
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Insert New Control Point Within Existing Road

1 Click the Road Plan Tool button.
2 Click the road you want to edit.
3 Move the mouse cursor over the blue control line at the location you want to insert a node.
4 Right-click to insert a new node within the control line of the road.

Adjust Radius of Road Curve

By default, the circular arcs in the road curves will fit in the space available. If a smaller curve radius
is desired:

1 Click the Road Plan Tool button.
2 Click the road you want to edit. The road is highlighted, and the control points are displayed and

connected by light blue lines.
3 Click the control point closest to the circular arc you want to modify. The attributes of the

selected control point will appear in the Attributes Panel.
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4 Adjust the Max Radius value to the desired radius. If you do not see anything change, then try a
lower value, because Max Radius will limit the maximum radius of the arc.

Adjust Curvature of Road Curve
See “Explicit Road Curves” on page 5-118.

Extend Existing Road

You can extend an existing road in either direction by adding more control points, as follows:

1 Click the Road Plan Tool button.
2 Click the road you want to extend. The road is highlighted, and the control points are displayed

and connected by light blue lines.
3 Click the control point on the end of the road you want to extend.
4 Right-click to create a new control point and extend the road.

Note For optimal performance, avoid very long individual roads. Keeping individual roads under 500
m is recommended. To create stretches of road longer than 500 m, use multiple roads connected end-
to-end. Refer to “Create New Road Connected End-to-End With Another Road” on page 5-113 and
“Connect Two Roads End-to-End” on page 5-113.
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Create New Road Connected End-to-End With Another Road

In a similar fashion to extending an existing road, you can also create a new road that connects end-
to-end with an existing road. The visual result is similar to extending the existing road, but there are
some important situations where end-to-end roads are needed:

• To avoid extremely long roads for performance reasons
• To create a road loop or self-intersecting road

You can create an end-to-end road that connects with an existing road as follows:

1 Click the Road Plan Tool button.
2 If another road is already selected, click away from any road to unselect it.
3 Click the lavender road node line at the end of a road.
4 Right-click to create a new control point, which creates a new road that extends off the existing

one.

Connect Two Roads End-to-End
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Similar to the steps above, you can extend a road and simultaneously connect it to the end of an
existing road as follows:

1 Click the Road Plan Tool.
2 Click the road you want to extend. The road is highlighted, and the control points are displayed

and connected by light blue lines.
3 Click the control point on the end of the road you want to extend.
4 Right-click the lavender line at the end of another road.

Create Road Loop
You can create a closed loop road by combining the steps above or by using the “Road Circle Tool” on
page 5-95.

Note Closed loops require at least three separate roads. You cannot form a loop from a single road.

1 Create the first road by using the “Create a New Road” on page 5-108 steps.

2 Create the second road by using the “Create New Road Connected End-to-End With Another
Road” on page 5-113 steps.

3 Create the final road by using the “Create New Road Connected End-to-End With Another Road”
on page 5-113 steps, followed by the “Connect Two Roads End-to-End” on page 5-113 steps to
end the road.
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Delete Road Control Point
1 Click the Road Plan Tool button.
2 Click the road you want to delete the point from. The road is highlighted, and the control points

are displayed and connected by light blue lines.
3 Click the control point you want to delete.
4 Press the Delete key, or select Edit > Delete from the Main Menu.

Delete Road
1 Click the Road Plan Tool button.
2 Click the road you want to delete.
3 Press the Delete key, or select Edit > Delete from the Main Menu.

Create Intersection
At-grade intersections are created automatically in RoadRunner wherever two or more roads cross.

Four-Way Intersections

To create a four-way intersection, create two roads that fully overlap:
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T-Junctions

To create a T-junction, create two roads where one ends within the extents of the other:

Ramps and Splits

To create onramps, offramps, and road splits, refer to the “Slip Road Tool” on page 5-146
documentation.

Self-Intersections

A single road should not overlap itself. If you need to create a road that loops back on itself, either
chop the road with the “Road Chop Tool” on page 5-94, or create roads connected end-to-end:
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Roads may not cross themselves Instead, create two or more roads connected end-
to-end

Double-Crossings

You might observe issues with lane markings when two roads cross each other twice (that is, two at-
grade intersections are formed between the same two roads).

Avoid double-crossing roads. If you need to create a double-crossing situation, either chop one of the
roads with the “Road Chop Tool” on page 5-94, or initially create one of the roads using two end-to-
end roads.

Avoid roads that cross each other twice. Instead, split one of the roads in two

(Note the lavender bar indicating an end-to-end
connection.)

Note Intersections are only created when the roads have similar heights at the crossing locations. To
adjust road heights, use the “Road Height Tool” on page 5-102.
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Explicit Road Curves
By default, new roads will be created out of straight lines and circular arcs. Roads created in this
method are called "Automatic." It is sometimes desirable to instead define a road curve as an explicit
set of straight lines, circular arcs, clothoids (spirals), and parametric cubics (hermite curves).

Roads created in this method are called "Explicit." Each line, arc, spiral, or cubic is called a
"Segment." The Explicit Road Curve also allows you to set the tangents of the road at each control
point. Editing the control points of an explicit curve is done the same as with an automatic curve.

Building Roads With Explicit Curves

Explicit curves can be used to create a road with a very specific profile (for example, a 50 m linear
section, followed by a 20 m spiral with specific starting and ending curvatures, followed by a 30 m
arc with specific curvature, and so on).

To build such a road, follow these steps:

1 Click the Road Plan Tool button.
2 Create a new road using these steps: “Create a New Road” on page 5-108.
3 Convert the new road to explicit form using these steps: “Make Road Curve Explicit” on page 5-

118.
4 Adjust the type and properties of the first road section.
5 For each new section you want to add to the road:

a Add a new section using these steps: “Extend Existing Road” on page 5-112.
b Adjust the type and properties of the new road section.

Make Road Curve Explicit
1 Click the Road Plan Tool button.
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2 Click the road you want to change.
3 In the Attributes Panel, press Convert to Explicit.

Make Road Curve Automatic
1 Click the Road Plan Tool button.
2 Click the road you want to change.
3 In the Attributes Panel, press Convert to Automatic.

Note Converting an explicit curve to an automatic curve can slightly change the curve and insert
additional points.

Change Tangent of Explicit Curve
1 Click the Road Plan Tool button.
2 Click the road you want to change.
3 Click and drag one of the tangent control points and move it to set the desired tangent.

Note Setting tangents on a road may change the type of the segments connected to the affected
control point.
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Change Type of Segment
1 Click the Road Plan Tool button.
2 Click the road you want to change.
3 Click the segment you want to change.
4 In the Attributes Panel, select the Type of the segment. This will automatically constrain the

segment's points and tangents to match the type.

Change Length of Segment
1 Click the Road Plan Tool button.
2 Click the road you want to change.
3 Click the segment you want to change.
4 In the Attributes Panel, adjust the Length of the segment to the desired length.

Note You can set the length of a segment only if the segment is a line, arc, or spiral.

Change Curvature of Segment
1 Click the Road Plan Tool button.
2 Click the road you want to change.
3 Click the segment you want to change.
4 In the Attributes Panel, adjust the Curvature (for circular arcs) or Start Curvature/End

Curvature (for spirals).

Note You can set the curvature of a segment only if the segment is an arc or spiral.
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Road Speed Limits Tool

The Road Speed Limits Tool enables you to set varying speed limits along sections of a road. When
you export your scene to a simulator, you can use these values to test whether vehicles drive the set
speed limits.

Set Speed Limits Along Road
This example shows how to set varying speed limits along a simple curved road.

Create a curved road segment by using the “Road Plan Tool” on page 5-108.

Divide the road into sections along which to set different speed limits.

1 Select the Road Speed Limits Tool button.
2 Select the road by clicking it.
3 Right-click the road at two locations to divide it into three sections. To adjust the sections, click

and drag the dividing nodes along the curve of the road.
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By default, each section of the road has a speed limit of 40 miles per hour. Set the middle section of
the road to a lower speed limit.

1 Click the middle section of the road to select it.
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2 In the Attributes pane on the right, set the Speed Limit to 20.

You can then adjust the sections further or add or delete sections. To delete a section, click a dividing
node to select it, and then click Delete. When you delete a dividing node, the merged section inherits
the speed limit of the road section that had the higher speed limit.

Road Speed Limit Attributes
Attribute Description
Speed Limit Speed limit of road section, specified as a

nonnegative integer.

By default, units are in miles per hour. To change
units to kilometers per hour, in the menu bar,
select Tools > Scene Settings. Then, set Speed
Units to KPH.

Default: 40
Road Type Type of road, specified as Unknown, Rural,

Motorway, Town, Low Speed, Pedestrian, or
Bicycle.

Default: Town

See Also
“Road Plan Tool” on page 5-108
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Scene Builder Tool

To import, inspect, and build roads from HERE HD Live Map data, use the Scene Builder Tool. After
building the roads, you can edit and export the scene by using other RoadRunner capabilities.

HERE HD Live Map, developed by HERE Technologies, is a cloud-based web service that enables you
to access highly accurate, continuously updated map data. The data is composed of tiled map layers
containing information such as the topology and geometry of roads and lanes.

The Scene Builder Tool is part of RoadRunner Scene Builder, an add-on product that requires an
addition to your RoadRunner license. For more details, see “Get RoadRunner Updates and Upgrades”
on page 1-8. You also need to enter into a separate agreement with HERE Technologies to gain access
to HERE HD Live Map data and to get the required Marketplace credentials (Access Key ID and
Access Key Secret).

Build Roads by Using HERE HD Live Map Data
This example shows how to build roads by using HERE HD Live Map data for an area in Santa Clara,
California that contains overpasses.

Choose Area of Interest

Specify an area of interest by using the “World Settings Tool” on page 5-165.

For this example, specify the world origin latitude as 37.4156 degrees and the world origin longitude
as –121.9749 degrees. Specify the X and Y workspace extents as 750 meters. Apply your changes by
clicking Apply World Changes.

Import and Explore Data

Open the Scene Builder Tool from the toolbar. Then, import the data by clicking the Import Data for
Area button from the sub-tool bar.

Before you import the data, enter the credentials that you obtained from HERE Technologies. Enter a
valid Access Key ID and Access Key Secret, then click OK. The credentials are saved for the rest of
your RoadRunner session on your machine. To save your credentials for future RoadRunner sessions
on your machine, in the dialog box, select Save my credentials. The credentials remain saved until
you delete them.
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The Scene Builder Tool imports HERE HD Live Map data from HERE tiles that intersect your
workspace, converts the data into a preview called a Transfer Map, and displays the Transfer Map in
the 3D Edit Window. The Transfer Map displays colors according to the confidence classification of
the data. For more information about classification, contact HERE Technologies.

Explore the imported data by selecting control points, lane boundaries, lanes, and lane groups. You
can view information such as classification, ID, and lane length from the Attributes Panel.

Build Roads

You can build roads from all the imported data or from a subset that you select. For this example,
select the subset of roads within your workspace (the rectangle with a dashed outline) by clicking and
dragging. Then, click the Build Roads button from the sub-toolbar.

In the Scene Builder dialog box, you can modify these options:

• Fit Cross Sections — By default, the Scene Builder Tool imports cross-section information such
as super-elevation (banking) and crowning. To import flat cross sections, disable this option. For
more information about cross sections, see “Cross Section Tool” on page 5-24.

• Auto Detect Asphalt Surfaces — By default, the Scene Builder Tool detects asphalt surfaces and
applies an asphalt texture to them. To apply a grass texture to all surfaces, disable this option. For
more information about surfaces and textures, see the “Surface Tool” on page 5-151.
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• Auto Detect Bridges — By default, the Scene Builder Tool creates bridges at road intersections
when the roads have different elevations. The tool extends the bridges by 20 meters on either side
of the intersection. You can change the amount of extension by changing the Bridge Span
Inflation value. To avoid creating bridges, disable this option. For more information, see “Road
Construction Tool” on page 5-96.

For this example, leave all of the options selected. Then, build the subset of roads by clicking Build
Selected.

Verify Results

The Scene Builder Tool builds roads from the HERE HD Live Map data and displays information about
the results in a dialog box. For information about troubleshooting common import issues, see
“Troubleshoot Import and Build Issues” on page 5-126. Close the dialog box by clicking Close.

Disable the Transfer Map by clicking a different tool. Then, explore the roads you built. For example,
navigate to the intersecting roads and inspect the overpass.

Continue exploring and editing the roads by using other RoadRunner capabilities. Then, export the
scene to a supported file format.

Troubleshoot Import and Build Issues
Depending on your area of interest, you might encounter issues when the Scene Builder Tool imports
data and builds roads. Some road issues might be due to missing or inaccurate map data in the HERE
HD Live Map service. Consider verifying the data by using an external map viewer.
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Roads overlap at junctions

If the Scene Builder Tool detects physical anomalies when building roads, then RoadRunner might
display this message in the Scene Builder Results dialog box:

>DEV: Detected potential accuracy issues in junction determined from road
overlap at this location

In other cases, you might notice unexpected shapes inside road junctions. To address these issues,
navigate to the junction and edit it by using road tools such as the “Maneuver Tool” on page 5-65.

Roads have extreme elevation changes

The Scene Builder Tool attempts to match the elevation of roads with the elevation of the imported
data. If the Scene Builder Tool builds roads with unrealistic elevation changes, then you can adjust
the road elevation manually by using the “Road Height Tool” on page 5-102. Alternatively, you can
project roads to an elevation map by using the Project Roads operation in the “Road Plan Tool” on
page 5-108. For more information about elevation maps, see “Elevation Map Assets” on page 4-4.

Bridges are not long enough

When the Scene Builder Tool creates a bridge from a road with multiple segments, the extension of
the bridge on either side of the intersection might be shorter than the Bridge Span Inflation value
that you specified. To address this issue, manually build a new bridge section by using the “Road
Construction Tool” on page 5-96.

Surfaces are asphalt instead of grass

The Scene Builder Tool might apply asphalt materials to areas next to roads instead of grass
materials. To drag a new material into the area, use the “Surface Tool” on page 5-151.

Tips
You can view the Transfer Map while using a different tool by selecting View > Transfer Map from
the menu bar. Transfer Maps do not persist between RoadRunner sessions.
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Scene Export Preview Tool

The Scene Export Tool can be used to visualize the exact scene geometry that will be exported. You
can also use it to query properties, such as triangle and material counts. Tile counts are determined
by fitting the Tile Size and Center parameters to the Scene Extents.

Adjust the Export Tile Size
1 Select the Export to Tiles toggle.
2 Adjust the Tile Size parameters to modify the size of individual tiles.
3 Adjust the Center parameters to modify the overall tiling center.
4 Click Preview Export.

Preview Segmentation Output
1 Modify the Split by Segmentation toggle.
2 Press Preview Export.
3 Enable segmentation display to preview segmentation categories in this tool.
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Screenshot Tool

The Screenshot Tool generates and saves an image of the current camera view. The dimensions of the
screenshot can be set independently of the dimensions of the actual viewport. This allows for full
control over the resolution and aspect ratio of the image without being limited to the resolution of the
monitor. The Screenshot Tool also allows control over the camera field of view.

Generate a Screenshot
1 Click the Screenshot Tool button.
2 Adjust the resolution and field of view as desired through the “Attributes Panel” on page 2-20.
3 Click the Take Screenshot button on the Attributes Panel.
4 Specify the file name and location in the File Save dialog box and click Save.

Generate a Quick Screenshot
1 Open any tool with the desired camera position. Quick screenshots use the current viewport

settings and resolution.
2 Either select Tools > Quick Screenshot from the “Menu Bar” on page 2-8 or press Ctrl+P.
3 Specify the file name and location in the file save dialog box and click Save.

.
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Signal Tool

The Signal Tool is used to configure junction signalization and signal traffic phases.

A junction's signalization can be static (not changing, for example, controlled by stop signs) or
dynamic (controlled by dynamic traffic signals). The signalization of a junction is defined using
phases. A phase indicates which signals are active and the state of the maneuver roads on page 5-65
(for example, whether traffic may enter the junction along a given maneuver road).

Each phase is composed of several intervals. An interval is a period in a junction that corresponds to
allowed movements. Typically, there are three intervals in a phase: green, yellow, and red.

The Signal Tool provides several autosignalization operations for automatically applying signalization
templates to a junction. These operations can also automatically place “Prop Assembly Assets” on
page 4-14 and “Signal Assets” on page 4-27.

Signal assets are linked to junctions by associating them to maneuver roads. This association can be
performed manually, but an automatic detection operation can attempt to identify nearby signals and
compute associations. A single signal asset can be associated with maneuver roads in multiple
separate junctions.
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Autosignalize a Junction

RoadRunner provides an autosignalization feature that can be used to apply common signalization
templates to an intersection. For example, use these steps to quickly configure a four-way stop, a
signalized intersection with protected left turns, and so on:

1 Click the Signal Tool button.
2 Select a junction.
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3 Click the Auto Signalize button in the “Attributes Panel” on page 2-20.

4 Select a signalization template from the Auto Signalize Junction dialog box, and then click
Signalize.
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Tip  If a prop or assembly is selected in the Library Browser first, select Automatically Place
Selected Prop to automatically place the prop and connect any signals to the junction.

Add an Empty Phase
1 Click the Signal Tool button.
2 Select a junction.
3 Right-click beyond the end of the phases in the “2D Edit Window” on page 2-12.

Alternatively, right-click an existing phase to duplicate it.

 Signal Tool

5-133



Clear All Phases
1 Click the Signal Tool button.
2 Select a junction.
3 Press the Delete key or select Edit > Delete from the “Menu Bar” on page 2-8.

Specify a Maneuver Road's State in a Phase
To control the traffic state of a maneuver road in a given signal phase, follow these steps:

1 Click the Signal Tool button.
2 Select a junction.
3 Select the desired phase in the “2D Edit Window” on page 2-12.
4 Select the maneuver road whose state you want to change.

5 Choose a State in the “Attributes Panel” on page 2-20.
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Specify a Signal State in a Phase
To control a traffic signal's bulb states in each interval of a given signal phase, follow these steps:

1 Click the Signal Tool button.
2 Select a junction.
3 Select a gate. Gates appear as lavender bars on maneuver roads.
4 Select a signal you want to disassociate.
5 Choose a signal state for each interval in the States group of the “Attributes Panel” on page 2-20.

Note  If no States group appears, then the selected signal is not associated with any maneuver road
gates in this junction. Refer to the Associate a Signal with a Maneuver Road Gate on page 5-137
section.

Edit a Phase Duration
To change the duration of each interval in a signal phase, follow these steps:

1 Click the Signal Tool button.
2 Select a junction.
3 Select the desired phase in the “2D Edit Window” on page 2-12.
4 Change the Interval Time in the “Attributes Panel” on page 2-20.
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Change the Current Phase
1 Click the Signal Tool button.
2 Select a junction.
3 Select the desired phase in the “2D Edit Window” on page 2-12.

Alternatively, click the phase arrow buttons in the “2D Edit Window” on page 2-12.

Tip You can scrub through the signal phases by dragging the timeline bar in the “2D Edit Window”
on page 2-12:
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Associate a Signal with a Maneuver Road Gate

To manually associate a maneuver road on page 5-65 with one or more “Signal Assets” on page 4-27,
follow these steps.

Note  In many cases, the Auto Detect Signals operation (see next section) works sufficiently. Try
that operation first.

1 Click the Signal Tool button.
2 Select a junction.
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3 Select a gate. Gates appear as lavender bars on a maneuver road.

Note Multiple gates might overlap. Cycle-Select on page 3-16 to choose which gate to edit.
4 Right-click the signal you want to associate the maneuver with.

Note  You cannot associate to signals in a prop assembly on page 4-14. You must first expand the
assembly on page 4-15.

Alternatively:

1 Click the Signal Tool button.
2 Select a junction.
3 Select a gate. Gates appear as lavender bars on a maneuver road.
4 Select a signal.
5 Click Add to gate in the “Attributes Panel” on page 2-20.
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Automatically Associate Signals with Maneuver Road Gates
This operation locates signals surrounding an intersection and attempts to automatically associate
signals with maneuver road gates.

1 Click the Signal Tool button.
2 Select a junction.
3 Click the Auto Detect Signals button in the “Attributes Panel” on page 2-20. At least one phase

must be present in the junction.

This operation uses the maneuver road turn types when determining which signals to associate with.
If a maneuver road is being associated to an inappropriate signal, verify that the maneuver road's
turn type is correct using the “Maneuver Tool” on page 5-65.

Note  Automatic detection does not work for signals in a prop assembly on page 4-14. You must first
expand the assembly on page 4-15.

Remove a Signal Association from a Maneuver Road Gate
1 Click the Signal Tool button.
2 Select a junction.
3 Select a gate. Gates appear as lavender bars on a maneuver road.
4 Select a signal you want to disassociate.
5 Click Remove from gate in the “Attributes Panel” on page 2-20.

Tips on Signals
• If the signals do not automatically detect the correct states, choose the phase, click the signal, and

set the desired states. Properly setting the Supported Turn Types for the signal can result in
better automatic choices.

• Before autosignalizing to automatically place signals, create a traffic light assembly and select it
in the “Library Browser” on page 2-13.
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Sign Tool

The Sign Tool is used to modify custom signs, such as street name signs and freeway billboards.

Sign Assets
RoadRunner has tools for quickly creating both basic and complex road signs. These signs can be
created and stored in the project assets, and then placed throughout the scene in 3D. A basic sign is a
sign that is built from a single image file (bitmap or vector graphic), such as a stop or yield sign. A
complex sign can have multiple elements, such as text and graphics, such as a custom freeway guide
sign. Both basic and complex signs can be created as assets in the asset library and then instanced in
the scene as props.

Create a Basic Sign Asset from a Single Bitmap or Vector Image

1 Click in the Asset Browser to select the destination directory in which to import the sign.
2 Drag the bitmap file (JPG, PNG, or BMP) or vector graphic file (SVG) from a file browser into the

Asset Browser. This action copies the actual file into the project assets. Once the image is in the
project assets, RoadRunner automatically generates an icon for the image.

3 Right-click the asset icon and select the Default Type > Sign menu option. This treats the image
file as a sign asset type and is necessary because images can be used as other asset types as
well.
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Create a Complex Sign Asset with Custom Text and Graphics

To create a complex sign asset with custom text, graphics, and so on, follow these steps:

1 Click in the Asset Browser to select the destination directory in which to import the sign.
2 Right-click in the Asset Browser and select the New > Sign menu option. This selection creates

a new sign asset that can be further customized with the Sign Tool described below.

Permanently Delete a Sign Asset from a Project

1 Click the sign asset you want to delete in the Asset Browser.
2 Press the Delete key, or select Edit > Delete from the Main Menu.
3 A dialog box warns you that this operation permanently deletes the file. Click Yes if you want to

proceed.

Modify an Existing Sign Asset

1 Click the sign asset you want to edit in the Asset Browser to display the sign's attributes in the
“Attributes Panel” on page 2-20.

2 Edit the sign's attributes as desired.
3 In the Main Menu, select File > Save Project. Changes to assets are not saved until you save

the project.

Place an Instance of a Sign in a Scene

To place a sign in a scene, click and drag the sign asset from the Library Browser into the scene.
Alternatively, follow these steps:

1 Click the Sign Tool button.
2 Click the desired sign asset.
3 Right-click in the scene to place the sign.

Sign Tool

The Sign Tool has features for customizing signs. With the Sign Tool, you can partition the sign into
rectangular regions and then place text, graphics, and colored rectangles within.
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Regions

Split a Region into Two Regions

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click the region you want to split.
4 Click the Add Horizontal Split or Add Horizontal Split button. When you click the button, the

region splits at the middle and draws a separator line. To adjust the position of the split, you can
click and drag the separator itself to the appropriate position.

Delete a Region

1 Click the Sign Tool button.
2 Click the sign you want to edit.
3 Click the region to delete.
4 Press Delete to remove the region.

Edit the Color and Boundary Properties of a Region

1 Click the Sign Tool button.
2 Click the sign you want to edit.
3 Click the region you want to edit.
4 Set the Color and Boundary properties in the “Attributes Panel” on page 2-20.
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Text

RoadRunner uses the standard system fonts installed through the operating system. You can specify
the font for each text box individually. Fonts for street signs in different countries are available from
various sources online. For example, Roadgeek 2005 is a good resource of sign fonts.

In the United States, most freeway and street signs are based on a set of fonts known as Highway
Gothic, formerly known as the FHWA Series fonts. These fonts were originally published in 1948 as
the FHWA's Standard Alphabets for Traffic-Control Devices and have been updated several times. The
original series had variants ranging from Series A (narrow) to Series F (wide). Series A is no longer
used in the U.S. because it was too narrow. Series E has a wider variant known as Series E-Modified
or sometimes Series E(M), which is used on many freeway guide signs. Highway Gothic is used in
several other countries as well.

Several U.S. states have adopted a newer font called Clearview, which was developed to improve
readability over the Highway Gothic font. There are different sets of Clearview fonts for light letters
on dark backgrounds, and dark letters on light backgrounds. There are six sizes in each set that vary
from narrow to wide. This leads to at least 12 variations on the font, usually labeled 1B-6B, and
1W-6W, plus a 13th revised version of 5W called 5WR.

Add a New Text Box

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click the Add Text button to create a new editable text box in the sign.

Note that the text box will inherit the properties of the last picked text box, and will appear centered
in the last picked region.

Delete a Text Box

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click the text box you want to delete.
4 Press the Delete key, or select Edit > Delete from the Main Menu.

Edit the Text in a Text Box

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.

 Sign Tool

5-143



3 Click the text box you want to edit.
4 Select the Text attribute on the Attributes Panel, and type in the desired string.

Change the Font or Other Visual Properties of a Text Box

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click the text box you want to edit. The attributes of the text box appear in the Attributes Panel.
4 Edit the desired attributes on the Attributes Panel. The Small Caps option can be used to format

lowercase letters as smaller capital letters

Graphics
Signs can include graphics in the form of bitmaps or vector graphics.

Add a New Sign Graphic

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click and drag a graphic onto the sign.

Delete a Sign Graphic

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click the graphic you want to delete.
4 Press the Delete key or select Edit > Delete from the Main Menu.

Edit the Shape of a Graphic

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click the graphic you want to edit.
4 Click and drag the edges of the graphic. The pointer changes to the resize symbol.

Change the Color or Other Visual Properties of a Graphic

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click the graphic you want to edit. The attributes of the graphic appear in the Attributes Panel.
4 Edit the desired attributes in the Attributes Panel.
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Rectangles

Add a New Sign Rectangle

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click the Add Rectangle button on the “Sub-Tool Bar” on page 2-10. The new rectangle inherits

the attributes of the last rectangle selected or has default values if no rectangle has been
selected.

Delete a Sign Rectangle

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click the rectangle you want to delete.
4 Press the Delete key or select Edit > Delete from the Main Menu.

Edit the Shape of a Rectangle

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click the rectangle you want to edit.
4 Click and drag the edges of the rectangle. The pointer changes to the resize symbol.

Change the Color or Other Visual Properties of a Rectangle

1 Click the Sign Tool button.
2 Click the sign you want to edit: either a sign asset in the Asset Browser or an instance of a sign in

the 3D scene.
3 Click the rectangle you want to edit. The attributes of the rectangle appear in the Attributes

Panel.
4 Edit the desired attributes in the Attributes Panel.
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Slip Road Tool

The Slip Road Tool is used to create onramps, offramps, and road splits.

When using the Slip Road Tool, a light blue circle follows the pointer. This circle snaps to lanes and
the lavender road node lines at the ends of roads.

Different actions occur depending on which objects you select, the locations where you right-click,
and whether you are pressing the Shift key.

Create a Single-Lane Onramp or Offramp

1 Click the Slip Road Tool button.
2 Move the pointer over the outermost driving lane of a road. The light blue circle gets slightly

larger.
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3 Right-click and drag to show a preview of the slip road to create. This action forms either an
onramp or offramp, depending on whether you are dragging ahead of the starting point or behind
the starting point.

4 Release the right-click button to create the road.

Tip  If you release the right-click button on another road, the new road is a slip road at both ends.
For example, it could be an offramp for the first road and an onramp for the second.

Junctions are automatically created whenever multiple roads overlap, including in slip road cases.
Refer to “Junction Tools” for more information on working with junctions.

For example, you can use the “Corner Tool” on page 5-23 to adjust the geometry of the curve between
the ramp and the main road:

Junctions involving slip roads still contain maneuver roads (see “Maneuver Tool” on page 5-65). The
automatically-created maneuver roads are not guaranteed to match the expected connectivity. It is
recommended to double-check maneuver road topology in slip road junctions as you would do with an
at-grade intersection. This is important to ensure that the lane connectivity is correct when exporting
to a format like OpenDRIVE®.
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Create a Multilane Onramp / Offramp

1 Select the Slip Road Tool.
2 Move the pointer over the innermost driving lane that you want to connect to the ramp. The light

blue circle gets slightly larger. This lane and all lanes up to the edge of the road will connect to
the ramp.

3 Right-click and drag to show a preview of the slip road to create. This action forms either an
onramp or offramp, depending on whether you drag ahead of the starting point or behind the
starting point.

4 Release the right-click button to create the road.

Note  By default, the driving lanes between the selected lane and the edge of the road end at the
new junction. That is, in an offramp case, these lanes are dedicated offramp lanes that do not
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continue along the main road. If you hold the Shift key when you release the right-click button, this
behavior is disabled and all driving lanes continue along the main road.

Create a Road Split

You can split a road into two roads by creating slip roads at the end of a road.

1 Click the Slip Road Tool button.
2 On the lavender road node line at the end of a road, move the pointer over the innermost driving

lane that you want to connect to the new slip road. The new slip road will include this lane and
all lanes up to the edge of the road.

3 Right-click and drag to show a preview of the slip road.
4 Release the right-click button to create the road.

You can optionally provide more fine-grained control over the lanes to be included in the slip road.
This is useful for creating more advanced types of road splits.

Before following the steps above, select a range of lanes on the lavender road node line. The created
slip road will connect to the range of lanes defined by the innermost and outermost selected lanes.

 Slip Road Tool

5-149



Create a Channelized Turn Lane

You can also use the Slip Road Tool to create physically separated, branching lanes in any situation.

For example, you can create a channelized right turn lane on an at-grade intersection. Follow the
steps to create a single lane on page 5-146 or multilane on page 5-148 ramp on a road leading up to
an intersection. If you end your drag on the crossing road, it will create a channelized turn lane.

Adjust Where a Slip Road Is Connected

You can adjust where a slip road is attached to the road at its ends:

1 Select the “Road Plan Tool” on page 5-108.
2 Click and drag the dashed lavender road node at the end of a slip road.
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Surface Tool

The Surface Tool models surfaces around roads, such as walkways, driveways, parking lots, and
natural terrain.

Overview
Terrain Surface Model

Terrain surfaces are regions graphs on page 5-15 bounded by curves. Some of these curves are
created automatically (such as the curves on the boundaries of roads). Other curves can be created
manually using the Surface Tool.

Here is an example of a single terrain surface bounded by manually created surface curves:

The points on the graph edge curve are curve end nodes, which can be shared by multiple curves. In
most regards, these curves use the same UI concepts outlined in the “Curve Editing” on page 5-3 and
“Polygon Editing” on page 5-5 pages.

In particular, each curve has a tangent direction that can be modified to change the shape of the
curve, as shown in this image:
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Each surface curve can have one surface connected to each side. The nodes can be shared by any
number of surface curves. In this manner, the surface curves form a contiguous (nonoverlapping)
patchwork of surfaces called a surface graph.

For example, you can split an initial surface into two surfaces by digitizing new surface curves in the
interior (taking care to share end nodes on the perimeter of the surface):

Surfaces also support enclosed surfaces (surfaces within surfaces). Any time a loop of surface curves
lies entirely within the interior of another surface, it creates a new surface in the interior.

The following image shows two nested levels of enclosed surfaces:
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It is important that surfaces do not overlap. Surfaces that overlap (in the XY dimension) cause visual
artifacts ("z-fighting" artifacts).

These artifacts can be seen in the following example, where a new loop of surface curves crosses the
existing surface curves:

To correct this situation, you must split the original surface curves to introduce nodes. These nodes
are then shared by multiple surface curves.

The example below includes corrected nodes.
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Surfaces and Roads

Roads automatically participate in the surface graph.

Roads that lie entirely within a terrain surface behave much like enclosed surfaces. Terrain surface
curves are automatically created around the perimeter of the roads, forming an enclosed road
surface.

In the following image, a simple intersection has been digitized (using the “Road Plan Tool” on page
5-108) in the interior of the surface:

As with overlapping surfaces, roads that overlap a surface curve can cause visual artifacts.

For example, dragging the end of a road such that it crosses a surface curve causes artifacts:
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One way to correct this issue is to adjust the containing surface such that the roads are fully
enclosed:

Surfaces can also be connected directly to roads. This enables surfaces to automatically move when
the roads are moved, helping to avoid overlaps.

In the following image, the three nodes are attached to the roads. Some of these nodes (such as the
two at the end of the road) are created automatically and cannot be removed or deleted in the
Surface Tool. Nodes can also be added parametrically along the side of a road. These points can be
inserted anywhere along a road, dragged along the road, or deleted.
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When surfaces are attached to these road surface nodes, moving the road automatically adjusts the
surfaces.

In the following image, the end of the road is moved toward the right:

Bridges

Only nonbridge portions of road surfaces participate in the surface graph (refer to the “Road
Construction Tool” on page 5-96). The surface graph ignores road construction spans that are marked
as bridges.

For example, the selected construction span in the following image is marked as a bridge:
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Note  A bridge span that has similar elevation to the surfaces underneath it can produce visual
artifacts. To avoid artifacts, ensure that the elevation of the bridge span is above the ground surface
beneath it (using the “Road Height Tool” on page 5-102).

Extruded Surfaces

Surfaces have an optional height attribute. If the height is nonzero, the surface is vertically extruded
upwards. This can be used to create simple mock buildings, as shown here:

Surfaces and Elevation

By default, the heights within a surface are automatically interpolated from the heights of the
surrounding surface curves.
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For example, this image shows a surface whose curves have a nonzero height (Z coordinate):

In scenes with Elevation Maps on page 4-4, each surface can optionally use the elevation maps to
define the interior elevations of the surface. This is illustrated in the images in the following sections.
For more details, see Control Whether a Surface Uses Elevation Samples on page 5-159.

Terrain Surface Attributes
Attribute Description
Material The Material Asset on page 4-10 to apply to the

surface.
Offset An XY offset to apply to the texture coordinates of

the surface.
Scale An XY scale to apply to the texture coordinates of

the surface.
Rotation An additional rotation to apply to the texture

coordinates of the surface.
Height If nonzero, the surface is extruded upward by this

amount.
Flat Top If a terrain surface's curves are not flat, then this

option forces the extruded top of the surface to
be flat.

This attribute affects only surfaces with nonzero
"Height" values.
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Attribute Description
Extrude Inner Regions If true, any enclosed surfaces form either holes or

raised areas (depending on the elevation of their
surface curves). If false, the outer surface slopes
downwards (or upwards) to meet the height of
the enclosed surface.

Only impacts surfaces with nonzero "Height"
values.

Edit Terrain Surface Curves and Regions
See “Region Graph Editing” on page 5-15.

Insert a Terrain Surface Node Along a Road Boundary
1 Click the Surface Tool button.
2 Right-click a terrain surface curve along a road boundary.

Note  You can slide these types of nodes along the road using click and drag.

Change the Material Assigned to a Terrain Surface
1 Click the Surface Tool button.
2 Select a terrain surface.
3 Assign a Material Asset on page 4-10 to the "Material" widget in the “Attributes Panel” on page 2-

20.

Alternatively, click and drag a Material Asset on page 4-10 from the “Library Browser” on page 2-13
onto a terrain surface. This operation can be performed in any tool.

Control Whether a Surface Uses Elevation Samples
By default, the interior of a surface is smoothly interpolated from its boundaries. Surfaces can
optionally use the elevation maps in the scene to determine the heights of interior points as follows:

1 Configure the elevation maps through the Elevation Map Tool as desired, using the previous
instructions.
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2 Click the Surface Tool button.
3 Select a surface.
4 Enable the Sample Global Elevation option in the “Attributes Panel” on page 2-20.

Sample Global Elevation: Off
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Sample Global Elevation: On

Note  This setting affects only the interior of the surface. The heights along the perimeter of the
surface are still defined by the surface curves, which are independent from the elevation map.

You can better align the perimeter of a surface to the elevation map by first inserting additional nodes
along the perimeter of the surface (where needed). Then, project the nodes to the surface using the
Project Nodes button in the “Sub-Tool Bar” on page 2-10.
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Vector Data Tool

The Vector Data Tool manages the import and configuration of vector data files, and enables
exploration of the shape attributes. RoadRunner can load a variety of georeferenced vector map files,
such as Shape files (.shp), OpenStreetMap files (.osm), GeoJSON files (.json, .geojson), and GPS
Exchange files (.gpx). Vector data such as points, lines, and polygons can be loaded from these files
along with their associated attributes.

Refer to the “Vector Data Assets” on page 4-37 page for a list of supported formats.

Note  The Vector Data Tool is used to visualize and explore vector file types for use as visual
references. Automatic conversion of vector map data into the RoadRunner internal format is not
supported.

Import a Georeferenced Vector Map
1 Click the Vector Data Tool button.
2 In the “Library Browser” on page 2-13, navigate to the directory containing the vector data on

page 4-37 file you want to import.
3 Click and drag the asset from the Library Browser into the 3D scene.

Note If the geographic position has not yet been set for this scene, the scene center is set to the
latitudinal and longitudinal center of the image. You can change the scene center using the “World
Settings Tool” on page 5-165.

If the geographic position has already been set, but the imported image is outside of the maximum
range of the scene, an error dialog box appears and cancels the import.

Remove a Vector Map
1 Click the Vector Data Tool button.
2 Click within the bounding box of the vector map you want to delete. Do not click the vector

element itself. Instead, click an empty space within the bounding box. When the map is clicked,
the bounding box turns red.

3 Press the Delete key or select Edit > Delete from the Main Menu.

Adjust the Properties of a Vector Map
1 Click the Vector Data Tool button.
2 Click within the bounding box of the vector map you want to adjust. Do not click the vector

element itself. Instead, click an empty space within the bounding box. When the map is clicked,
the bounding box turns red.
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3 Adjust any properties as desired on the Attributes Panel.

Toggle the Display of Vector Data
Select View > Vector Data on the Main Menu or press the F7 key.

View the Attributes of a Feature in a Vector Map
1 Click the Vector Data Tool button.
2 Click the vector feature you want to examine. The properties of the feature are displayed in the

Attributes Panel.

• You can select multiple features to view the aggregate set of attributes for all selected
features.

• If you click an attribute field name or value in the Attributes Panel, the main scene highlights
the objects with that value.

Color Features Based on Attributes

You can apply custom colors to vector features based on type or other attribute values as follows:

1 Click the Vector Data Tool button.
2 Select the features that you want to recolor (or press Ctrl+A to select all).
3 In the Attributes Panel, locate the feature attribute that you want to use for recoloring. If you

click an attribute field name or value, the main scene highlights the objects with that value.
4 Right-click an attribute field name or value, and select Color With.
5 Choose a color in the color picker.

Note  You can hide the highlighted features by setting the Alpha channel value to 0.

Clear Feature Colors
If you assigned a custom color to vector features, you can clear the custom color as follows:
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1 Click the Vector Data Tool button.
2 Select the features whose colors you want to reset (or press Ctrl+A to select all).
3 In the Attributes Panel, locate the feature attribute whose colors you want to reset.
4 Right-click an attribute field name or value and select Clear Colors.
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World Settings Tool

The World Settings Tool is used to configure the geographic position and size of the environment
model.

RoadRunner allows models to optionally be georeferenced, meaning they are built to match a
particular location on the surface of the Earth.

For more information about the coordinate system used in RoadRunner, refer to “Coordinate Space
and Georeferencing” on page 3-2.

Working with GIS Data
Ideally, set the desired latitude and longitude in your scene before importing any GIS files or before
starting to model any roads. To do so, follow the instructions in the “Specify an Initial Latitude/
Longitude Origin for the Scene” on page 5-165 section. This enables you to enter explicit latitude and
longitude values.

Another option is to center the origin on the first GIS file imported. RoadRunner does this
automatically if you try to drag a GIS file into the scene without having set the origin. Once the origin
is set, any additional GIS files brought in are positioned relative to the specified origin.

Note that you can always adjust your world origin later, though it is recommended to make all
adjustments prior to creating any roads or other scene elements. Changing the world origin after GIS
files have been imported will change the map projection and will require all GIS files to be reloaded
and reprojected. This is done automatically when you change the origin.

Scene Workspace
The scene workspace defines the rectangular size of the environment model. This rectangular region
is referred to as the workspace and is based on a center XY coordinate (in meters relative to the
origin) and an XY rectangle size, defined in meters.

Because GIS data can get quite large, RoadRunner loads only GIS data that lies within the
workspace. The scene workspace is also used for export. The visual scene is geometrically clipped
against the scene workspace during export.

The workspace dimensions can be easily changed at any time using the steps in “Change the
Workspace Size and Location” on page 5-167.

Specify an Initial Latitude/Longitude Origin for the Scene
1 Click the World Settings Tool button.
2 Enter the desired latitude and longitude that you want to use as the origin of the scene in the

World Origin section of the Attributes Panel.

 World Settings Tool

5-165



3 Click the Apply World Changes button on the Attributes Panel.

Clear the Geographic Position
1 Click the World Settings Tool button.
2 Press the Clear World Projection button in the Attributes Panel.
3 A warning dialog appears, saying that clearing the projection invalidates imported GIS files. To

proceed, press the Clear button.

Center the Geographic Position on an Existing GIS File
1 Click the World Settings Tool button.
2 Click the GIS file you want to center the projection on.
3 Press the Center World on Selected button in the Attributes Panel.
4 Press the Apply World Changes button in the Attributes Panel.
5 A dialog box appears, asking if you want to just change the world projection (the Only Change

Projection button) or if you want to transform the model to the new projection (the Transform
Scene button). See the note on changing world settings to determine the appropriate action and
click the appropriate button.

Change the Origin of the Environment to a Specific Latitude/Longitude
1 Click the World Settings Tool button.
2 Enter the desired latitude and longitude that you want to use as the origin of the scene in the

World Origin section of the Attributes Panel.
3 Click the Apply World Changes button on the Attributes Panel.
4 A dialog appears, asking if you want to just change the world projection (the Only Change

Projection button) or if you want to transform the model to the new projection (the Transform
Scene button). See the note on changing world settings to determine the appropriate action and
press the appropriate button.

Alternatively, follow these steps:

1 Click the World Settings Tool button. Locate the green circular mark indicating the World
Origin.

2 Click and drag the World Origin mark to the desired new origin position.
3 Click the Apply World Changes button on the Attributes Panel.
4 A dialog appears, asking if you want to just change the world projection (the Only Change

Projection button) or if you want to transform the model to the new projection (the Transform
Scene button). See the note on changing world settings to determine the appropriate action and
press the appropriate button.

Note To transform a scene, you have two options:

• Only Change Projection: Use this option if want to change the origin without moving any scene
objects. This changes the lat/long locations of the objects but preserves their local (XY)
coordinates.
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• Transform Scene: Use this option if want to change the origin and move objects to preserve their
location on the earth. This changes the local (XY) coordinates of the objects but preserves their
geographic (lat/long) coordinates.

Change the Workspace Size and Location
1 Click the World Settings Tool button.
2 Enter the desired workspace parameters (Center and Extents) on the Attributes Panel.

Alternatively, follow these steps:

1 Click and drag inside the blue World Origin box in the “3D Edit Window” on page 2-11 to move
the center of the workspace.

2 Click and drag the edges or corners of the blue World Origin box to change the dimensions of the
workspace.

3 Click the Apply World Changes button on the Attributes Panel.

Note Changing the workspace does not remove or modify any data in the scene. When working with
large GIS files, it can be useful to shrink the workspace to view only the portion of the file you want to
view at a given time. However, remember to increase the workspace size again before exporting.
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Importing OpenDRIVE Files
RoadRunner can import OpenDRIVE files and convert the data to the internal road format.

OpenDRIVE Overview
RoadRunner can visualize and import OpenDRIVE 1.4 data, converting the data to the internal road
format during import. The OpenDRIVE data is visualized before import. The import option is designed
to enable editing of OpenDRIVE files.

Import OpenDRIVE into Scene
1 Add the OpenDRIVE file to the Library Browser in RoadRunner.
2 Click and drag the OpenDRIVE file from the Library Browser into the scene. This action switches

to the OpenDRIVE Viewer Tool.
3 Click the imported file in the 3D scene and click the Convert to Roads button in the actions

toolbar.

Import Objects and Signs
See the "OpenDRIVE User Asset Configuration" section of “Exporting to OpenDRIVE” on page 7-18.

Import Options
The OpenDRIVE import dialog box provides these options:

• Import Props: If this option is enabled, all <object> entries are mapped to props or markings as
needed.

• Import Signals: If this option is enabled, all <signal> entries are mapped to signals or signs as
needed.

Limitations
• Lane connections are stored differently between OpenDRIVE and RoadRunner. Lanes that were

connected in OpenDRIVE might be disconnected in RoadRunner. A validation error is printed if
this is the case.

• Some OpenDRIVE files do not distinguish between logical and physical position of signs and
signals. During import, signs and signals might be placed directly on the road surface at the
stopping location.

• RoadRunner road plan geometry requires that segments (line, arc, clothoid, or parametric cubic)
be continuous. Some OpenDRIVE data might be defined as a series of <line> segments that are
mapped to a continuous curve during import. The OpenDRIVE geometry type <poly3> is not
supported.

• RoadRunner roads cannot connect to themselves. Connections in OpenDRIVE of a road connected
to itself is ignored during import.

• RoadRunner creates junctions based on the overlap of roads. If roads are overlapping in
OpenDRIVE, a junction might be created during import.
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Exporting to AutoCAD
You can export RoadRunner scenes to the AutoCAD DXF file format.

AutoCAD Export
From the menu, select File > Export > AutoCAD (.dxf).

Export Options
Set the file destination and click Export.
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Exporting to FBX
RoadRunner can export scenes to the FBX file format. Although this option is compatible with Unity
and Unreal®, for those applications, using the specific export option along with MathWorks plugins is
recommended.

Export Options

Split by Segmentation

This parameter splits meshes by their segmentation type on page 3-9.

Embed Textures

This parameter embeds the exported textures inside the FBX file.

Tiling

The Export To Tiles parameter splits the meshes per tile. This parameter also groups props by the
tile that they are in.

• By default, only one file is exported. Tiles are stored in separate nodes.
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• If Export Individual Tiles is enabled, then each tile is stored in its own FBX file (for example,
scene _Tile_0_1 .fbx).

Advanced Details
Node Naming

• All nodes have "Node" appended to the end of their name (for example, RoadsNode).
• Props have their GUID prepended to the front of their name (for example, {40ce66ca-

c817-425b-8802-17cdbd76371f}Signal_Post_30ftNode).

• Props generated from a curve, polygon, or span share GUIDs with the associated curve,
polygon, or span.

• During export, all node names in the scene graph are made to be unique.

• "_#" is appended for duplicate node names (for example, light_green_1Node).
• Because the scene graph is not a tree, duplicate names are still possible when converting to

FBX if there are multiple instances of the same node (such as when reusing props).
• When the mesh is split by segmentation, the roads and terrain have extra child nodes for each

segmentation type it has, with the segmentation type appended to the name (for example,
Road_SidewalkNode).

• When the mesh is split by transparency sorting layer (for the Unreal on page 7-55 export option),
the roads and terrain have extra child nodes for each sorting layer, with the layer number
appended to the name (for example, Roads_Layer2Node).

• This can also be combined with the segmentation type (for example,
Road_Sidewalk_Layer0Node).

• For traffic signals on page 5-130, the name of the variant is added to the FBX name (for example,
{4674ef2e-deea-403c-9b52-487e0ba9f13d}Signal_3Light_Bare01_RedYellowGreen LeftNode).

Material Details

• Materials are converted into FbxSurfacePhong materials.
• When the mesh is split by segmentation, the segmentation type is appended to the material name

(for example, Concrete1_Curb).
• When materials need a transparency sorting order defined (typically for overlapping transparent

markings), a duplicate of the material is created.
• Materials with duplicate names add "_#" to distinguish between them (for example, Leaves_1).

• This can be combined with the segmentation type (for example, OilPath01_Road_1).

FBX Scene Settings

• RoadRunner exports scenes with the Maya Z-up axis system. Units are in meters.

Combo Exports

Other export options combine the FBX export with other files. Depending on the target application,
the RoadRunner software applies extra changes.

• Unity on page 7-38: Mesh is identical to the normal FBX export option.
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• Unreal on page 7-55: Mesh is split by transparency sorting order.
• CARLA on page 7-63: Mesh is split by segmentation and transparency sorting order.
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Exporting to glTF
RoadRunner can export scenes to the GL Transmission Format (glTF).

glTF Export
From the menu, select File > Export > glTF (.gltf).

Export Options

Split by Segmentation

This parameter splits meshes by their segmentation type on page 3-9.

Tiling Options

The Export to Tiles parameter splits the meshes per tile. This parameter also groups props by the
tile that they are in.

• By default, only one file is exported. Tiles are stored in separate nodes.
• If Export Individual Tiles is enabled, then each tile is stored in its own glTF file (for example,

scene _Tile_1_2.gltf).
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Limitations
RoadRunner follows the glTF 2.0 specification as much as possible, but there are some limitations.

• Texture sampler information is not exported. This limitation might result in texture clamping
issues for objects like signs.

• RoadRunner uses a specular setup for materials. Because glTF uses metallic-roughness by default,
RoadRunner attaches whatever is in the "Specular Map" slot to the "metallicRoughnessTexture" in
the exported material and sets the "metallicFactor" to 0.
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Exporting to OpenFlight
RoadRunner can export scenes to the OpenFlight (.flt) file format.

OpenFlight Export
From the menu, select File > Export > OpenFlight (.flt).

Export Options

Split by Segmentation

This parameter splits meshes by their segmentation type on page 3-9.

Tiling Options

The Export to Tiles parameter splits the meshes per tile. This parameter also groups props by the
tile that they are in.

• By default, only one file is exported. Tiles are stored in separate nodes.
• If Export Individual Tiles is enabled, then each tile is stored in its own FLT file (for example,

scene_Tile_1_2.flt).
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Limitations
• Texture wrapping settings are not exported. This limitation might result in texture clamping issues

for objects like signs.
• The OpenFlight file is exported through the OpenSceneGraph plugin, which exports OpenFlight

version 16.1.
• RoadRunner does not export the normal or specular maps for materials.
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Exporting to OpenSceneGraph
RoadRunner can export scenes to various OpenSceneGraph file formats, including ".osg", ".osgb", and
".ive".

OpenSceneGraph Export
From the menu, select File > Export > OpenSceneGraph (.osg, .osgb, .ive).

Export Options

Split by Segmentation

This parameter splits meshes by their segmentation type on page 3-9.

Embed Textures

This parameter embeds the exported textures inside the OpenSceneGraph file.

Tiling Options

The Export to Tiles parameter splits the meshes per tile. This parameter also groups props by the
tile that they are in.
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• By default, only one file is exported. Tiles are stored in separate nodes.
• If Export Individual Tiles is enabled, then each tile is stored in its own OpenSceneGraph file (for

example, scene_Tile_1_2.osg).

Limitations
• Texture wrapping settings are not exported. This limitation might result in texture clamping issues

for objects like signs.
• RoadRunner does not export the normal or specular maps for materials.
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Exporting to Wavefront OBJ
RoadRunner can export scenes to the Wavefront OBJ (.obj) file format.

Wavefront Export
From the menu, select File > Export > Wavefront (.obj).

Export Options
Set the file destination and click Export.

Advanced Details
This code shows an example of a material in an exported Material Library (.mtl) file:
newmtl Grass1                     # Material Name
illum 2                           # Color with specular highlights
Ka 1.000000 1.000000 1.000000     # Ambient color matches the diffuse
Kd 1.000000 1.000000 1.000000     # Diffuse color
Ks 0.039216 0.039216 0.039216     # Specular color
Ns 800.200012                     # Specular exponent, approximated from the Roughness value
Tr 0.000000                       # Transparency
map_Kd Grass1_Diff.png            # Diffuse Map
map_bump Grass1_Norm.png          # Normal Map
map_Ks Grass1_Spec.png            # Specular Map
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Exporting to GeoJSON
RoadRunner can export scenes to a GeoJSON file format. This format is meant to complement the
OpenDRIVE file format and fill in some of its missing data, but it can also be used on its own.

GeoJSON Export
From the menu, select File > Export > GeoJSON (.geojson).

Export Options
Set the file destination and click Export.

GeoJSON Details
The MathWorks version of the GeoJSON format is a collection of lanes, lane boundaries, junctions,
gates, crosswalks, and signals.

This code shows a sample GeoJSON file.
'#' are double values compliant with JSON
{
     "features": [{  
         "geometry": {    
             "coordinates": [[#,#,#], ...],    
             "type": "LineString"   
          },
          "properties": {    
              "Id": 1,    
              "LaneType": "Curb",    
              "LeftBoundary": {     
                  "Dir": "Forward",     
                  "Id": 0
              },   
              "Predecessors": [{      
                  "Dir": "Forward",     
                  "Id": 4
              } ],    
              "RightBoundary": {     
                  "Dir": "Forward",     
                  "Id": 5
               },    
              "Successors": [{      
                  "Dir": "Backward",      
                  "Id": 6
              }],    
              "TravelDir": "Undirected",    
              "Type": "Lane"   
          },   
          "type": "Feature"  
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      },
      {
         "geometry": { 
             "coordinates": [[#,#,#], ...], 
             "type": "LineString" 
         }, 
         "properties": { 
             "Id": 0, 
             "LeftLane": { 
                 "Dir": "Forward", 
                 "Id": 1
             }, 
             "RightLane": { 
                 "Dir": "Forward", 
                 "Id": 2
             },
             "Type": "LaneBoundary" 
         }, 
        "type": "Feature" 
    },
    {
        "geometry": {
              "coordiantes": [[[[#,#,#], …], …], …],
              "type": "MultiPolygon"
        },
        "properties: {
              "Id": 12,
              "Type": "Junction",
              "Gates": [{"Id": 775}, …],
              "Lanes": [{"Id": 52}, …],
              "Phases": [
                  "Phases": [{
                      "Intervals": [{
                          "BulbStates": [{"Id":0, "On": false, "SignalId": 767}, …],
                          "GateStates": [{"Id": 775, "State": "StopYield"}, …]
                      }]
                  }]
              ]
        },
        "type": "Feature"
    },
    {
        "geometry": {
            "coordinates": [[#,#,#], …],
            "type": "LineString"
        },
        "properties": {
            "Id": 775,
            "Lane": {"Id": 233"},
            "Signals": [{"Id":771}, …],
            "Type": "Gate"
        },
        "type": "Feature"
    },
    {
        "geometry": {
            "coordinates": [[[#,#,#], …], …],
            "type": "Polygon"
        },
        "properties": {
            "Id": 763,
            "Bulbs": [
                {
                    "Point": [#,#,#],
                    "Name": "LeftTurnRed", 
                    "NodeName": "light_red"
                },
                …
            ],
            "Name": "PathToFile.fbx",
            "SignalType": "Signal",
            "Type": "Signal"
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        },
        "type": "Feature"
    }]
}
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Exporting to USD
RoadRunner can export to the Universal Scene Description (USD) file format.

USD Export
From the menu, select File > Export > USD (.usd, .usdc, .usda).

Setting the file extension to .usd or .usdc creates a USD binary file. Setting the extension to .usda
creates a USD ASCII file.

Export Options

Split by Segmentation

This option splits meshes by their “Segmentation” on page 3-9 type.

Tiling Options

The Export to Tiles parameter splits the meshes per tile. The parameter also groups props by the
tile they are in.

• By default, only one file is exported. Tiles are stored in separate nodes.
• If Export Individual Tiles is enabled, each tile is stored in its own USD file (for example,

scene_Tile_1_2.usd).
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Limitations
There are several limitations with the UsdPreviewSurface schema, which limits the ability to map
RoadRunner materials to USD materials. Here is a list of known issues:

• UsdPreviewSurface cannot support diffuse color scaling and vertex coloring at the same time.
RoadRunner sets the texture reader's scale to the diffuse color of the material. However, vertex
colors and a primvar reader for them are still included if you want to use them.

• Because UsdPreviewSurface does not support specifying a rendering order, overlapping
transparent surfaces are not supported.

• Because the double-sided attribute is stored per mesh instead of per material, it is not exported.
Therefore, some props (mainly trees) might not render properly.
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Exporting to OpenDRIVE
RoadRunner can export scenes to the OpenDRIVE (.xodr) file format.

OpenDRIVE Overview
RoadRunner can export scenes to the OpenDRIVE 1.4 format. The OpenDRIVE export option exports
an OpenDRIVE (.xodr) file containing the layout of the scene and an optional MathWorks GeoJSON
file.

Export to OpenDRIVE
From the menu, select File > Export > OpenDRIVE (.xodr).

To preview the OpenDRIVE export and explore exported data interactively, use the “OpenDRIVE
Export Preview Tool” on page 5-79

Export Options
The OpenDRIVE export dialog box has several options to conform to various simulator needs.
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Attribute Description
Database Version A user-defined identifier for the exported scene.

Useful for versioning exports of the same scene.
Database Name (optional) A user-defined name for the exported scene.
Driving Side A hint to the exporter for the driving side of the

scene. Travel direction is explicitly defined in
RoadRunner using the Lane Travel Direction.

The travel direction in OpenDRIVE is implicit
based on the country and side of the road.

Export individual markings as <line> Export additional lane marking data (spacing,
dash length, and individual paint strip widths).

Export signals When this attribute is selected, all signals and
signs mapped to junctions are exported as
<signal> entries.

This selection applies only to signals and signs
that have been associated with junctions (using
the “Signal Tool” on page 5-130). Refer to the
Traffic Signals and Signs on page 7-23 section.

Export props When this attribute is selected, props are
exported as <object> entries. Refer to the
OpenDRIVE User Asset Configuration on page 7-
21 section.

Clamp distances When this attribute is selected, the RoadRunner
scene clamps distances to be a multiple of 1 cm
to prevent very short roads.

Note  This clamping is performed on the scene
itself, so it can cause very small changes to the
roads in the scene.

Export Auxiliary Data Exports a MathWorks GeoJSON file along with
the exported OpenDRIVE file. For more details,
see “Exporting to GeoJSON” on page 7-13.

OpenDRIVE Representations
This section describes how various types of RoadRunner objects are represented in OpenDRIVE.
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Roads, Lanes, and Junctions

Roads, lanes, and junctions are exported to OpenDRIVE using the standard <road>, <lane>, and
<junction> entries.

For each road in a scene, RoadRunner creates one or more <road> entries. Whenever a road ends or
a junction begins or ends, RoadRunner creates a unique <road> entry. OpenDRIVE <road> entries
cannot extend through a junction, so the geometry is cut and exported as separate roads.

Note The <shape>, <crossfall>, <surface>, and <railroad> entries are not used.

For each lane in a scene, RoadRunner creates one or more <lane> entries. The resulting <lane>
entry is placed on one side or the other of the center lane, depending on its travel direction or the
travel direction of neighboring lanes and the selected Driving Side during export. Whenever a lane
starts or ends, RoadRunner creates a new <laneSection> entry.

Note The "level" flag in <lane> entries is not used. The <height>, <material>, <visibility>, and
<access> entries are also not used.

For each junction in a scene, RoadRunner creates a <junction> entry. RoadRunner exports some
junctions as one <junction> entry due to overlapping maneuver roads or corners. A connecting
<road> entry is exported for each maneuver road in each junction. Where possible, the exporter
prefers the geometry and lane markings of nonmaneuver roads that extend through the junction. The
resulting geometry of each connecting road might be the combination of multiple maneuver and
nonmaneuver roads.

Note The <priority> entry is not used.

7 Exporting

7-20



Props

Note Prop polygons on page 5-92 are not exported, but if you run the 'bake' operation to convert
them to points, you can export them in point format.

With the exception of traffic signals and signs (see below), point props are exported as OpenDRIVE
<object> instances. The exported prop includes sufficient information to identify the prop type and
the oriented bounding box (OBB) of the prop model.

In OpenDRIVE, objects are stored on roads. The position and orientation of a given object depends on
the geometry of the road it is assigned to. RoadRunner props are freely positioned in the world, so
the export process must choose a road for each prop to export. In most cases, RoadRunner selects the
road closest to the prop.

Note In some cases, it is impossible to represent a prop's position in OpenDRIVE. In this image, the
bush on the right is past the end of the road and there is no other road in the scene. In this case, the
prop is not exported and a warning is displayed during export.

Prop Attributes

Exported props include the following attributes:

OpenDRIVE Attribute Description
name Name of the prop asset (for example,

"Signal_Post_30ft")
s/t Inertial position of the prop point
hdg/roll/pitch Inertial rotations of the prop point
zOffset Relative height of the prop point
height/width/length Dimensions of the prop model's bounding box
type Object type, as defined by the configuration XML

file for the point's asset (refer to OpenDRIVE
User Asset Configuration on page 7-21)
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Crosswalks and Marking Polygons

Crosswalks on page 4-3 and marking polygons on page 5-76 are exported as OpenDRIVE <outline>
objects, similar to the crosswalk example in section 7.4 of the OpenDRIVE 1.5M specification.

Unlike that example, RoadRunner exports the polygon vertices as <cornerLocal> objects (rather than
<cornerRoad> objects), which means that the vertices are defined relative to the pivot point specified
in the attributes of the <object> parent.

This example code shows the representation of the crosswalk polygon in the previous image.

<object id="162" name="ContinentalCrosswalk" s="5.9095723267801631e+1" t="1.7834630409170869e+0" zOffset="1.9073486328125000e-6" hdg="1.3359605073928833e+0" roll="0.0000000000000000e+0" pitch="0.0000000000000000e+0" orientation="-" type="crosswalk" width="2.9256307177817877e+0" length="1.6163854233175169e+1">
    <outline>
        <cornerLocal u="-8.0157129245630365e+0" v="1.4628157932607735e+0" z="0.0000000000000000e+0"/>
        <cornerLocal u="8.0819274304890261e+0" v="1.0363072624453764e+0" z="-1.9073486328125000e-6"/>
        <cornerLocal u="8.0157129245556504e+0" v="-1.4628157932298933e+0" z="-1.9073486328125000e-6"/>
        <cornerLocal u="-8.0819274304964104e+0" v="-1.0363072624144962e+0" z="0.0000000000000000e+0"/>
        <cornerLocal u="-8.0157129245630365e+0" v="1.4628157932607735e+0" z="0.0000000000000000e+0"/>
    </outline>
</object>

Crosswalks and Marking Polygon Attributes

Exported crosswalks and marking polygons include the following attributes.

OpenDRIVE Attribute Description
name Name of the marking (for example,

"ContinentalCrosswalk")
s/t Inertial position of the pivot point
hdg/roll/pitch Inertial rotations of the pivot point
zOffset Relative height of the pivot point
height/width/length Dimensions of an oriented bounding box fit to the

polygon's vertices. The 'width' is treated as the
dimension along the road, and the 'length' is
treated as the dimension across the road.

type Object type, as defined by the configuration XML
file for the marking's asset (refer to OpenDRIVE
User Asset Configuration on page 7-21)
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Traffic Signals and Signs

RoadRunner exports traffic signals and signs as OpenDRIVE <signal> objects.

For optimal behavior, traffic signals and signs for controlled intersections should be mapped to
junction gates by using the “Signal Tool” on page 5-130. Traffic signals are exported only if they are
mapped to junction gates. Signs are exported regardless if they are mapped to junction gates and are
automatically mapped to the nearest road if not explicitly mapped.

If you need to add a traffic signal outside of a controlled intersection (for example, for a freeway
onramp or pedestrian crossing), you can use the “Custom Junction Tool” on page 5-31 to create a
junction along a single road.

Note Traffic signals and signs within “Prop Assembly Assets” on page 4-14 are not exported. To
export signals or signs in an assembly, you must first expand the instance of the assembly on page 4-
14.

Signals and Signal References

When a signal or sign is mapped to a junction gate, it appears in the OpenDRIVE export as a
<signal> instance and one or more <signalReference> instances, where:

• <signal> defines the physical location of the signal. Use <signal> to derive the 3D location of the
signal, regardless of which roads or lanes are controlled by the signal. In most cases, the signal is
mapped to the closest road (similar to the approach used for “Props” on page 7-21). This mapping
might have no logical association to the signal (for example, the signal could be a nearby side
street).

• <signalReference> associates the signal to the roads and lanes that are controlled by the signal.
Signal references indicate the semantic relationship between the signal and the road network (as
opposed to <signal>, which is used purely for geometric positioning). Signal references are
present for each maneuver road gate associated with the signal (through the “Signal Tool” on
page 5-130).

Signal Attributes

Exported signals and signs include the following attributes:
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OpenDRIVE Attribute Description
name

s/t

hOffset/roll/pitch

zOffset

height/width/length

Refer to Prop Attributes on page 7-21.

"hOffset" is treated the same as the <object>
"hdg" attribute.

type/subtype Signal type and subtype, as defined by the
configuration XML file for the signal's asset (refer
to OpenDRIVE User Asset Configuration on page
7-21)

country "OpenDRIVE" is always used.
dynamic Specify "yes" for dynamic junction signalization

and "no" for static signalization (for example, "All
Go" or "All Stop")

value Unused (set to "-1" in all cases).
text Unused (set to empty string in all cases).

Parking Spaces

RoadRunner exports parking spaces as an <object> with type "parking" and an additional
<parkingSpace> entry under the <object> following section 5.3.8.1.5 in the OpenDRIVE 1.4H
specification. Markings on a parking space are exported as <marking> under the <parkingSpace>
entry following section 5.3.8.1.6 in the OpenDRIVE 1.4H specification.
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Parking Attributes

Exported parking spaces include the following attributes.

OpenDRIVE Attribute Description
name

s/t

hdg/roll/pitch

zOffset

height/width/length

Refer to Prop Attributes on page 7-21.

type Always set to "parking".
side (attribute for <marking> entries under
<parkingSpace>)

Side of the marking (left, right, front, or rear),
where the rear is the entry point of the parking
space.

type/width/color (attributes for <marking>
entries under <parkingSpace>)

Same properties as <roadMark> entries for
<lane>.

OpenDRIVE User Asset Configuration
The OpenDRIVE exporter uses a configuration XML file to map RoadRunner props, signals, signs, and
markings to the appropriate <object> or <signal> "id" and "subtype". This configuration file is also
used to define the correlation during import.

Export a Custom Prop or Signal

1 Copy the file located in the RoadRunner install location under AssetsInstall/
ResourceAssets to the "Project" folder in your project on page 3-22 (next to the
"Project.rrproj" file).

2 Open the new OpenDriveAssetData.xml file in a text editor.
3 Add entries for new objects, markings, or signals.
4 Save your file and export an OpenDRIVE file.

You do not need to restart RoadRunner after creating or modifying the OpenDriveAssetData.xml
file.

Here is the definition of the format of the OpenDriveAssetData.xml file:
<?xml version="1.0"?>
<OpenDriveAssetData>
    <Objects>
        <Object>   
            <Type> OpenDRIVE "type" </Type> (Required)
            <Id> OpenDRIVE object "id" </Id> (Optional - only used for Import)
            <Name> OpenDRIVE object "name" </Name> (Optional - only used for Import)
            <FilePath> Relative Asset file path to RoadRunner asset </FilePath> (Required)
        </Object>
    </Objects>
    <Markings>
        <RoadMark>
            <Type> OpenDRIVE "type" </Type> (Required)
            <Color> OpenDRIVE "color" </Color> (Optional)
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            <FilePath> Relative Asset file path to RoadRunner asset </FilePath> (Required)
        </RoadMark>
    </Markings>
    <Signals>
        <Signal>
            <Type> OpenDRIVE "type" </Type> (Required)
            <SubType> OpenDRIVE "subtype" </SubType> (Optional)
            <Id> OpenDRIVE signal "id" </Id> (Optional - only used for Import)
            <Name> OpenDRIVE signal "name" </Name> (Optional - only used for Import)
            <Country> OpenDRIVE signal "country" </Country> (Optional - only used for Import)
            <FilePath> File path to RoadRunner asset </FilePath> (Required)
            <Variant> Variant of RoadRunner signal/sign asset (integer, where 0 is the first variant, 1 is the second, etc.)<FilePath>
        </Signal>
    </Signals>
</OpenDriveAssetData>

Limitations
Here is a list of features that are not exported from RoadRunner to OpenDRIVE.

• Prop polygons on page 5-92 (these polygons can be exported only if you run the 'bake' operation
to convert them to points)

• Lateral profile (overall road banking is exported, but the full cross section profile on page 5-24 is
not exported)

• Lane height
• Road surface heightfield (CRG)

See Also

External Websites
• ASAM OpenDRIVE
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Left-Hand Drive Export to OpenDRIVE 1.4

Recommended Approach
If the scene being built in RoadRunner is meant to have left-hand driving, the "Driving Side" should
be set to "Left." Otherwise, it should be set to "Right."

OpenDRIVE Details
OpenDRIVE 1.4 does not have a notion of lane travel direction. Instead, it is expected that all drivable
lanes on one side of the road go one way and the drivable lanes on the other side of the road go the
opposite way.

OpenDRIVE 1.4 does not have a notion of "driving side" (for example, left-hand driving in the UK or
Japan). Instead, it is expected that the travel direction be one of these options:

• Assumed right-side (common)
• Assumed based on <header> country code (uncommon)
• Determined using the <incoming> lanes in <junction> entries (uncommon, difficult, and

sometimes impossible if no junctions are present)
• Determined by the initial orientation of placed vehicles in a scenario (most common)

RoadRunner Export
RoadRunner does the following on export for travel direction:

1 Ensures that lanes are placed on one side or the other of the OpenDRIVE road based on travel
direction

2 Writes out the travel direction of the lane in <userData> for each lane.

During export, lanes traveling in one direction are placed on one side of the OpenDRIVE road
(regardless of the lane’s original side of the road in RoadRunner), and the lanes traveling in the
opposite direction are placed on the other side of the OpenDRIVE road. The "Driving Side = Left"
option provides a hint to the exporter that lanes marked as "Forward" travel direction should (in
general) be placed on the "Left" side of the OpenDRIVE road.
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Examples
Right-Hand Driving with "Driving Side = Right"

RoadRunner Scene Exported OpenDRIVE Scene

The forming lanes are created on either side of
the center lane. Travel direction is irrespective of
the side of the road.

The lanes are placed on each side (colored red
and green for left and right, respectively) to
adhere to the OpenDRIVE travel direction
restrictions.

Left-Hand Driving with "Driving Side = Left"

RoadRunner Scene Exported OpenDRIVE Scene

The forming lanes are created on either side of
the center lane. Travel direction is irrespective of
the side of the road.

The resulting OpenDRIVE road is the same as the
previous OpenDRIVE road (this is expected).
However, these roads will not be identical in
regards to junctions because the <incoming>
lanes will be different for the right vs. left cases.
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Left-Hand Driving with "Driving Side = Right" (Not Recommended)

RoadRunner Scene Exported OpenDRIVE Scene

The forming lanes are created on either side of
the center lane. Travel direction is irrespective of
the side of the road.

All lanes are on the same side of the road. The
following warnings are printed in the Output
panel:

WARNING: Detected non-critical validation issues.
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Downloading Plugins
RoadRunner provides plugins for exporting scenes to Unity, Unreal, and CARLA.

The latest plugins can be downloaded here.

The plugins are delivered as a zip file containing subfolders for each plugin type. Refer to the
following sections for details on installing and using a specific plugin.

Unity
See “Exporting to Unity” on page 7-38 for instructions on installing and using the plugin.

Unreal and CARLA
The basic RoadRunner importer and the CARLA integration plugin are included in the same plugin
folder. If you are using Unreal and not CARLA, copy only the "RoadRunnerImporter" folder.

See “Exporting to Unreal” on page 7-55 or “Exporting to CARLA” on page 7-63 for instructions on
installing and using the plugin.
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RoadRunner Metadata Export
RoadRunner includes an extra metadata file for certain export options.

Metadata Overview
When exporting to Unity on page 7-38, Unreal on page 7-55, or CARLA on page 7-63, an
additional ".rrdata.xml" file is generated during export. This file is used in combination with the
RoadRunner import plugins to help cover the information not available in the FBX file. The metadata
file holds information about the materials included in the scene and holds traffic signal information.
For examples on how to parse this information, refer to the Unity or Unreal plugins included with the
RoadRunner installation under the "Tools" folder.

File Details
The metadata file continues to update as needed. The metadata version is stored under the top-level
element (for example, <RoadRunnerMetadata Version="3">).

The data is organized into three main sections: SignalConfigurations, Signalization, and MaterialList.

SignalConfigurations

This section holds information about how the signal bulbs change for each configuration of a traffic
light (for example, which bulbs are on and off during a green light or red light).

Example:
<Signal>
    <ID>{9b15662e-0dae-40d5-ab82-55e0077bcbc2}</ID> // GUID of the signal asset
    <Type>Straight Right</Type>                     // Supported turn types
    <Configuration>                                 // Configuration entry
        <Name>Red</Name>                            // State name
        <LightState>                                // Light bulb mesh state
            <Name>light_red_on</Name>               // Name of the mesh node in the signal's FBX
            <State>true</State>                     // "true" if mesh should be visible
        </LightState>
        <LightState>
            <Name>light_red_off</Name>              // Light bulbs typically have a corresponding mesh node for when the light is off
            <State>false</State>
        </LightState>
        ...
    </Configuration>
    ...
</Signal>

Signalization

This section holds information about each traffic junction in the scene and how each signal changes
over time.

Example:
<Junction>
    <ID>{5c348c08-d2d7-423e-b560-04eb52ddcd10}</ID>                                 // GUID of the junction
    <SignalPhase>                                                                   // Each signal phase holds a list of intervals
        <Interval>                                                                  // Each interval represents the state of the junction (i.e. the northbound road currently has a yellow light)
            <Time>20</Time>                                                         // Duration of the interval
            <Signal>
                <ID>{d33d9030-c427-44ff-860b-486f3caf45b2}</ID>                     // GUID of the signal prop. This can be referenced to a node in the exported FBX
                <SignalAsset>{9b15662e-0dae-40d5-ab82-55e0077bcbc2}</SignalAsset>   // GUID of the signal asset. This can be referenced to the SignalConfigurations listed above
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                <ConfigurationIndex>2</ConfigurationIndex>                          // Index into the list of configurations held in the signal asset
            </Signal>
            <Signal>
                <ID>{00dd1cc3-9b68-44dd-bb20-a3e49452606f}</ID>                     // All signals attached to the junction are listed
                <SignalAsset>{9b15662e-0dae-40d5-ab82-55e0077bcbc2}</SignalAsset>
                <ConfigurationIndex>0</ConfigurationIndex>
            </Signal>
            ...
        </Interval>
        ...
    </SignalPhase>
    ...
</Junction>

MaterialList

This section contains a list of all the materials used in the scene, along with all the parameters so that
they can be reconstructed in the target software.

Example:
<Material>
    <Name>Asphalt1</Name>                                       // Name of the material, matches the one stored in the FBX
    <DiffuseMap>Asphalt1_Diff.png</DiffuseMap>
    <NormalMap>Asphalt1_Norm.png</NormalMap>
    <SpecularMap>Asphalt1_Spec.png</SpecularMap>
    <AmbientColor>1.000000,1.000000,1.000000</AmbientColor>     // Ambient color matches diffuse
    <DiffuseColor>1.000000,1.000000,1.000000</DiffuseColor>
    <SpecularColor>0.058824,0.058824,0.058824</SpecularColor>
    <Roughness>0.150000</Roughness>
    <SpecularFactor>1.000000</SpecularFactor>
    <TransparencyFactor>0.000000</TransparencyFactor>           // Inverse of diffuse color alpha
    <Emission>0.000000</Emission>
    <TextureScaleU>0.35</TextureScaleU>
    <TextureScaleV>0.35</TextureScaleV>
    <TwoSided>false</TwoSided>
    <DrawQueue>0</DrawQueue>                                    // Render order for overlapping transparent markings
    <ShadowCaster>true</ShadowCaster>
    <IsDecal>false</IsDecal>                                    // Set to "true" for transparent markings
    <SegmentationType>Road</SegmentationType>
</Material>

7 Exporting

7-32



Exporting to Apollo

Apollo Overview
RoadRunner can export road scenes to Baidu Apollo formats. You can export to Apollo 3.0 and 5.0
XML formats and Apollo 5.0 binary format.

Before you export to any Apollo format, ensure that your scene’s world origin is set in the “World
Settings Tool” on page 5-165. Once you are ready to export, navigate to File > Export > Apollo
(.bin, .xml) to open the export options window. Make sure you choose the appropriate Apollo version
before completing your export, and ensure that you specify the file extension (.xml or .bin) you
intend to export to. Exports to the binary format will include a human readable .txt representation
of the protobuf data serialized in the .bin counterpart.

About the Different Apollo Maps
Apollo’s Dreamview front-end tool can visualize and simulate routing on RoadRunner Apollo exports.
A complete map is composed of the following files for proper simulation:

• base_map.bin — A protobuf representation of HDMap information. The representation might be
accompanied with a human-readable .txt version.

• sim_map.bin — A downscaled version of base_map.bin used for faster visualization at runtime.
The file might be accompanied with a .txt version.

• routing_map.bin — Topological map information used for generating routes.
• default_end_way_point.txt — A start point for routing.

Given either a binary or XML export from RoadRunner, these files can be generated using various
tools provided by the Apollo codebase.

Generating Necessary Map Files

Note If you have not yet set up your Apollo Docker environment, follow this guide to do so.

Binary maps can be generated from XML by using the following command in the Apollo Docker
environment:

bazel-bin/modules/maps/tools/proto_map_generator --map_dir=INPUT_DIR
--output_dir=OUTPUT_DIR

INPUT_DIR is the name of the directory containing the XML file, and OUTPUT_DIR is the desired
output directory. Within the input directory, ensure the XML file is named base_map.xml before
running it. This will generate a binary file named base_map.bin and a text file version named
base_map.txt in the output directory specified.

With this .bin file or a .bin file exported directly from RoadRunner, a sim_map can be generated
with the following command:

bazel-bin/modules/maps/tools/sim_map_generator --map_dir=INPUT_DIR
--output_dir=OUTPUT_DIR
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Again, ensure that the .bin file is named base_map.bin before running it.

A routing map can be generated with the following command:

scripts/generate_routing_topo_graph.sh --map_dir=INPUT_DIR

More information about the different Apollo map types can be found here.

Visualizing Maps in Apollo Dreamview
Once you have all of the components for an Apollo map, you can visualize and simulate it in the
Dreamview front-end.

Create a folder for your map in apollo/modules/maps/data, and add all the map files to that
folder. Rename the folder to what you would like to appear in the Dreamview map selection drop-
down. Restart Dreamview to refresh the maps in your data folder.

Once Dreamview starts, select your newly added map and a test vehicle in the top-right corner.
Ensure that the standard mode is selected.

Go to the Tasks tab on the left, and enable Sim Control to render the map.

Routing Simulations in Apollo Dreamview
To run a road simulation in Dreamview, ensure that Routing is enabled in the Modules window. In
the routing window, define a route on the map by using at least two waypoints. Click Send Route
Request to run the simulation.

Visualizing Maps in LGSVL
LGSVL has the ability to import Apollo 5.0 binary files for editing and visualization.

Note If you have not yet set up LGSVL with Unity, follow this guide to do so.

To import an Apollo map into LGSVL, open the HD Map Import window under Simulator > Import
HD Map. Under Import Format, select Apollo 5 HD Map, and optionally modify the Distance and
Delta Threshold values. Click "..." to open the file browser and select the binary file export. Click
import to add the map to the scene.

More information about importing maps into LGSVL can be found here.

Apollo User Asset Configuration
The Apollo exporter uses a configuration XML file to map RoadRunner props, signals, signs, and
markings to the appropriate <object> or <signal> "id" and "subtype". This process works the same
way as the OpenDRIVE asset configuration.
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Exporting a Custom Prop or Signal

1 Copy the ApolloAssetData.xml file located in the RoadRunner install location under
AssetsInstall/ResourceAssets to the Project folder in your project (next to the
Project.rrproj file).

2 Open the new ApolloAssetData.xml file in a text editor.
3 Add entries for new objects, markings, or signals.
4 Save your file and export an Apollo file.

You do not need to restart RoadRunner after creating or modifying the ApolloAssetData.xml file.

The format of an ApolloAssetData.xml file is the same as the format of an
OpenDRIVEAssetData.xml file. For a detailed definition of this format, see “Exporting to
OpenDRIVE” on page 7-18. The template file in the AssetsInstall/ResourceAssets folder also
contains examples for a traffic light, stop sign, and yield sign.

Exporting a Traffic Signal with Multiple Variances

Here is the definition of the format to properly set a traffic signal’s asset data for different variances
and subsignals.

<Signals>
    <Signal>
        <Type>trafficLight</Type>
        <SubType>mix3Vertical</SubType>
        <SubSignals>
            <Variant>1</Variant>
            <SubSignal>
                <LightName>light_red</LightName>
                <Type>circle</Type>
            </SubSignal>
            <SubSignal>
                <LightName>light_yellow</LightName>
                <Type>circle</Type>
            </SubSignal>
            <SubSignal>
                <LightName>light_green</LightName>
                <Type>circle</Type>
            </SubSignal>    
        </SubSignals>
        <SubSignals>
            <Variant>2</Variant>
            <SubSignal>
                <LightName>light_red</LightName>
                <Type>arrowLeft</Type>
            </SubSignal>
            <SubSignal>
                <LightName>light_yellow</LightName>
                <Type>arrowLeft</Type>
            </SubSignal>
            <SubSignal>
                <LightName>light_green</LightName>
                <Type>arrowLeft</Type>
            </SubSignal>
        </SubSignals>
        <SubSignals>
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            <Variant>3</Variant>
            <SubSignal>
                <LightName>light_red</LightName>
                <Type>arrowRight</Type>
            </SubSignal>
            <SubSignal>
                <LightName>light_yellow</LightName>
                <Type>arrowRight</Type>
            </SubSignal>
            <SubSignal>
                <LightName>light_green</LightName>
                <Type>arrowRight</Type>
            </SubSignal>
        </SubSignals>
        <FilePath>Props/Signals/Signal_3Light_Post01.fbx</FilePath>
    </Signal>
</Signals>

Unsupported Features
The following data records are currently unsupported for export.

• Route View Record (<routeView> … </routeView> and its children)
• Lane Overlap Group (<laneOverlapGroup> … </laneOverlapGroup> and its children)

See Also
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Exporting to Metamoto
RoadRunner can export road scenes for use in Metamoto simulations. To export to Metamoto, follow
these steps:

1 Select File > Export > Metamoto.
2 Specify a file name. All other export options are set for exporting to Metamoto.

When you export, the software generates a zip file containing the files needed to use your scene
in Metamoto. These zipped files have the same name you specified when exporting. For example,
MyScene.zip would contain:

• MyScene.fbx (and any other necessary texture files)
• MyScene.xodr
• MyScene.geojson
• MyScene.rrdata.xml

For any limitations, refer to the documentation about exporting to FBX on page 7-3, OpenDRIVE® on
page 7-18, and GeoJSON on page 7-13.

See Also

External Websites
• https://www.metamoto.com/
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Exporting to Unity

Unity Overview
RoadRunner can export scenes to Unity format. The Unity export option exports a Filmbox (.fbx) file
containing the 3D objects in a scene along with an additional XML file to hold extra data for materials
and traffic signals in the scene.

On the Unity side, a set of scripts are included in the RoadRunnerUnityTool asset package to help
import the FBX file using the information stored in the XML file. The script handles the following
details:

• Setting up materials

• Material data is read in from the XML file and mapped into the included custom shaders.
• Adding colliders to roads and terrain

• Colliders are added to all imported meshes.
• Setting up the components of traffic signals

• Signal data is read in from the XML file to create a new game object in the prefab, with the
light bulb references to game objects set up during import.

• The traffic signals will cycle through their phases during play mode.
• The UUIDs prefixed in the game object for prop instances are needed only at import time to set

up references to game objects in the traffic signal script so that they can be renamed freely.
• Unity software requirements: Unity Version 2017.3+

Installing the Import Tool
Follow the instructions in this section to install the Import Tool into your Unity project.

1 See the page “Downloading Plugins” on page 7-30 for instructions for downloading the latest
version of the plugin.

2 Extract the RoadRunner Plugins zip file and locate the "RoadRunnerUnityTool.unitypackage" file
in the "Unity" folder.

3 Open your project in Unity.
4 Open the RoadRunnerUnityTool asset package file to import it. Alternatively, drag the package

file into the Unity Project window, or select

Assets > Import Package > Custom Package and then select the package file.
5 Click Import in the Import Unity Package dialog box.
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Selecting Package Files to Import

The package includes some extra files to add a drivable vehicle to your scene. If you do not need
these extra files, then you can deselect them when you import the package.

The essential scripts inside the "RoadRunner" folder are needed to set up the materials and traffic
signals in the scene.
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Package Contents

• Models: Mesh, materials, and textures for the drivable car prefab.
• Prefabs: The prefab for the car with scripts set up.
• RoadRunner:

• ImportWindow.cs: Editor window to display messages for the RoadRunner importer.
• RoadRunnerImporter.cs: Editor script for importing the FBX file with the data from the XML
file.

• Metadata.cs: Contains classes to hold the imported metadata XML file.
• TrafficJunction.cs: Component for controlling signals from data in the XML file at import time.
• Various shaders to match RoadRunner material settings.

• Scripts: For the Sedan prefab.
• Standard Assets: For the Sedan prefab.

Exporting from RoadRunner to Unity
Follow these steps to export a scene from RoadRunner to Unity:

1 Open your scene in RoadRunner.
2 Export the scene to Unity format using File > Export > Unity (.fbx + .xml) from the Main

Menu.
3 In the Export Unity dialog box, set your desired options, and then click Export.
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4 Browse to open the file dialog box to set the exported file's name and path. The textures and the
XML file are exported to the same folder. (Tip: Create a new folder when choosing a file location,
so you can import the entire folder into Unity.)

• The mesh can be split by segmentation type. Meshes have "<segmentation type>Node" appended
to their names.

• If the Export To Tiles option is selected, meshes are split per tile. Props are grouped by the tile
they are in.

• By default, only one file is exported. Tiles are stored in separate nodes.
• If Export Individual Tiles is enabled, each tile will be stored in its own FBX file.

• When exporting with Embed Textures selected, you need to manually extract the textures inside
Unity.
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Importing into Unity
To import a scene into Unity that you previously exported from RoadRunner, drag all the exported
files (or the entire folder) into the Unity project window. Alternatively, use Assets > Import New
Asset in Unity and select all the exported files.

The output window that opens contains log messages from the import plugin.

(Optional) Test Drive in Unity

You can place and drive a car model around an imported scene by following these steps:

1 Drag the Sedan prefab from the Prefabs folder into the scene. (Note: In some versions of Unity,
you might need to manually tag the Main Camera as "MainCamera" for some scripts to work.)
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2 Click Run.

About Importing Traffic Signals into Unity

If traffic signals were set up in RoadRunner, then they are imported into Unity as junction controllers.
These controllers are automatically created during import and attached to the prefab.

Prop instances for traffic signals are prefixed by their UUID so that the traffic signal controller has a
way to identify which signals it controls. The TrafficJunction script handles the logic for switching
between signal states.

FBX details

The FBX file is identical to the one exported from the Filmbox export option. The only difference is
the extra rrdata.xml metadata file.

Setting Up the Sample Vehicle
The RoadRunnerUnityTool unitypackage also includes the RoadRunner Sedan 3D model. This section
covers how to set it up with Unity Standard Assets.

Note The following section was tested on Unity 2019.1. Older versions might require different steps
to modify prefabs.

Adding the Standard Assets

1 Download the "Standard Assets (for Unity 2017.3)" package from the Unity Asset Store.
2 Select the following folders to import:

• "Standard Assets/Cameras"
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• "Standard Assets/CrossPlatformInput/Scripts"
• "Standard Assets/Editor/CrossPlatformInput"
• "Standard Assets/Vehicles/Car"

3 Import the package by clicking Import.

Setting Up the Sedan Prefab

1 Select the Sedan prefab (located in "Assets/Prefabs") and click Open Prefab in the Inspector
window.
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2 For each Wheel Hub Game Object under "Sedan/WheelsHubs" (for example,
"WheelHubFrontRight"), complete these steps:

a Add the "Wheel Effects" component.

• Set the "Skid Trail Prefab" to the "SkidTrail" Prefab (located in "Assets/Standard Assets/
Vehicles/Car/Prefabs").

b Set the Audio Source's "AudioClip" to the "Skid" sound effect if it is missing.
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3 Select the top level "Sedan" game object in the hierarchy window.
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a Add the "Car Controller" component with the following settings.
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To avoid errors, verify that the order of the wheels is correct.
b Add the "Car Audio" component with the following settings.
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c Add the "Car User Control" component.

4 Select the "light_brakes" game object.
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a Add the "Brake Light" component and set the "Car" property to the top level "Sedan" game
object.

5 Select the "ParticleBurnoutSmoke" game object.
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a Enable the game object.
b Set the Particle System component's Renderer Material property to "ParticleSmokeWhite".
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6 Exit Prefab edit mode.
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Setting Up the Camera

1 Delete any existing cameras in the scene.
2 Add the Sedan prefab to the scene.
3 Add the "MultipurposeCameraRig" prefab (located in "Standard Assets/Cameras/Prefabs") to the

scene with the following settings.

Running the Scene

Add in an imported RoadRunner scene and click play to drive around in it.
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Exporting to Unreal

Unreal Overview
RoadRunner can export scenes to Unreal. The Unreal export option exports a Filmbox (.fbx) file and
generates an additional XML file to hold extra data. The XML file holds data for materials and traffic
signals in the scene.

On the Unreal side, a plugin is provided to help import the FBX file by using the information stored in
the XML file. The plugin handles the following:

• Setting up materials

• Material data is read in from the XML file and maps the data into new instance of one of the
base materials included with the plugin.

• Transparent materials will choose between the translucent and masked blend modes based on
the transparency of the diffuse color.

• Adjusting the colliders in the imported static meshes

• During import, newly created static mesh assets have their "Collision Complexity" property set
to "Use Complex Collision As Simple".

• Setting up the traffic signal components:

• Signal data is read in from the XML file and creates a component in the blueprint with the light
bulb names set up during import.

• The traffic signals will cycle through their phases during play mode.
• The UUIDs prefixed in the scene components for prop instances are needed to reference the

static mesh component in the traffic signal script during play mode, so signals will not work if
their names are changed.

• Unreal software requirements: Unreal Version 4.17+

Installing the Plugin
Follow the instructions in this section to install the Unreal plugin.

1 See “Downloading Plugins” on page 7-30 for instructions for downloading the latest version of
the plugin.

2 Extract the RoadRunner Plugins zip file and locate the "RoadRunnerImporter" folder and
"RoadRunnerMaterials" folders under "Unreal/Plugins".

Note  The Unreal plugin folder now also contains a RoadRunnerCarla integration plugin. Do not
copy this folder if you are not using CARLA.

3 Copy the "RoadRunnerImporter" folder and "RoadRunnerMaterials" folder into the "Plugins"
folder under the project directory. If a "Plugins" folder does not exist, create one.
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4 Rebuild the plugin.

a Generate the project files.

• Windows - Right-click the .uproject file and select "Generate Visual Studio project files."
• Linux - Run this code at the command line:

$UE4_ROOT/GenerateProjectFiles.sh -project="<Path to .uproject file>" -game -engine

Set UE4_ROOT to your Unreal Engine install directory.
b Open the project and build the plugins by clicking Yes.

5 The plugin shows up under Edit > Plugins. If it does not appear in that menu, check that the
Enabled parameter is selected.

Plugin Contents

• RoadRunnerImporter module:

• Overrides the default FBX importer when the metadata file is present
• Option to overwrite default materials with new materials using the metadata file
• Import signal data and timing

• RoadRunnerRuntime module:

• Contains component to control traffic signal visuals
• RoadRunnerMaterials plugin:
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• Base materials to create instances from

Exporting from RoadRunner to Unreal
Follow these steps to export a scene from RoadRunner to Unreal:

1 Open your scene in RoadRunner.
2 Export the scene using the Unreal option. Select File > Export > Unreal (.fbx + .xml) from the

Main Menu.
3 In the Export Unreal dialog box, set the mesh merging and tiling options, and then click Export.

4 Browse to open the file dialog box to set the exported file's name and path. The FBX, textures,
and XML files are exported to the same folder.

• The mesh can be split by segmentation type. Meshes have "<segmentation type>Node"
appended to their names.

• If the Export To Tiles option is selected, meshes are split per tile. Props are grouped by the
tile they are in.

• By default, only one file will be exported. Tiles will be stored in separate nodes.
• If Export Individual Tiles is enabled, each tile will be stored in its own FBX file.
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Importing into Unreal
There are multiple ways to import the scene into Unreal:

• Drag the file into the Content Browser.
• Use the "Import" button and select the FBX file.

The plugin checks if there is a RoadRunner XML file associated with the imported file and imports as
normal if a corresponding XML file is not found.

Selecting File > Import Into Level does not use the exported RoadRunner XML and uses the Unreal
importer instead.

Prop Instances are prefixed by their UUID so that the traffic signal controller has a way to identify
which signals it controls.

When the RoadRunner Import Options Dialog Box Opens

• Overwrite Materials

• Overrides the default material importing
• Needs to be unchecked if you want to set the materials to "Use Existing" in the next dialog box

• Import Signal Visuals

• Functional only when "Create one Blueprint asset" is selected in the next dialog box

When the FBX Scene Import Options Dialog Box Opens:

1 Set Scene > Hierarchy Type to "Create one blueprint asset" (selected by default).

Note  Only the "Create one Blueprint asset" import option works with materials, signals, and
transparency sorting. The "Create one Actor with Components" and "Create Level Actors"
options import only materials.

2 Select Invert Normal Maps if needed.
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3 Set Static Meshes > Normal Import Method to "Import Normals".

4 (Optional) Clear the Remove Degenerates parameter, which can help for some props created in
a larger scale.

5 Click Import.
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About Importing Traffic Signals into Unreal

If traffic signals were set up in RoadRunner, they are imported into Unreal as
RoadRunnerTrafficJunction components. These controllers are automatically created during import
and included in the created blueprint.

The RoadRunnerTrafficJunction component handles the logic for switching between signal states.
UUIDs are used to match to specific game objects in the scene.

FBX Details

The FBX file automatically splits the mesh by transparency sorting layer. This is due to Unreal storing
"Translucency Sort Priority" on the static mesh component.

sRGB Textures

Unreal Engine does not support 16-bit sRGB textures. Therefore, textures appear to be washed out,
unless the texture files are converted to 8-bit sRGB textures.

Large Scene Optimizations

Using the "Create one Actor with Components" option can be more efficient. However, signals will not
be set up.

Importing Without the Plugin
This section covers fixes handled automatically by the RoadRunner plugin.

Fix Stretched Textures

Meshes with UV coordinates far away from the 0 to 1 range can cause issues in Unreal. On Static
Mesh assets with this issue, the "Use Full Precision UVs" option can be set to fix it.
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Fix Objects Floating Above the Road

Static Mesh assets need to have their Collision Complexity property set to "Use Complex Collision As
Simple". Otherwise, collision boxes need to be manually added.
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Exporting to CARLA

CARLA Export Overview
RoadRunner can export scenes to the CARLA simulator. The CARLA export option exports a Filmbox
(.fbx) file, an XML for some metadata, and an OpenDRIVE (.xodr) file. The XML file holds data for
materials in the scene.

On the CARLA or Unreal side, a plugin is provided to help import the FBX file by using the
information stored in the XML file. The plugin handles the following:

• Setting up materials

• Material data is read in from the XML file and maps the data into a new instance of one of the
base materials included with the plugin.

• Certain materials will instantiate from one of the CARLA materials.
• Transparent materials will choose between the translucent and masked blend modes based on

the transparency of the diffuse color.
• Adjusting the colliders in the imported static meshes

• During import, newly created static mesh assets have their "Collision Complexity" option set to
"Use Complex Collision As Simple".

• Setting up the traffic signal visuals

• Traffic signal logic is not hooked up to the simulator.
• Software requirements

• Unreal Version 4.21+
• CARLA 0.9.5 built from source

Installing the Plugins
Follow the instructions in this section to install the Unreal plugin:

1 See “Downloading Plugins” on page 7-30 for instructions for downloading the latest version of
the plugin.

2 Extract the RoadRunner Plugins zip file and locate the "RoadRunnerImporter",
"RoadRunnerCarlaIntegration", and "RoadRunnerMaterials" folders under "Unreal/Plugins".

3 Copy the "RoadRunnerImporter", "RoadRunnerCarlaIntegration", and "RoadRunnerMaterials"
folders into the "Plugins" folder under the CarlaUE4 project directory, located at <carla>/Unreal/
CarlaUE4/Plugins (next to the "Carla" folder).
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4 Rebuild the plugin.

a Generate the project files.

• Windows - Right-click the .uproject file and select "Generate Visual Studio project files."
• Linux - Run this code at the command line:

$UE4_ROOT/GenerateProjectFiles.sh -project="<Path to Carla folder>/Unreal/CarlaUE4/CarlaUE4.uproject" -game -engine

Set UE4_ROOT to your Unreal Engine install directory.
b Open the project and build the plugins by clicking Yes.

5 The plugin shows up under Edit > Plugins. If it does not appear in that menu, check that the
Enabled check box is on.
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Plugin Contents

• RoadRunnerImporter module:

• Overrides the default FBX importer when the metadata file is present
• Option to overwrite default materials with new materials using the metadata file
• Import signal data and timing

• RoadRunnerRuntime module:

• Contains component to control traffic signal visuals
• RoadRunnerCarlaIntegration module:

• Creates a new map and imports the FBX into the level
• Moves static mesh assets based on segmentation type
• Creates materials instantiated from CARLA materials for weather effects
• Generates the routes from the OpenDRIVE file

• RoadRunnerMaterials plugin:

• Base materials to create instances from

Exporting from RoadRunner to CARLA
Follow the steps below to export a scene from RoadRunner to Unreal:

1 Open your scene in RoadRunner.
2 Export the scene using the CARLA option. Select File > Export > CARLA (.fbx + .xml + .xodr)

from the Main Menu.
3 In the Export CARLA dialog box, set the mesh tiling on the FBX tab and the OpenDRIVE options

on the OpenDRIVE tab as needed. Then, click Export.
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4 Browse to open the file dialog box to set the exported file's name and path. The FBX, textures,
XML, and OpenDRIVE files are exported to the same folder.

• The mesh can be split by segmentation type. Meshes have "<segmentation type>Node"
appended to their names.

• If the Export To Tiles option is selected, meshes are split per tile and props are grouped by
the tile they are in.

• By default, only one file is exported. Tiles are stored in separate nodes.
• If Export Individual Tiles is enabled, each tile is stored in its own FBX file.

Note  The plugin does not fully support the Export Individual Tiles option.
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Importing into CARLA/Unreal
There are multiple ways to import the scene into Unreal for use with CARLA.

• Drag the file into the Content Browser.
• Use the "Import" button and select the FBX file.

The plugin checks if there is a RoadRunner XML file associated with the imported file, and imports as
normal if a corresponding XML file is not found.

Selecting File > Import Into Level does not use the exported RoadRunner XML and uses the Unreal
importer instead.

When the RoadRunner Import Options Dialog Box Opens

• Overwrite Materials

• Overrides the default material importing. Instances from CARLA materials for roads and
foliage.

• Needs to be unchecked if you want to set the materials to "Use Existing" in the next dialog box.
• Import Signal Visuals

• Only functional when the "Create one Blueprint asset" option is selected in the next dialog box.

Note  The Importing Signal Visuals option does not have any effect on the traffic simulation.

When the FBX Scene Import Options Dialog Box Opens

1 Set Scene > Hierarchy Type to "Create One Blueprint Asset" (selected by default).

Note  Only the "Create one Blueprint asset" import option works with materials, signals, and
transparency sorting. The "Create one Actor with Components" and "Create Level Actors"
options import only materials.
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2 Select Invert Normal Maps, if needed.

3 Set Static Meshes > Normal Import Method to "Import Normals".

4 (Optional) Uncheck Remove Degenerates, which can help for some props created in a larger
scale.
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5 Click Import.

About Importing Traffic Signals into Unreal

If traffic signals were set up in RoadRunner, they are imported into Unreal as
RoadRunnerTrafficJunction components. These controllers are automatically created during import
and included in the created blueprint.

The RoadRunnerTrafficJunction component handles the logic for switching between signal states.
UUIDs are used to match to specific game objects in the scene.

FBX Details

The FBX file will automatically split the mesh by segmentation and transparency sorting layer due to
the following:

• Segmentation: CARLA determines segmentation by static mesh assets.
• Transparency sorting: Unreal stores the "Translucency Sort Priority" value on the static mesh

component.

Testing the map

1 Click Play in the editor (the first time you click Play takes extra time to build the map).

2 Run the example Python® scripts.
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Creating Map Packages for Distribution (CARLA 0.9.5)

Note  Some steps in CARLA have changed since the 0.9.5 release of CARLA, but the same concepts
should apply if there are issues.

Exporting the Map
1 Import the FBX into UE4 by using the plugin.
2 Run this command: make export-maps ARGS="--file=<map name>"
3 If the map uses RoadRunner materials, you will likely get a missing material error when trying to

run the executable. Follow the steps in the next section if this issue occurs.

RoadRunner Material Workaround

Since CARLA scripts do not copy the RoadRunner plugin "Content" folder, they need to be generated
and copied manually to the distribution build.

1 In UE4, open the packaging settings under File > Package Project > Packaging Settings.

a Uncheck "Use Pak File".
b Add the map you want to package to the "List of maps to include in a packaged build."

2 Run this command: make package
3 Copy the cooked plugin content (located at <carla>/Dist/0.9.5-dirty/LinuxNoEditor/CarlaUE4/

Plugins/RoadRunnerImporter) to the desired location.
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Note  This procedure generates only the materials used in the included maps.
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Exporting to VTD
RoadRunner has a combination exporter for exporting scenes to VIRES Virtual Test Drive (VTD)

RoadRunner provides a VTD export option that exports an OpenDRIVE® (.xodr) file for the road
network and an OpenSceneGraph (.ive) file for the visual scene.

Exporting to VTD
From the menu, select File > Export > VTD (.xodr + .ive).

Export Options (OpenDRIVE)
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Export Options (OpenSceneGraph)

Split by Segmentation

This option will split meshes by their segmentation type on page 3-9.

Tiling

The Export To Tiles option splits the meshes per tile. This parameter also groups props by the tile
they are in.

• By default, only one file is exported. Tiles are stored in separate nodes.
• VTD does not support scenes tiled to separate files.
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Importing into VTD
Once exported from RoadRunner, the scene can be imported into VTD.

1 (Optional) Convert the OpenSceneGraph IVE file to an OSGB file by using OpenSceneGraph
version 3.2.3.

2 Copy the exported files (OpenDRIVE and IVE files) to your current project in the Databases
folder. Placing the files in a separate folder is recommended.

3 Open VTD.

4 Open ScenarioEditor and click New.
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5 Click the Properties button.
6 Select the location of the Layout File (OpenDRIVE) and Visual Database (IVE).

7 Insert at least an Ego vehicle.
8 Save the scenario.
9 Select the scenario in VTD.
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10 Run the scenario.

Limitations
Refer to “Exporting to OpenSceneGraph” on page 7-10 for further details on limitations.
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RoadRunner Tips and Tricks

• “Graphics and Startup Issues” on page 8-2
• “Obtain RoadRunner Log Files” on page 8-6
• “Camera Movement in Linux or Ubuntu” on page 8-7
• “Resolve Triangulation Issues in Junctions” on page 8-8
• “Decompress LAZ Files” on page 8-10
• “GIS Data Resources for RoadRunner” on page 8-13
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Graphics and Startup Issues

System Requirements
RoadRunner is primarily a 3D graphics application. It requires a graphics card with support for
OpenGL version 3.2 or higher.

Check that your system meets the minimum RoadRunner System Requirements on page 1-3.
RoadRunner might still work with some lower specification system version, but you might experience
poor performance.

Graphics Drivers
If you are experiencing rendering issues or crashes on startup, check to make sure that you are
running the latest graphics drivers for your system. Some computer manufacturers install custom or
unstable drivers. Windows Update has also been known to automatically install problematic graphics
drivers.

Downloading drivers directly from your graphics card manufacturer is recommended. Common
graphics card manufacturers include:

• NVIDIA (drivers download page)
• AMD (drivers download page)
• Intel (drivers download page)

On Linux, if your graphics card manufacturer does not supply drivers for Linux, try updating your
Mesa graphics drivers.

If you are unsure which type of graphics card you have, you can often determine that by visiting your
computer manufacturer's web page and searching for drivers for your system. This search usually
involves entering a model (or serial) number or installing an autodetection application.

On Windows, you can determine which graphics cards you have installed by following these steps:

1 Click the Start button and type Run.
2 Type dxdiag and press Enter.
3 Inspect the Name and Manufacturer on the Display tabs. You might have multiple graphics

cards installed, so inspect each listed Display tab.
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Laptops
RoadRunner can run on laptops with sufficiently powerful graphics cards. Newer laptops with low-
powered graphics cards (such as Intel embedded graphics chips) might still be able to run
RoadRunner acceptably.

To conserve battery life, modern laptops often have two graphics cards, for example, higher-powered
NVIDIA graphics combined with lower-powered Intel embedded graphics. In these cases,
RoadRunner requests to use the higher-power graphics card, but there is no guarantee that your
system will obey that request.

If your laptop has multiple graphics cards (often true if your laptop advertises an NVIDIA or AMD
graphics cards), then it is recommended that you check that your system provides the higher-power
graphics card to RoadRunner.

The steps for this process differ depending on the laptop manufacturer, graphics driver, and other
factors. For additional help, see these links:

• https://www.techadvisor.co.uk/how-to/pc-components/how-set-default-
graphics-card-3612668/

• https://www.nvidia.com/content/Control-Panel-Help/vLatest/en-us/
mergedProjects/nv3d/Manage_3D_Settings_(reference).htm (see "Program Settings"
section; for RoadRunner, select the high-performance NVIDIA processor option)

Remote Desktops
If you are using RoadRunner while connected to a remote desktop, you might encounter performance
issues. To resolve these issues, consider using one of these options.

NVIDIA Remote Desktop Acceleration

If you are using Microsoft® Remote Desktop on newer NVIDIA GeForce drivers, follow the procedure
described in the "Accelerate Windows Remote Desktop" section of https://
developer.nvidia.com/designworks.
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Chrome Remote Desktop

Chrome™ Remote Desktop from Google® provides a solution for remote access that supports newer
OpenGL applications. For details, see https://remotedesktop.google.com/.

Video Card Connection
On desktops, you might also want to check that your monitor is connected to a video card, rather
than to a low-powered graphics card (also called "onboard" or "integrated" graphics). Trace your
monitor cable to make sure that it is not plugged into the built-in graphics port, but rather into a
video card in one of the expansion slots.
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Further Support
If the previous information does not resolve your issue, report your issue to MathWorks Technical
Support. It is helpful to include your log files. For more details, see “Obtain RoadRunner Log Files”
on page 8-6.
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Obtain RoadRunner Log Files
While debugging RoadRunner issues, MathWorks Technical Support might request your RoadRunner
log files. You can also use log files to try debugging issues yourself.

Log files include all messages printed to the “Output Panel” on page 2-25.

Locate Log Folder
To locate log files in Windows, click Start, and then type:

%appdata%\MathWorks\RoadRunner\<release version>\Logs

To locate log files in Linux, navigate to this folder:

~/.local/share/MathWorks/RoadRunner/<release version>/Logs

Provide Log File Contents to MathWorks Technical Support
1 Locate the log folder (see previous section).
2 Zip (or tar) the contents of the log folder.
3 Attach the zip file to a new or existing ticket for MathWorks Technical Support.
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Camera Movement in Linux or Ubuntu
To move the RoadRunner camera, you need to press and hold the Alt or Windows/Command key. In
Ubuntu 16.04, however, pressing the Alt key moves the current window, and pressing the Windows/
Command key shows certain help overlays. It is recommended that you update Ubuntu to use the
Windows/Command key (instead of the Alt key) for moving windows. To make this update, follow
these steps:

1 Install dconf-editor (if not already installed). At the command line, enter this code:

sudo apt-get install dconf-editor
2 Open dconf-editor.
3 Navigate to org > gnome > desktop > wm > preferences.
4 Change the mouse-button-modifier to <Super>.

Note It is important to assign a valid key to mouse-button-modifier. Leaving that option blank
prevents the mouse from interacting with any windows.
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Resolve Triangulation Issues in Junctions
In RoadRunner, a junction represents the complex intersection of multiple roadways, defining a space
where multiple surfaces compete for influence over the junction's final surface representation. Even
in simple intersections, roads can vary by width, length, bank angle, and elevation. Roads also vary by
features such as medians, curbs, and sidewalks, which need to be gracefully clipped from the final
result. The goal of RoadRunner software is to unify these overlapping regions into a single
representation suitable for simulation use cases. This unification often requires triangulating the
junction surface to export into various formats. This task is nontrivial and can often lead to
undesirable artifacts in the final junction triangulation.

To avoid common triangulation issues, use these tips.

Adjust Road Elevations
RoadRunner continually detects overlaps with neighboring roads and automatically creates junctions
for any roads which overlap within 2 vertical meters. However, given that each road is fully
independent, it is possible to create intersections that vary in grade, which can cause undesirable
triangulation artifacts. One way to resolve this issue is to adjust road elevations to match as closely as
possible within the junction.

From within the “Road Plan Tool” on page 5-108, the RoadRunner 2D Profile editor displays all
overlapping roads for any selected road. You can use the tool to raise or lower any road to match the
height of other roads by selecting and dragging either the height profile nodes or spans. Dragging a
span is equivalent to dragging the nodes on either end.

Bank Roads
When two or more roads that intersect have different slopes, the intersections might need to be
banked to better align the road surfaces. The RoadRunner “Cross Section Tool” on page 5-24 offers
an interface to adjust road bank at lane boundary locations. To use this tool, select the road you want
to edit, select a cross section, and adjust the banking by using the 2D Cross section editor window.
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Use Slip Connections
RoadRunner offers a way to enforce height constraints between roads that have a dependent
relationship, such as a freeway and a freeway offramp. By creating slip roads, the end height and
slope of the slip road is constrained to that of the master road. To build a slip road, use the “Slip Road
Tool” on page 5-146 to pull a slip road off of any other road in your scene.
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Decompress LAZ Files
RoadRunner software does not support some LAZ files, resulting in this error: "The LAZ schema
is not recognized". To resolve this issue, you can decompress the LAZ file into an LAS file.

Decompression Process
1 To get started, on Windows, get the latest version of LASzip (found here). To get started on Linux,

build an executable for your operating system.
2 For both operating systems, run the LASzip executable.

Tip LASzip can sometimes have strange behavior when clicking or selecting in the interface. To
fix this issue, try maximizing the LASzip window or increasing the window size.

3 Click browse.

4 Find the desired LAZ file on your system. You can go to a specific directory using the directory
field and clicking go.
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Tip To add multiple LAZ files, you can use the wildcard field to specify which types of files to
add. Then click add. This action adds all the files fitting that wildcard in the currently browsed
directory.

5

6 Adjust settings for output and processor usage in the upper-right corner of the window. Then
click Decompress.
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7 Click Start to run the decompression.

8 Once the RUN window closes, the decompression is complete. Assuming default settings, you can
find your LAS files beside your LAZ files in the same directory.
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GIS Data Resources for RoadRunner

Importing GIS Data in RoadRunner
After you obtain geographic information systems (GIS) data, the process for importing the data into
RoadRunner is the same as importing any other data, regardless of where the data was obtained.

RoadRunner supports a multitude of different formats. Refer to the documentation for lists of
supported formats for each type of GIS data. The most common file formats are:

• Raster data (satellite imagery and elevation), such as GeoTIFF and JPEG 2000
• Lidar data, such as LAZ and LAS

USGS
The U.S. Geological Survey (USGS) provides freely available GIS data1 for much of the United States.
Coverage and quality varies depending on the data type and location.

The table shows USGS interfaces from which you can access GIS data.

Interface Link Interface Description
https://viewer.nationalmap.gov/basic/ Basic National Map explorer interface (preferred)
https://viewer.nationalmap.gov/advanced-viewer/ Advanced National Map explorer interface
https://earthexplorer.usgs.gov/ Earth Explorer interface

Each interface has a different user interface (UI) for selecting locations and data sets, and the
different interfaces can contain different data sets. When finding data for a specific project, checking
all the USGS interfaces is recommended.

For example, to download data from the Basic National Map explorer interface:

1 Find your area of interest by using the interface on the right.
2 Select one or more data sources on the left. The "Show Availability" links display the coverage of

a given data source.

• For elevation data, select "Elevation Products" (a 1/9 arc-second is recommended, but that
option is not available in all locations).

• For lidar data, select "Elevation Source Data" (lidar point cloud (LPC) option).
• For imagery data, select "Imagery - NAIP Plus."

3 Click "Find Products", and then click the "results" links to view the download links.
4 Use the download links to obtain data. Some data might require downloading multiple tiles to

cover your area of interest.

1. Credit: U.S. Geological Survey
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RoadRunner Asset Library Product Description
Populate RoadRunner scenes with a library of 3D models

RoadRunner Asset Library is a set of 3D models and assets for 3D scenes created with RoadRunner.
The library provides hundreds of models, including road and highway signs, traffic signals, road
surface markings, trees, barriers, and road damage textures, such as cracks and oil spills. All models
are professionally designed and visually consistent.
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RoadRunner Scene Builder Product Description
Automatically generate 3D road models from HD maps

RoadRunner Scene Builder imports and automatically synthesizes 3D road models from HERE HD
Live Map road data. You can visualize and edit the road models in RoadRunner, adding trees, streets,
road signs, and other elements to create 3D scenes.

The 3D road models can be exported to OpenDRIVE, FBX, glTF™, OpenFlight, OpenSceneGraph, OBJ,
and USD formats. The exported scenes can be used in automated driving simulators and game
engines, including CARLA, VIRES VTD, NVIDIA DRIVE Sim, Metamoto, LGSVL, Baidu Apollo, Unity,
and Unreal Engine.
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